Download it now!
Bug 30853 - Crash when running a specific macro in documents.
Summary: Crash when running a specific macro in documents.
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Noel Power
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 23:36 UTC by Yifan Jiang
Modified: 2013-11-23 13:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test data (19.80 KB, application/vnd.ms-excel.sheet.macroenabled.12)
2010-10-13 23:36 UTC, Yifan Jiang
Details
test data (19.14 KB, application/vnd.ms-excel.sheet.binary.macroEnabled.12)
2010-10-13 23:38 UTC, Yifan Jiang
Details
crash stack (90.00 KB, application/x-tar)
2010-10-13 23:40 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-13 23:36:21 UTC
Created attachment 39426 [details]
test data

Platform: SLED 10 sp3
build info: LibreOffice 3.2.99.1a with VBA patch

[Steps]

    1. Open the attached vba-project.xlsm or vba-project.xlsb

    2. Run document embedded macro MyUserForm:
    
        Tools->Macro->Run Macro...->vba-project.xlsm->Standard->MyUserForm->Run

[Problem]

    LibO crashes after clicking Run
      
[Extra Information]

    This is a regression against build without VBA patch.
Comment 1 Yifan Jiang 2010-10-13 23:38:56 UTC
Created attachment 39428 [details]
test data
Comment 2 Yifan Jiang 2010-10-13 23:40:15 UTC
Created attachment 39431 [details]
crash stack
Comment 3 Noel Power 2010-10-15 06:33:25 UTC
hmm this is a strange one, the trace indicates this is a duplicate of bug #30856. But... since I don't have the vba build you tested with but the latest master ( which includes the same fixes ) I indeed see a crash... however I also see the same crash in Openoffice-m10 :-/ So..
a) I think this bug is a duplicate but now in the recent builds we still have a crash ( but for a different reason :-) ) so we keep the bug!!! 

anyway I will try to fix this
Comment 4 LeMoyne Castle 2010-10-15 15:58:29 UTC
Just completed clean build of 3.2.99.2 for Lucid (Ubuntu 10.4) on a fresh new build setup pulled up to current as of ~5-6PM UTC 10/15 - when I pulled Noel's fix of previous VBA patch.    
Did source ooenv and ./soffice in target dir - LibO came up fine.
First thing I tried was to make a new macro in Calc ...
soffice crashes upon attempt to create a new macro upon selection in Macro Organizer - 
on click of Edit (macro in Standard Library - outside doc) 
on click of New (macro in document). 

Upshot:  Same or similar crash also happening with creation of new macro in dev build. 

Will test current Beta (2?) installer later in Vista and Lucid as part of studying behavior of install towards existing OO macros (if any) per previous request in dev mail list.
Comment 5 LeMoyne Castle 2010-10-15 16:41:35 UTC
Quick additional test: 
Can do other things in dev build like type, edit and change fonts and save.  
Can also record a macro with the macro recorder and save it in Doc or Standard.
But same 'fast exit' as in macro creation when I try to edit the macro by selection of macro + click Edit in Macro Organizer.
Comment 6 Noel Power 2010-10-16 06:05:44 UTC
(In reply to comment #4)
> Just completed clean build of 3.2.99.2 for Lucid (Ubuntu 10.4) on a fresh new
> build setup pulled up to current as of ~5-6PM UTC 10/15 - when I pulled Noel's
> fix of previous VBA patch.    

please open a new bug for this ( and a stack trace would be nice ) also exact steps to reproduce. 
I am totally convinced that this is a seperate bug 'cause this bug specifically relates to a error in the basic runtime ( whereas what you describe seems to be something to do with the IDE ). Funny though I cannot reproduce this ( but my build is at the state of the repos when I made the pushes associated with this bug ( with the exception of the the changes to fix the compile error ). Even running with valgrind raising the Macro Organizer, creating new and pressing edit to edit existing macros does not cause any problems :-/ I'll try again with a fresh build ( assuming master builds )

I am closing this bug.
Comment 7 LeMoyne Castle 2010-10-24 13:05:03 UTC
Did not open additional bug about crash on opening macro editor (Basic IDE) because the behavior stopped after subsequent pull.  The crash was consistent on 10-15 but has not occurred in recent builds after pulling to get to dev master HEAD.  Not occurring in Win Vista install of Beta2 as of today (10-24).
Comment 8 sophie 2010-11-01 11:33:50 UTC
Verified in 10_10_28_Cedric.rpm build - Closing - Sophie