Download it now!
Bug 30857 - The File-Properties set could not reflect to corresponding document fields.
Summary: The File-Properties set could not reflect to corresponding document fields.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) All
: medium normal
Assignee: Noel Power
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 00:05 UTC by Yifan Jiang
Modified: 2013-02-05 14:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test data (10.25 KB, application/vnd.sun.xml.writer)
2010-10-14 00:05 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-14 00:05:07 UTC
Created attachment 39433 [details]
test data

Platform: SLED 10 sp3
build info: LibreOffice 3.2.99.1a with VBA patch

[Steps]

    1. Open the attached sxw file, set User data in
    Tools->Options->User Data, say set a random First/Last Name
    etc.

    2. File->Properties, check on 'Apply User Data', Press
    'Reset' button, Press 'OK'


[Problem]

    It is expected some of the field in the document should honor option set
    in the step 1 (i.e, the Author field should be changed to the new set
    name), however there's no change at all.

      
[Extra Information]

    This is a regression against LibreOffice 3.2.99.1a withouot VBA patch
Comment 1 Rainer Bielefeld Retired 2010-12-20 11:22:27 UTC
@Yifan:
Can you please try to attach a more typical sample document than this write protected .sxw document (that seems not to contain a User name field?)?
Still a problem with 3.3 RC?

If yes, please contribute a more detailed step by step instruction how to reproduce the problem.
Comment 2 Yifan Jiang 2010-12-21 00:36:59 UTC
Sorry that's a bit confused since I found the problem when testing a vba specific patch, the test data was used by testautomation. 

Let me re-describe the story, considering the OO.o build versus LibO build:

1. Create a new odt file

2. Insert->Fields->Author

3. Save the file and reopen it

4. Select from menu Tools->Options->User Data, say set a random First/Last Name etc.

5. Select from menu File->Properties, check on 'Apply User Data', Press 'Reset' button (notice there're 2 Reset buttons, I clicked the above one inside the tab page), Press 'OK'

=>

It is expected the 'Author' field will be updated immediately after the step 5, and the field is expected to contain the First Last Name set by the step 4. This is also what OO.o build does.

LibO would not update this field automatically after step 5 unless user changes some static content in the document and press 'Save', and then 'Reload'.

The RC1 still appears the same behavior.
Comment 3 rl 2011-04-13 00:00:52 UTC
See this in LibreOffice 3.3.2 on Mac OS X 10.6.7 and Windows 7 (64 bit). 

Therefore changed "Platform" to "All".

This bug might be somehow connected to "Bug 32177 - Writer does not perceive addition of custom document properties as a change for saving", where Writer doesn't save modified file properties.
Comment 4 Noel Power 2013-02-05 14:51:22 UTC
works on latest builds