Download it now!
Bug 30883 - Base - Report Wizard Crashes LibreOffice
Summary: Base - Report Wizard Crashes LibreOffice
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 15:33 UTC by reporter_of_bugs
Modified: 2011-12-22 05:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Base file still crashes LibO when Wizard trying to generate a report from it. (1.62 KB, application/vnd.sun.xml.base)
2010-11-24 19:12 UTC, Yifan Jiang
Details
crash stack for generating report for biblio.odb (60.68 KB, text/x-log)
2010-11-24 19:13 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reporter_of_bugs 2010-10-14 15:33:27 UTC
Overview: Creating a dynamic report & specifying "Create report now" crashes all openoffice components.

Steps to Reproduce:
1) Create new HSQLDB embedded database with 1 table and 1 query as shown in the following tutorial: http://user.services.openoffice.org/en/forum/viewtopic.php?f=83&t=31414
Do not save the database at any stage.

2) Create report via Wizard as per above tutorial, except on step 6, choose "Create report now" BEFORE pressing  the "Finish" button

3) Press "Finish" & the report preview *briefly* appears before all of LO crashes.

Build : LibreOffice 3.3.0 OOO330m9 (Build:1) libreoffice-build 3.2.99.2 on Ubuntu 10.10 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:26:05 UTC 2010 x86_64 GNU/Linux

Additional Information:

FWIW The report read-only preview in Writer crashes (and sometimes the rest of LO) semi-regularly when choosing "Static report" on Step 6 of the wizard from existing databases already populated with tables & queries. I would supply more examples but they weren't consistent reproducible.
Comment 1 reporter_of_bugs 2010-10-14 16:35:16 UTC
Here is terminal output containing a backtrace. Apologies if this should have been an attachment, I can't see any mention in the Bug Writing Guidelines (https://bugs.freedesktop.org/page.cgi?id=bug-writing.html).

sh /opt/libreoffice3/program/soffice /tmp/vocab-exp_v0.6.odb
anon@anonpc:~$ sh /opt/libreoffice3/program/sbase &
[1] 4928
anon@anonpc:~$ 15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibSerializer 1.0.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibBase 1.0.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibLoader 1.0.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibRepository 1.0.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibFonts 1.0.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibLayout 0.2.9 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibFormula 0.2.0 started.
15-Oct-2010 12:29:00 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: LibXML 1.0.0 started.
15-Oct-2010 12:29:01 org.pentaho.reporting.libraries.base.boot.AbstractBoot start
INFO: Pentaho Reporting Flow-Engine 0.9.2 started.
*** glibc detected *** /opt/libreoffice3/program/soffice.bin: free(): corrupted unsorted chunks: 0x0000000003d4b3f0 ***
======= Backtrace: =========
/lib/libc.so.6(+0x774b6)[0x7f36b0e994b6]
/lib/libc.so.6(cfree+0x73)[0x7f36b0e9fc83]
/opt/libreoffice3/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3(+0x1bf43)[0x7f36b01a5f43]
/opt/libreoffice3/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3(+0x22306)[0x7f36b01ac306]
/opt/libreoffice3/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3(uno_Environment_invoke_v+0x32)[0x7f36b01ac3a2]
/opt/libreoffice3/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3(uno_Environment_invoke+0x88)[0x7f36b01ac43e]
/opt/libreoffice3/program/../basis-link/program/../ure-link/lib/libuno_cppu.so.3(+0x1ad41)[0x7f36b01a4d41]
/opt/libreoffice3/ure/lib/libjava_uno.so(Java_com_sun_star_bridges_jni_1uno_JNI_1proxy_finalize__J+0x7e)[0x7f363885f74e]
[0x7f367e8b7c88]
======= Memory map: ========
00400000-00402000 r-xp 00000000 08:0a 7755                               /opt/libreoffice3/program/soffice.bin
00601000-00602000 rw-p 00001000 08:0a 7755                               /opt/libreoffice3/program/soffice.bin
01fcc000-04917000 rw-p 00000000 00:00 0                                  [heap]
7f36344bf000-7f36344c2000 ---p 00000000 00:00 0 
7f36344c2000-7f36345c0000 rwxp 00000000 00:00 0 
7f36345c0000-7f3634619000 r-xp 00000000 08:0a 373                        /opt/libreoffice3/basis3.3/program/libxmlsecurity.so
7f3634619000-7f3634818000 ---p 00059000 08:0a 373                        /opt/libreoffice3/basis3.3/program/libxmlsecurity.so
7f3634818000-7f363481e000 rw-p 00058000 08:0a 373                        /opt/libreoffice3/basis3.3/program/libxmlsecurity.so
7f363481e000-7f363487e000 r-xp 00000000 08:0a 304                        /opt/libreoffice3/basis3.3/program/libraptor.so.1
7f363487e000-7f3634a7e000 ---p 00060000 08:0a 304                        /opt/libreoffice3/basis3.3/program/libraptor.so.1
7f3634a7e000-7f3634a82000 rw-p 00060000 08:0a 304                        /opt/libreoffice3/basis3.3/program/libraptor.so.1
7f3634a82000-7f3634abb000 r-xp 00000000 08:0a 363                        /opt/libreoffice3/basis3.3/program/librasqal.so.1
7f3634abb000-7f3634cbb000 ---p 00039000 08:0a 363                        /opt/libreoffice3/basis3.3/program/librasqal.so.1
7f3634cbb000-7f3634cbd000 rw-p 00039000 08:0a 363                        /opt/libreoffice3/basis3.3/program/librasqal.so.1
7f3634cbd000-7f3634cf3000 r-xp 00000000 08:0a 350                        /opt/libreoffice3/basis3.3/program/librdf.so.0
7f3634cf3000-7f3634ef3000 ---p 00036000 08:0a 350                        /opt/libreoffice3/basis3.3/program/librdf.so.0
7f3634ef3000-7f3634ef5000 rw-p 00036000 08:0a 350                        /opt/libreoffice3/basis3.3/program/librdf.so.0
7f3634ef5000-7f3634f25000 r-xp 00000000 08:0a 285                        /opt/libreoffice3/basis3.3/program/libunordflx.so
7f3634f25000-7f3635124000 ---p 00030000 08:0a 285                        /opt/libreoffice3/basis3.3/program/libunordflx.so
7f3635124000-7f3635128000 rw-p 0002f000 08:0a 285                        /opt/libreoffice3/basis3.3/program/libunordflx.so
7f3635128000-7f3635136000 r-xp 00000000 08:0a 7706                       /opt/libreoffice3/basis3.3/program/libswdlx.so
7f3635136000-7f3635336000 ---p 0000e000 08:0a 7706                       /opt/libreoffice3/basis3.3/program/libswdlx.so
7f3635336000-7f3635337000 rw-p 0000e000 08:0a 7706                       /opt/libreoffice3/basis3.3/program/libswdlx.so
7f3635337000-7f363533a000 r--s 000cb000 08:08 139151                     /usr/lib/jvm/java-6-sun-1.6.0.21/jre/lib/ext/localedata.jar
7f363533a000-7f363533c000 r--s 0000b000 08:0a 6249                       /opt/libreoffice3/share/extensions/report-builder/commons-logging-1.1.1.jar
7f363533c000-7f363533e000 r--s 00002000 08:0a 6407                       /opt/libreoffice3/share/extensions/report-builder/sac.jar
7f363533e000-7f3635348000 r--s 0003b000 08:0a 6408                       /opt/libreoffice3/share/extensions/report-builder/flow-engine-0.9.2.jar
7f3635348000-7f363534b000 r--s 0000b000 08:0a 6239                       /opt/libreoffice3/share/extensions/report-builder/libxml-1.0.0.jar
7f363534b000-7f363534d000 r--s 00009000 08:0a 6243                       /opt/libreoffice3/share/extensions/report-builder/librepository-1.0.0.jar
7f363534d000-7f3635351000 r--s 0000d000 08:0a 6400                       /opt/libreoffice3/share/extensions/report-builder/libloader-1.0.0.jar
7f3635351000-7f363536d000 r--s 000a8000 08:0a 6393                       /opt/libreoffice3/share/extensions/report-builder/liblayout-0.2.9.jar
7f3635457000-7f3635487000 rw-p 00000000 00:00 0 
7f3635487000-7f3635489000 r--s 00001000 08:08 139150                     /usr/lib/jvm/java-6-sun-1.6.0.21/jre/lib/ext/dnsns.jar
7f3635489000-7f363548f000 r--s 00092000 08:08 138976                     /usr/lib/jvm/java-6-sun-1.6.0.21/jre/lib/jsse.jar
7f363548f000-7f36354d5000 r--s 00000000 08:08 261432                     /usr/share/fonts/truetype/msttcorefonts/Arial_Bold.ttf
7f36354d5000-7f3635508000 r--s 00000000 08:08 261436                     /usr/share/fonts/truetype/msttcorefonts/Arial_Italic.ttf
7f3635508000-7f3635534000 r--s 00000000 08:08 14386                      /usr/share/fonts/truetype/openoffice/opens___.ttf
7f3635534000-7f3636100000 r-xp 00000000 08:0a 203                        /opt/libreoffice3/basis3.3/program/libswlx.so
7f3636100000-7f36362ff000 ---p 00bcc000 08:0a 203                        /opt/libreoffice3/basis3.3/program/libswlx.so
7f36362ff000-7f36363d7000 rw-p 00bcb000 08:0a 203                        /opt/libreoffice3/basis3.3/program/libswlx.so
7f36363d7000-7f36363dd000 rw-p 00000000 00:00 0 
7f36363dd000-7f3636e07000 r-xp 00000000 08:0a 46                         /opt/libreoffice3/basis3.3/program/libsclx.so
7f3636e07000-7f3637006000 ---p 00a2a000 08:0a 46                         /opt/libreoffice3/basis3.3/program/libsclx.so
7f3637006000-7f363709b000 rw-p 00a29000 08:0a 46                         /opt/libreoffice3/basis3.3/program/libsclx.so
7f363709b000-7f36370a2000 rw-p 00000000 00:00 0 
7f36370a2000-7f3637112000 r-xp 00000000 08:0a 20                         /opt/libreoffice3/basis3.3/program/librptxmllx.so
7f3637112000-7f3637312000 ---p 00070000 08:0a 20                         /opt/libreoffice3/basis3.3/program/librptxmllx.so
7f3637312000-7f3637317000 rw-p 00070000 08:0a 20                         /opt/libreoffice3/basis3.3/program/librptxmllx.so
[1]+  Exit 134                sh /opt/libreoffice3/program/sbase
Comment 2 Drew Jensen 2010-10-14 20:20:28 UTC
This is a pain for sure - the report builder is released pretty much in step with each release of OO.o. During a new release cycle the developers drop RB builds sometimes on a per build basis to test with. Looking at the qa-upload ftp server the last was OOo3.3 RB 1.2.1_m_7 - I noticed that Zoltan, still doing Base triage at OO.o asked the developers to drop a fresh build to the qa-upload ftp server just today.

I will check this but pretty sure that with LO 3.3 beta 2 we are going to need an updated report builder.

Using Ubuntu Studio 10.04 (amd64) LO 3.3 Beta2 and Report Builder 1.2.1, can reproduce the crash but not every time, at least every other time of using the wizard however. 

Downloaded the m_7 RB from qa-upload and still crashes, actually now it seems to be every time. Well there is something to be said for consistency, no :)
Comment 3 Drew Jensen 2010-10-14 20:41:30 UTC
To follow up - using XP / LO 3.3 beta2 / RB 1.2.1_m_7 - created a couple of reports each, against 2 HSQLdb databases and an ODB file with an MS Access 2007 data store, no problems at all, at least no crashes anyway.
Comment 4 Zoltán Reizinger 2010-10-15 08:26:22 UTC
On Win7 LibO 3.3 beta2 crashes with one file all reports,
but can create new reports with wizards.
Other files reports working well.
Comment 5 Zoltán Reizinger 2010-10-15 08:32:17 UTC
Need to wait for newer version of LibO based on m10 or later, this will contain the latest bugfixes in report builder.
Comment 6 Thorsten Behrens (CIB) 2010-11-18 15:44:47 UTC
Zoltán, beta3 is out, which includes OOo m10 - could you retry?
Comment 7 Drew Jensen 2010-11-18 16:18:37 UTC
Hi @zoltan - Checked w/ Ubuntu 10.10 (64bit), Libo 3.3 Beta 3 / SUN jvm 1.6-0.22 
used 3 different ODB files for testing, created, edited, ran report builder reports in each. No Crashes. Did a little real work, ran Invoices against 4th ODB - all went as expected. I did NOT test anything with charts in the report BTW.
Comment 8 Alex Thurgood 2010-11-22 00:38:36 UTC
Hi all,

I followed the steps described in the issue, but can't reproduce the crash in LibO beta 3 on MacOSX SnowLeaopard (10.6.5).


Alex
Comment 9 Yifan Jiang 2010-11-24 19:12:49 UTC
Created attachment 40561 [details]
Base file still crashes LibO when Wizard trying to generate a report from it.
Comment 10 Yifan Jiang 2010-11-24 19:13:42 UTC
Created attachment 40562 [details]
crash stack for generating report for biblio.odb
Comment 11 Yifan Jiang 2010-11-24 19:17:22 UTC
LibO 3.3 Beta 3 stills meets crash with a specific odb on SLED 11 sp1.

The steps are the same as described in this topic, the crash happens
immediately after 'Create report now' -> 'Finish'

The testautomation keeps failing on the script dba_Main.bas.

The case uses the attached odb file is:

$testautomation/dbaccess/required/includes/Wizards.inc:107:testcase tReportWizard

Compared to legacy automation logs and the problem should be a regression against OO.o 3.2.1.

- test document and crash stack attached.
Comment 12 Yifan Jiang 2010-12-12 23:32:56 UTC
3.3 RC1 still has this problem ,the report builder Wizard is not usable :(
Comment 13 Cédric Bosdonnat 2010-12-13 06:56:52 UTC
(In reply to comment #12)
> 3.3 RC1 still has this problem ,the report builder Wizard is not usable :(

I can't reproduce it here on 3.3 branch built (openSuse 11.2) neither with nor without the patches applied on top of LibreOffice.
Comment 14 Yifan Jiang 2010-12-14 00:03:26 UTC
Looked more in various platforms:

1. SLED 11 sp1 x64 w/ java-1_6_0-sun-1.6.0.u20-0.1.1

- hard to reproduce now.

2. SLED 11 sp1 i586 w/ java-1_6_0-sun-1.6.0.u20-0.1.1

- Not always but can frequently reproduce by steps:

   a) create a report through wizard
   b) if libo is still alive, close the launched writer(read-only)
   c) create again

Usually the crash will happen after *at most 3 times* try of above steps.
Comment 15 Zoltán Reizinger 2010-12-30 06:05:03 UTC
Sorry I'm not followed the bug history. 
Now I installed LibO 3.3RC2 on win7.
The LibO not crashing, with the provided by LibO version of report builder.
Creates report.
Comment 16 Alex Thurgood 2011-02-03 06:22:46 UTC
There don't appear to have been any more reports of crashing since December 14th, 2010. Can we close this bug now that final is out ?

@Yifan : could you test again on SLED please and report back ?

Thanks,


Alex
Comment 17 Thorsten Behrens (CIB) 2011-02-09 05:50:07 UTC
Appears fixed to me. Please re-open if this still happens with 3.3 final.
Comment 18 Alex Thurgood 2011-02-09 06:24:38 UTC
closing
Comment 19 Björn Michaelsen 2011-12-22 05:35:44 UTC
Remove infoprovider from closed and resolved bugs.
Comment 20 Björn Michaelsen 2011-12-22 05:52:05 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.