Download it now!
Bug 30889 - User data does not hold when saving a document
Summary: User data does not hold when saving a document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-15 03:38 UTC by RGB
Modified: 2012-05-07 09:38 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test file with missing user info (7.78 KB, application/vnd.oasis.opendocument.text)
2010-10-28 12:36 UTC, RGB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2010-10-15 03:38:07 UTC
Steps to reproduce the problem:
1- on LibO beta 2, go to Tools -> Options -> LibreOffice -> User data and fill some fields, like Name, Surname.
2- create a Writer document. If you look at File -> Properties, you will see the user info near creation data.
3- save the document.
Result:
If you now return to File -> Properties, the user data is now missing.

This is a big problem with long documents, because Writer relies on user data to show the last edited point when document is reopened. I marked this as a "blocker" because it is a regression and give me many troubles as I am used to work on very long and complex documents and not always remember the last point in which I was working the previous day.
Comment 1 RGB 2010-10-15 14:27:22 UTC
Some more testing: the field that shows the number of times the document was edited always show 1.
Other fields, like those on File -> Properties -> Description tab are retained without problems.
Comment 2 Muthu 2010-10-16 10:26:25 UTC
One for cedric?
Comment 3 Cédric Bosdonnat 2010-10-28 07:47:37 UTC
I can't reproduce that here in LibreOffice beta2 or a recent build from master branch. Could you give some more details or a sample document to help reproduce the bug?
Comment 4 RGB 2010-10-28 12:36:23 UTC
Created attachment 39871 [details]
Test file with missing user info

LibO beta2, 64 bits on openSUSE 11.2. Spanish localization applied. Nothing else: just create a document and the user info (introduced on Tools -> Options -> LibreOffice -> User information disappears on save (there is nothing on File -> Properties that shows who created the document, and because of that the last edited point is not restored on file reopen.
Comment 5 Cédric Bosdonnat 2010-10-29 01:27:04 UTC
(In reply to comment #4)
> LibO beta2, 64 bits on openSUSE 11.2. Spanish localization applied. Nothing
> else: just create a document and the user info (introduced on Tools -> Options
> -> LibreOffice -> User information disappears on save (there is nothing on File
> -> Properties that shows who created the document, and because of that the last
> edited point is not restored on file reopen.

After testing again, I can't reproduce the bug, even with Beta2. Do you have the "Apply User Data" box checked in the Properties dialog before saving?
Comment 6 RGB 2010-10-29 04:55:38 UTC
(In reply to comment #5)

> After testing again, I can't reproduce the bug, even with Beta2. Do you have
> the "Apply User Data" box checked in the Properties dialog before saving?

Yes. As Commented on first message, I can see the data when the document is created, but it get lost as soon as the document is saved.
Comment 7 Cédric Bosdonnat 2010-11-02 03:00:47 UTC
Bug only in Beta2: can't be reproduced in latest builds.
Comment 8 Björn Michaelsen 2011-12-22 05:36:30 UTC
Remove infoprovider from closed and resolved bugs.
Comment 9 Roman Eisele 2012-05-07 09:38:19 UTC
Set version field according to comment #4 and comment #7.