Download it now!
Bug 30904 - Function wizard shows incorrect cell/sheet address
Summary: Function wizard shows incorrect cell/sheet address
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Linux (All)
: highest blocker
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-15 10:34 UTC by Liz Young
Modified: 2012-05-04 01:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Young 2010-10-15 10:34:05 UTC
LibreOffice 3.3.0 
OOO330m9 (Build:1)
libreoffice-build 3.2.99.2

Ubuntu 10.04 LTS (Lucid Lynx)

Also filed in Debian bug tracker August 8 2010: #594120 (openoffice.org-calc: Function Wizard omits sheet reference)

Much simpler way to reproduce this in Calc:
-Click Function Wizard
-Double-click ABS function
-Select Sheet2.A1
Function Wizard enters =ABS(A1:A1) and Calc returns Err:522

Expected:
Function Wizard to enter =ABS(Sheet2.A1) and Calc to return 0.

For me the severity is critical because it stops me from working efficiently. I use the Function Wizard daily to build formulas on complex multi-sheet files.  But, I can revert to Beta1 where this bug does not appear to exist.
Comment 1 Kohei Yoshida 2010-10-15 10:53:01 UTC
Yes, this needs to be fixed.  Thanks for reporting this.  I'll look into this sooner rather than later.
Comment 2 Kohei Yoshida 2010-10-23 08:29:14 UTC
Found the cause & fixed it on master.  This will be fixed in the next release.
Comment 3 sophie 2010-11-01 05:42:32 UTC
Verified in 10_10_28_Cedric.rpm build - Closing - Sophie
Comment 4 Roman Eisele 2012-05-04 01:07:55 UTC
This is a Calc issue, therefore changed 'Component' field accordingly.

Set Version according to original description.