Download it now!
Bug 30905 - WRITER - crashes when copy particular table
Summary: WRITER - crashes when copy particular table
Status: RESOLVED DUPLICATE of bug 30921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-15 11:06 UTC by Rainer Bielefeld Retired
Modified: 2012-05-04 04:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (17.61 KB, application/vnd.oasis.opendocument.text)
2010-10-15 11:08 UTC, Rainer Bielefeld Retired
Details
JRE error log (99.47 KB, text/x-log)
2010-10-16 13:24 UTC, reporter_of_bugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-10-15 11:06:16 UTC
I tried with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2] 

Steps to reproduce:

1. Open attached SampleTableCrash.odt
2. scroll that you see table with heading "Auftragsakte"
3. click above table
4. press <cntrl>
5. click under table so that all table will be selected
6. press <cntrl> + <c>
   expected: selection will be copied into clipboard
   actual: CRASH
Comment 1 Rainer Bielefeld Retired 2010-10-15 11:08:16 UTC
Created attachment 39470 [details]
Sample document

You should be able to reproduce the crash using that document.
Comment 2 Rainer Bielefeld Retired 2010-10-16 04:42:17 UTC
NOT Reproducible with "Ooo-Dev 3.3.0 multilingual version English UI WIN XP: [OOo330m10 (Build 9533)]"!
Comment 3 Muthu 2010-10-16 09:46:50 UTC
Works fine under linux (master build today's)...Let me check on windows too...
Comment 4 reporter_of_bugs 2010-10-16 13:24:08 UTC
Created attachment 39483 [details]
JRE error log
Comment 5 reporter_of_bugs 2010-10-16 13:27:10 UTC
I was able to reproduce this under Ubuntu 10.10 X86_64. 

Various row and/or column selections  & de-selections resulted in a crashes also.
Comment 6 reporter_of_bugs 2010-10-16 13:30:20 UTC
(In reply to comment #5)
> I was able to reproduce this under Ubuntu 10.10 X86_64. 
> 
> Various row and/or column selections  & de-selections resulted in a crashes
> also.

Sorry, here is my LO build info:

LibreOffice 3.3.0 
OOO330m9 (Build:1)
libreoffice-build 3.2.99.2
Comment 7 Rainer Bielefeld Retired 2010-10-18 21:42:28 UTC
I am not sure whether it's because of the same reason, but many of my WRITER documents (only if they contain tables) crash even when I open them. Currently it's impossible to do further tests with LibO because of this bug, I had to switch back to OOo.
Comment 8 Muthu 2010-10-20 05:33:17 UTC
It would be great if you could attach an backtrace and strace. This would help us identify the problem quicker. Thank you!

[ ref: http://en.opensuse.org/openSUSE:Bugreport_OOo ]
Comment 9 Rainer Bielefeld Retired 2010-10-20 11:09:13 UTC
I know, but I'm still and also with LibO suffering from
<http://www.openoffice.org/issues/show_bug.cgi?id=103555>

No crash report available!
Comment 10 Thorsten Behrens (CIB) 2010-10-21 01:42:28 UTC
Not sure if that's in any way related - deleting arbitrary columns in the sample table, followed by undo -> crash.

backtrace snippet:

#0  0x00007ffff36ceabe in utl::ReadWriteGuard::ReadWriteGuard(utl::ReadWriteMutex&, int) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libutllx.so
#1  0x00007ffff36c5132 in LocaleDataWrapper::getLocale() const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libutllx.so
#2  0x00007fffdecd5c44 in SwCalc::Str2Double(String const&, unsigned short&, double&, SwDoc*) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#3  0x00007fffdec90ddc in SwFormulaField::SetFormula(String const&) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#4  0x00007fffdec8e84b in SwGetExpField::Copy() const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#5  0x00007fffdec905bc in SwField::CopyField() const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#6  0x00007fffdeac833c in SwFmtFld::SwFmtFld(SwFmtFld const&) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#7  0x00007fffdeac8379 in SwFmtFld::Clone(SfxItemPool*) const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#8  0x00007ffff4c2837b in SfxItemPool::Put(SfxPoolItem const&, unsigned short) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libsvllx.so
#9  0x00007fffdeae77e9 in MakeTxtAttr(SwDoc&, SfxPoolItem&, unsigned short, unsigned short) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#10 0x00007fffdeaed79f in SwTxtNode::InsertItem(SfxPoolItem&, unsigned short, unsigned short, unsigned short) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#11 0x00007fffdeae0265 in SwTxtNode::CopyText(SwTxtNode*, SwIndex const&, SwIndex const&, unsigned short, bool) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#12 0x00007fffdeae23f1 in SwTxtNode::CopyText(SwTxtNode*, SwIndex const&, unsigned short, bool) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#13 0x00007fffdeaf8674 in SwTxtNode::MakeCopy(SwDoc*, SwNodeIndex const&) const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#14 0x00007fffdeb1d68b in SwNodes::_CopyNodes(SwNodeRange const&, SwNodeIndex const&, unsigned char, unsigned char) const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#15 0x00007fffdeaf8d5b in SwTableNode::MakeCopy(SwDoc*, SwNodeIndex const&) const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#16 0x00007fffdeb1d6d4 in SwNodes::_CopyNodes(SwNodeRange const&, SwNodeIndex const&, unsigned char, unsigned char) const () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#17 0x00007fffdecb0d48 in SwUndoDelete::Undo(SwUndoIter&) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#18 0x00007fffdeca53bf in SwDoc::Undo(SwUndoIter&) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#19 0x00007fffde8cc655 in SwEditShell::Undo(SwUndoId, unsigned short) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#20 0x00007fffdef78f30 in SwWrtShell::Do(SwWrtShell::DoType, unsigned short) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
#21 0x00007fffdee86e3f in SwBaseShell::ExecUndo(SfxRequest&) () from /builds/oobuild/ooo-build-pristine-git/build/install/program/../basis-link/program/libswlx.so
Comment 11 Thorsten Behrens (CIB) 2010-10-21 01:51:47 UTC
Cedric, any idea?
Comment 12 Cédric Bosdonnat 2010-10-28 06:30:49 UTC
Yet another duplicate of that magically fixed bug

*** This bug has been marked as a duplicate of bug 30921 ***
Comment 13 Björn Michaelsen 2011-12-22 05:36:46 UTC
Remove infoprovider from closed and resolved bugs.
Comment 14 Björn Michaelsen 2011-12-22 05:50:48 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 15 Roman Eisele 2012-05-04 04:13:20 UTC
This is a Writer issue, therefore changed the 'Component' field appropriately.

Set Version field according to original description and comment #6.