Download it now!
Bug 30921 - Writer crashes when using custom fields.
Summary: Writer crashes when using custom fields.
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
: 30905 31181 31182 31183 31184 31312 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-16 05:31 UTC by big0424
Modified: 2012-05-04 02:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description big0424 2010-10-16 05:31:31 UTC
In LibreOffice Writer 3.3 beta 2, I'll use custom field (CTRL+F2). I choose a new Sequence variable, and when I click Insert, writer crashes.
I'm using LibreOffice 3.3 beta2 in French
Comment 1 big0424 2010-10-20 10:36:19 UTC
Testes on linux : same error !
How to reproduce : Starting Writer, then CTRL+F2,choose Variable, then Sequence, and try to insert any field.

result : Writer crashes.
Comment 2 Muthu 2010-10-20 13:08:38 UTC
Would it be possible for you to attach the backtrace/strace, please?

[ ref: http://wiki.documentfoundation.org/BugReport ]

Thank you!
Comment 3 sophie 2010-10-21 00:58:43 UTC
Hi, please find the compressed log here (was too large for bugzilla):
http://cjoint.com/data/0kvjZ7nSrGg_strace.log.bz2 - Sophie
Comment 4 Muthu 2010-10-21 01:50:17 UTC
Reassigning to cedric for further analysis...
Comment 5 xihh 2010-10-27 11:27:36 UTC
On Archlinux x86_64
LibreOffice 3.3.0 
OOO330m9 (Build:1)
3.2.99.2 ArchLinux build-1 (ooo330-m7)

It crashes when inserting any Number Range field by any of this procedures:

* AutoCaption
* Right click on image/graph/other > Caption
* CTRL + F2 > Insert any Number Range field
Comment 6 Cédric Bosdonnat 2010-10-28 01:09:19 UTC
This crash has been fixed now: can't reproduce anymore in master branch.

I'm closing as WORKSFORME, but I could reproduce the bug with Beta2: I don't know what has fixed the bug.
Comment 7 Cédric Bosdonnat 2010-10-28 02:50:48 UTC
*** Bug 31182 has been marked as a duplicate of this bug. ***
Comment 8 Cédric Bosdonnat 2010-10-28 02:54:20 UTC
*** Bug 31183 has been marked as a duplicate of this bug. ***
Comment 9 Cédric Bosdonnat 2010-10-28 06:01:41 UTC
*** Bug 31184 has been marked as a duplicate of this bug. ***
Comment 10 Cédric Bosdonnat 2010-10-28 06:30:49 UTC
*** Bug 30905 has been marked as a duplicate of this bug. ***
Comment 11 Cédric Bosdonnat 2010-11-02 02:38:36 UTC
*** Bug 31181 has been marked as a duplicate of this bug. ***
Comment 12 Cédric Bosdonnat 2010-11-02 03:29:50 UTC
*** Bug 31312 has been marked as a duplicate of this bug. ***
Comment 13 Rainer Bielefeld Retired 2010-11-18 01:46:17 UTC
Worksforme verified with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.2)]"
Comment 14 Roman Eisele 2012-05-04 02:57:54 UTC
This is a Writer issue, therefore changed the 'Component' field appropriately.

Set Version according to original description.