Download it now!
Bug 30922 - Linking images on drag-drop causes problems on document copy/move
Summary: Linking images on drag-drop causes problems on document copy/move
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-16 05:38 UTC by Rob Juurlink
Modified: 2010-11-01 11:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Juurlink 2010-10-16 05:38:09 UTC
By default, images *are* embedded as links in Impress if they are drag-dropped
from the Desktop / Finder.

I think this a serious usability issue. 

Drag and dropping an image, the user expects the image to be in the document. It
is just weird and pretty annoying to discover afterward that the images are not
there when the presentation is opened at another computer. It just doesn't make
sense. It is also not consistent with Writer.

See also this forum discussion:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=10&t=14972

Edit>Links>Break link is not a solution. It isn't even clear that the image is
linked instead of embedded. 

(Bugreport OpenOffice.org Impress equivalent: http://www.openoffice.org/issues/show_bug.cgi?id=50096)
Comment 1 Rob Juurlink 2010-10-16 06:01:18 UTC
I discovered that the behavior is not consistent. 
Currently it looks to me that:

- Drag-n-drop PNG image from the desktop -> embedded.
- Drag-n-drop JPG image from the desktop -> linked to the original.
Comment 2 Rob Juurlink 2010-10-16 06:10:42 UTC
I was mixing OpenOffice.org and LibreOffice. Double clicking the .odp file opens OpenOffice.org, that caused my confusion.

Apparently the issue is fixed in LibreOffice (not in OpenOffice.org btw). 
Thank you Libre Office!
Comment 3 sophie 2010-11-01 11:22:36 UTC
Closing - Sophie