Download it now!
Bug 30925 - Remove filter does not work for Autofilter
Summary: Remove filter does not work for Autofilter
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: low normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-16 10:53 UTC by Rainer Bielefeld Retired
Modified: 2011-12-23 15:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (10.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-10-16 10:55 UTC, Rainer Bielefeld Retired
Details
Screen shot for removing autofilter. (33.83 KB, image/jpeg)
2010-10-18 03:14 UTC, Muthu
Details
Screenshot (108.65 KB, application/x-download)
2010-11-23 03:02 UTC, Rainer Bielefeld Retired
Details
Pls see Comment 14 (208.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-01-12 11:53 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-10-16 10:53:21 UTC
I checked with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)]

I have been used to unfilter clicking menu 'Data -> Filter -> Remove Filter'
Now I find this menu item always greyed out 

Steps to reproduce:

1. download and open attached "sample.ods"
2. Click filter button for column 2
3. Filter for "2"
   all rows with "2" will be shown
3. Menu 'Data -> Filter -> Remove Filter'
   Expected: option possible
   Actual: greyed out

Same with my "Remove Filter" button in task bar.
Works fine for Standard Filter

Works fine with "Ooo-Dev 3.3.0 multilingual version English UI WIN XP: [OOo330m10 (Build 9533)]"!
Comment 1 Rainer Bielefeld Retired 2010-10-16 10:55:08 UTC
Created attachment 39482 [details]
Sample document
Comment 2 Muthu 2010-10-16 23:18:05 UTC
Isn't this now Data->Filter->Auto Filter (since this is now a checkbox?)
Click on it again to remove the autofilter.

Please let us know if that is what you are looking for. Thank you!
Comment 3 Rainer Bielefeld Retired 2010-10-17 21:00:25 UTC
@Muthu:
I can't see the problem to find out what my needs are. 
I do not want to remove the auto filter, I do want to see all data without filter, for that menu 'Data -> Filter -> Remove Filter' is required.
I can't see any checkbox at Data->Filter->Auto Filter, can you please provide a screenshot?

Funny thing, today every thing works as expected, I will try to find out what circumstances cause the problem I saw.
Comment 4 Muthu 2010-10-18 03:14:56 UTC
Created attachment 39499 [details]
Screen shot for removing autofilter.

Screenshot attached.
In some cases the checkbox would be a icon (the icon button might look to be pressed or released depending on the state of the autofilter).
Comment 5 Rainer Bielefeld Retired 2010-10-18 04:03:03 UTC
@Muthu:
Yes, I have the icons, and with much fantasy I can distinguish "pressed" and "unpressed".
But as I wrote, I'm talking about problems with  item "Remove Filter", that still sometimes does work and sometimes does not.
Comment 6 Muthu 2010-10-20 05:49:53 UTC
@Rainer:
Remove filter would be enabled when you filter something using the auto-filter. 

If you are still facing problems, it would be great if you could provide us more information on the problem. Thank you!
Comment 7 Rainer Bielefeld Retired 2010-10-20 11:18:10 UTC
@Muthu:
Please! I have been using OOo for several years, I know how such filter should work.
You will find all available information in my report and comments, including that the problem is not 100% reproducible.
I stopped using beta2 because of bug 30905, so even if it would be possible to find additional information - I can't do that before the next build.
Comment 8 Noel Power 2010-10-26 07:35:26 UTC
kohei for you?
Comment 9 Kohei Yoshida 2010-11-03 12:06:17 UTC
I can think of two things:

1) maybe the cell cursor was positioned outside the filtered area in which case the Remove Filter entry is grayed.

2) the original file was imported from an xls file, which may set the data base range smaller than the actual data range.  And somehow that's interfering with the state of the Remove Filter menu item.

other than that, I can't reproduce this problem, so I'm tempting to mark this WORKSFORME...
Comment 10 Kohei Yoshida 2010-11-16 13:01:09 UTC
Just to say that I just saw this happen on me when I was messing with autofilter, but I don't remember what I did. :-/
Comment 11 Rainer Bielefeld Retired 2010-11-16 22:02:30 UTC
I haven't seen that for weeks, but currently I do not use filter function very often. 
When I saw the problem, I clicked into the filter heading to be sure that the cell cursor isn't outside the filter area, because - of course - that happens sometimes during my daily work. That did not heal the problem.
Currently I still try to reproduce the problem from time to time, without success.
Comment 12 Rainer Bielefeld Retired 2010-11-18 21:37:40 UTC
Now I use Beta3 for my daily work, if I can't find out more details, I will close this bug end of November.
Comment 13 Rainer Bielefeld Retired 2010-11-23 03:02:35 UTC
Created attachment 40503 [details]
Screenshot

Today I see it again. In one of my "real life" spreadsheets after a while I lost the "Remove Filter" Function. But it was not reproducible with same time opened sample document for this bug report
Comment 14 Rainer Bielefeld Retired 2011-01-12 11:51:18 UTC
Another attempt to provide a sample document. I checked with "LibreOffice 3.3.0 RC2 - WIN7  Home Premium (64bit) German UI  [OOO330m18 (build 3.3.0.2)]"

Please  
1. open document
2. Press filter button for column "Artikel"
3. select 'Standard Filter'
   Unexpected: already contents in 'Value', I see that effect in all 
               documents where I see that problem, and the problem does not 
               appear with OOo 3.1.1
               I don't know any method to 
11. Replace filter Value contents "Relais" and proceed filter
    as expected, only rows with "Relais" in column 'D' will be shown
12. click into 'D367'
13. Watch button "remove filter" in Standard Toolbar.
    expected: active
    actual: greyed out
14. Try menu 'Data -> Filter - Remove Filter Toolbar.
    expected: active
    actual: greyed out
15. Watch Filter Button in column 'D'
    expected: blue
    actual: no filter color
21. Press filter button for column "Artikel"
22. select 'All'
    As expected filter will be removed
23. Redo from step 2., you should see the same unexpected effects.

As I told, whith OOo 3.1.1 filter of that document works without problems
Comment 15 Rainer Bielefeld Retired 2011-01-12 11:53:33 UTC
Created attachment 41933 [details]
Pls see Comment 14
Comment 16 Rainer Bielefeld Retired 2011-01-15 00:32:24 UTC
@Katarina:
can you help?
Comment 17 Kohei Yoshida 2011-01-15 08:45:43 UTC
Info provided, and let's set the target to 3.4.
Comment 18 Kohei Yoshida 2011-03-22 20:37:14 UTC
I think I figured this out.

The short answer is, this is probably not a bug.

When you have autofilter set to a named database range, you can't remove autofilter; you can only hide it.  You can remove autofilter only when you have it set to an un-named database range.

To check whether the database range is named, set the cell cursor to a cell within the database range, and go to Data - Define Range.  It should highlight the current named range where the cursor is in.

However, this may be a usability bug.  To me, hiding and removing autofilter should be combined into just one "remove autofilter".  It would be nice to know the original rationale behind this behavior though...
Comment 19 Kohei Yoshida 2011-03-22 20:40:56 UTC
Technically this is not a bug.  So, I'll close it as such.

If this poses a usability concern, please file a new bug.
Comment 20 Rainer Bielefeld Retired 2011-03-23 00:59:45 UTC
@Kohei:

If you think there is no bug please explain how I can get work reliable step 3 of this comment.

Be sure, this is a bug, but it seems that I failed to explain the problem.
It seems there is some misunderstanding concerning the problem, reason might be ambiguity of words like "remove" or "hide" 

Do we really talk about the same situation?
1. I use Autofilter to show only some particular interesting data
   That works fine
2. Now I want to switch back to primary view with all data. 
3. For this I have to use menu 'Data > Filter > Remove Filter' or alternatively
   the function that can be added to the toolbar.
   This does not remove Autofilter (the buttons will remain), but the filter
   will be switched to a "show all mode"
   This works with LibO for several documents and several cases, and several
   times,  sometimes with some documents it does not work with LibO. I doubt 
   that your comment is concerning such an intermitting problem.
   This works with perfectly with all OOo versions and all other spreadsheets I 
   used the last 20 years in the same way.

I would have liked to create a more demonstrative demo than my attached screenshots, but just now everything works fine. Yesterday the same problem caused some additional grey hairs for me ...

To be honest, I do not understand at all what you want to tell me in Comment 18. That I use CALC filters in a wrong way? 

If there are problems to understand my problem I can give you remote access to my PC so that you can see the problem.
Comment 21 Kohei Yoshida 2011-03-23 06:45:01 UTC
Ok.  I'll be honest with you.  I couldn't reproduce the problem in comment 14.  So, I'm also confused.  Your step 11 is where I failed to reproduce.  There is no data "Ralais" in the test document.
Comment 22 Björn Michaelsen 2011-12-22 05:51:17 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.