Download it now!
Bug 30994 - window size not set properly when opening
Summary: window size not set properly when opening
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-19 16:09 UTC by Peter N. Steinmetz
Modified: 2011-01-11 13:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter N. Steinmetz 2010-10-19 16:09:04 UTC
When a document with a large size from a large screen is re-opened using a smaller screen (for example, on a laptop), the window size is larger than the screen, rather than being resized down.
Comment 1 Muthu 2010-10-20 02:53:33 UTC
Re-assigning...
Comment 2 Tor Lillqvist 2010-10-21 01:30:31 UTC
Please, give exact reproduction instructions. As far as I know, LibreOffice does not keep the size of window last used for a document stored with the document in any of the document format (if that eveb was possible). So presumably you mean that *any* Writer (or Calc, etc) document window will open with its previous size even if that is now then too large. Or am I misunderstanding?
Comment 3 Peter N. Steinmetz 2010-10-21 16:04:35 UTC
Sorry, that was unclear.

I mean you have LibreOffice running when connected to a large screen and a document occupying much of it. 

You then reconnect the computer to a smaller screen, or just disconnect the large screen and start working on the smaller laptop screen.

The document retains its much larger size, rather than adjusting to be no larger than the current screen.
Comment 4 Tor Lillqvist 2010-10-25 04:48:50 UTC
OK. So you keep LibreOffice running while disconnecting a monitor and reconnecting a different pixel-dimensioned one? (Presumably it is not the only monitor on the system that you disconnect?) And initially you have a LibreOffice window open on that monitor, so while the monitor is not there, that LibreOffice window is not visible anywhere on the desktop?

Isn't that actually a more serious problem, what if you aren't going to attach another monitor until much later perhaps? Shouldn't LibreOffice in this case be clever enough to move any window open on a monitor that gets disconnected to one of the remaining monitors? (And obviously also then resize if necessary to fit on the monitor where they are moved.) Whether it then should remember that the window was automagically moved, and move back in case another monitor gets re-attached, I don't know... Sure, in many cases it would make sense.

We need to test how these scenarios behave in the other desktop environments, too. (Windows/GNOME/KDE[34]/other X11)
Comment 5 Peter N. Steinmetz 2010-10-25 07:38:01 UTC
Also, on a laptop there might only effectively be one display if the top is down the built-in display is off. So disconnecting the big display, there is none. Then two scenarios: reconnect to another larger display at some later time, or open the built-in.
Comment 6 Tor Lillqvist 2010-10-25 08:57:09 UTC
But especially on a MacBook, surely the machine goes to sleep very reliably when the lid is closed, and apps don't need to do anything at all, unless they want to? Or is that configurable, I must check with my MacBook...?
Comment 7 Don't use this account, use tml@iki.fi 2010-12-02 04:00:31 UTC
Thorsten, do you have any insight on potential Mac OS X -specific points here?
Comment 8 Thorsten Behrens (CIB) 2010-12-03 01:12:21 UTC
Quite frankly, this is a task for the operating system / window manager (the more obscure examples you gave, Tor). For the original problem: well yeah, I assume LibO should limit window sizes to the current monitor dimension. Should be a general issue, just maybe hidden on some platforms which implicitely do that already.
Comment 9 Don't use this account, use tml@iki.fi 2010-12-15 06:44:26 UTC
I can't reproduce the problem on Windows. If I have OOo runnin with only a Writer window open as non-maximized but quite large on the only monitor, then close OOo, change the monitor width to be much smaller, and then restart OOo to open the Writer document, the window size is set to be smaller so that it fits on the monitor. (I do this in a vmware virtual machine (running XP) so it is trivial to resize the monitor.)

As the initial report was for Max OS X, setting it back to that, and assigning to Thorsten.
Comment 10 Alex Thurgood 2011-01-05 08:08:09 UTC
I can not reproduce this behaviour switching between a 14" screen and my MacbookPro, the document window opens full screen on both.


Alex
Comment 11 Thorsten Behrens (CIB) 2011-01-11 13:06:57 UTC
Closing for the while - Peter, if this problem persists for you in newer versions, please reopen with further input.