Download it now!
Bug 31019 - LibreOffice Beta 2 - unable to register/load Java runtime (on Mac OS X 10.6)
Summary: LibreOffice Beta 2 - unable to register/load Java runtime (on Mac OS X 10.6)
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
: 31260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-20 19:54 UTC by PeterSHarris
Modified: 2011-01-15 04:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PeterSHarris 2010-10-20 19:54:23 UTC
While using the above beta I found a function could not run because it requires Java. I'm almost certain the function worked in Beta 1.

I checked Preferences to find that no Java runtime was registered despite having the lastest Mac release of it (as of today). Attempts to load and register Java within LO Preferences failed despite indications that it attempts to register.

NeoOffice has the latest Java Runtime correctly registered and functions appropriately.

Thanks
Comment 1 Muthu 2010-10-21 02:21:02 UTC
Reassigning...
Comment 2 PeterSHarris 2010-10-21 11:58:06 UTC
Further to my initial comment. I have since test installed OO 3.3 RC and, what appears to be the same JAVA issue, occurs with it.
Comment 3 Alex Thurgood 2010-10-24 12:54:49 UTC
I have changed the platform in this issue to Mac since it only affects that OS.

This bug is already known for the current OOo and future 3.3 betas :

http://www.openoffice.org/issues/show_bug.cgi?id=115180


It is due apparently to Apple's wondrous update of Java to version 1.6.0_22 and OOo's non-standard way of looking for the presence of the JVM and determining its version number.


Not only does this screw up the betas, but it also screws up any existing version that is installed or re-installed (apparently, and judging from the very irate comments on the OOo user groups).


Alex
Comment 4 PeterSHarris 2010-10-24 13:38:36 UTC
I wonder if the Java detection code from NeoOffice can be used in LO to detect Apple's  Java 1.6.0_22 "wondrous" update. NeoOffice seems to detect the Java location correctly.
Comment 5 Florian Effenberger 2010-10-26 07:09:18 UTC
In addition, when disabling Java support in the options, nearly every action (like copy and paste, or printing) throws an "This function needs Java" error message, although I'm pretty sure these functions do not require Java at all.
Comment 6 Caolán McNamara 2010-11-01 08:48:09 UTC
m13 was merged today, it should fix this.
Comment 7 Caolán McNamara 2010-11-01 08:48:56 UTC
*** Bug 31260 has been marked as a duplicate of this bug. ***
Comment 8 Thorsten Behrens (CIB) 2010-11-02 02:32:59 UTC
Fixed indeed. we should have a beta update soon.
Comment 9 PeterSHarris 2010-11-02 02:57:57 UTC
(In reply to comment #8)
> Fixed indeed. we should have a beta update soon.

Thank you.
Comment 10 sophie 2011-01-15 04:13:54 UTC
Closing - Sophie