Download it now!
Bug 31039 - .docx list elements do not indent lines after the initial
Summary: .docx list elements do not indent lines after the initial
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium minor
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-21 23:20 UTC by Andrew M
Modified: 2013-11-20 16:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original document that displayed the behaviour (608.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-10-25 15:49 UTC, Andrew M
Details
screen shot of how it renders for me (54.96 KB, image/png)
2010-10-25 15:54 UTC, Andrew M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew M 2010-10-21 23:20:31 UTC
In a .docx files list elements that contain text which wraps to the next line do not indent to the same position that the parent line indents to.

e.g
1.   Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut mollis libero ac nisi tempus eu cursus nisi tincidunt.
2.   bar 


would appear:

1.   Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut mollis libero ac
     nisi tempus eu cursus nisi tincidunt.
2.   bar 



I am unsure if this is actually a bug or the intended behavior. I don't have MS Word but apparently the behavior of Word is that it matches the indentation in example 2. Since this is a .docx file I am assuming the correct way to display this is in the same way word does.  Apologies if that is not the case.

Please let me know if the original document i was given would be useful for seeing an example. OOo displays the same behaviour.
Comment 1 Muthu 2010-10-25 08:16:35 UTC
Yes, please do attach the sample files!
Comment 2 Andrew M 2010-10-25 15:49:16 UTC
Created attachment 39767 [details]
Original document that displayed the behaviour

The issue presents for me on the lines:

1. Using your computer, copy the Webinar VoiP link for the call you wish to join from the list below, and paste this link into your web browser.  Please enter the registration information as requested and follow the remainder of instructions provided.  A headset or speakers are required.


1. Select an appropriate dial-in access number from the list provided below and make note of the ACCESS CODE which is the same for each call.

2. Dial the call access number, when prompted please enter the ACCESS CODE selected above. 
Please note that if you use the incorrect ACCESS CODE you will not enter conference room.
A PIN is not required and you will automatically connect to the conference call.
Comment 3 Andrew M 2010-10-25 15:54:09 UTC
Created attachment 39768 [details]
screen shot of how it renders for me

Just attached a screen shot incase you can't reproduce.
Comment 4 Noel Power 2010-10-27 03:35:05 UTC
this is imo a bug, the text should be indented, but.. again the import filters are known not to be perfect, this is a nice catch, thanks!!. 

For you Cedric?
Comment 5 Andrew M 2010-10-27 18:59:01 UTC
If you have an idea roughly where things are going wrong I may be able to gave a go at fixing it myself. (In reply to comment #4)
> this is imo a bug, the text should be indented, but.. again the import filters
> are known not to be perfect, this is a nice catch, thanks!!. 
> 
> For you Cedric?

Can you tell me roughly where about's in the src are the input filters located? I am happy to attempt fixing it myself. I have some programming knowledge and it might be something an entry level person could fix. I do unfortunately get a bunch of these documents so if i can learn how to fix some of the minor issues i run across I may be able to reduce the burden on the real developers.
Comment 6 Cédric Bosdonnat 2011-03-31 00:12:16 UTC
Hi Andrew,

(In reply to comment #5)
> Can you tell me roughly where about's in the src are the input filters located?
> I am happy to attempt fixing it myself. I have some programming knowledge and
> it might be something an entry level person could fix. I do unfortunately get a
> bunch of these documents so if i can learn how to fix some of the minor issues
> i run across I may be able to reduce the burden on the real developers.

Almost all the docx import code is located in the writerfilter module:
http://cgit.freedesktop.org/libreoffice/filters/tree/writerfilter/

I'm not sure it's an entry level task to fix it, but you can have a go at it. It took me quite some time to understand that intricated XSL and C++ code there.
Comment 7 Roman Eisele 2012-05-04 09:18:30 UTC
This is (primarily) a Writer issue, therefore changed 'Component' field
accordingly.
Comment 8 Jorendc 2013-03-24 22:01:58 UTC
Seems like this is fixed. I can not reproduce this anymore using Linux Mint 14 x4 with LibreOffice Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c). Therefore I mark this bug as RESOLVED WORKSFORME (we don't know which commit fixed this issue, therefore mark it as WORKSFORME, not FIXED).

@Andrew: If this is still an issue, please feel free to REOPEN this bug.

Kind regards,
Joren