Download it now!
Bug 31070 - PDF export does not export color text
Summary: PDF export does not export color text
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) other
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-23 19:10 UTC by Andy Brown
Modified: 2010-10-28 11:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File I am using. (121.90 KB, application/vnd.oasis.opendocument.text)
2010-10-23 19:10 UTC, Andy Brown
Details
Minimum file triggering the wrong behavior (10.16 KB, application/vnd.oasis.opendocument.text)
2010-10-26 01:04 UTC, Giuseppe Castagno (aka beppec56)
Details
Minimum file which exports right to PDF. (8.59 KB, application/vnd.oasis.opendocument.text)
2010-10-26 01:13 UTC, Giuseppe Castagno (aka beppec56)
Details
Resulting export file (166.91 KB, application/pdf)
2010-10-27 13:31 UTC, Andy Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Brown 2010-10-23 19:10:41 UTC
Created attachment 39658 [details]
File I am using.

Here Ubuntu 9.10 with LibreOffice Beta2, OOO330m build 3.2.99.2

When using pdf export test is exported as black not in color.  From replies this seems to only effect some Linux versions.
Comment 1 Marc Pare 2010-10-24 18:15:37 UTC
This also occurs on my Mandriva 2010.1, KDE 4.5.0 desktop with Acrobat reader 9.3.4

Marc
Comment 2 clio 2010-10-24 22:44:53 UTC
The same is with Ubuntu 10.04.
Comment 3 Giuseppe Castagno (aka beppec56) 2010-10-25 00:36:37 UTC
Tested on Ubuntu 9.10, 64 bit, current build OOO330_m12 bug still exists.
Comment 4 Giuseppe Castagno (aka beppec56) 2010-10-25 00:37:46 UTC
Added Caolan, since this bug may be somewhere in the vcl layer.
Comment 5 Giuseppe Castagno (aka beppec56) 2010-10-26 01:04:54 UTC
Created attachment 39777 [details]
Minimum file triggering the wrong behavior

The attached file I obtained removing all the item from the first file attached and leaving a minimum to demonstrate the bug.
I carried out the editing operation using OOo 3.2.1.

Exporting to PDF from OOo 3.2.1 there is no problem.

The problem pops up if you export with LibO, current dev.

I didn't try with current RC2 of OOo 3.3.0, but I bet the problem exists there as in LibO.

I'm going to attach another file after this, very similar, but in which the problem doesn't seem to exist.
Comment 6 Giuseppe Castagno (aka beppec56) 2010-10-26 01:13:49 UTC
Created attachment 39778 [details]
Minimum file which exports right to PDF.

This file doesn't trigger the wrong exporting behavior.
I created it from scratch, it's a bare minimum, similar to attachment 39777 [details].

I edited it with LibO.
Comment 7 Andy Brown 2010-10-26 10:13:50 UTC
Giuseppe,

How did you get it to work?
Comment 8 Giuseppe Castagno (aka beppec56) 2010-10-26 10:26:45 UTC
@Andy: I simply wrote it (attachment 39778 [details]) anew, from scratch; trying to keep same page dimensions, etc...

Unfortunately ATM I don't know what triggers the wrong behavior.
It seems something hidden in the document.

I didn't have time to look for it.
Comment 9 Noel Power 2010-10-27 03:07:29 UTC
have you tried with beta2 ( works for me with attached doc ) on opensuse11.3
Comment 10 Andy Brown 2010-10-27 12:37:09 UTC
The problem is with the original document.  Created from new, copy/pasted the text and the exporting works as expected.  No sure what older files this may affect so I would not call it "solved" yet.  Maybe reduce the importance till others have the same problem.
Comment 11 Noel Power 2010-10-27 13:13:54 UTC
(In reply to comment #10)
> The problem is with the original document.  Created from new, copy/pasted the
> text and the exporting works as expected.  No sure what older files this may
> affect so I would not call it "solved" yet.  Maybe reduce the importance till
> others have the same problem.

I tested with your original file from comment #0 and like I said can't reproduce with beta2 ( opensuse 11.3 ) Otoh I didn't read your first comment carefully enough where you say that you indeed use beta2 :-/ I wonder can you upload the exported document too, maybe someone might be able figure out something from that too
Comment 12 Andy Brown 2010-10-27 13:31:38 UTC
Created attachment 39819 [details]
Resulting export file
Comment 13 Andy Brown 2010-10-27 13:35:44 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > The problem is with the original document.  Created from new, copy/pasted the
> > text and the exporting works as expected.  No sure what older files this may
> > affect so I would not call it "solved" yet.  Maybe reduce the importance till
> > others have the same problem.
> 
> I tested with your original file from comment #0 and like I said can't
> reproduce with beta2 ( opensuse 11.3 ) Otoh I didn't read your first comment
> carefully enough where you say that you indeed use beta2 :-/ I wonder can you
> upload the exported document too, maybe someone might be able figure out
> something from that too

I do not see where it will help but uploaded a copy.  But as I also said "From replies this seem to only effect some Linux version".  It also happens in OOo 3.3RC2.
Comment 14 Noel Power 2010-10-28 01:35:41 UTC
hmm I think (maybe?) you have some rendering problems on your system, I open your export file in evince and I see lots of nice colors, I'm inclinded to think that this is not a problem related to libreoffice
Comment 15 Andy Brown 2010-10-28 07:32:53 UTC
A better example is in Comment 5.  It is the text, not the logo, that should be in color.  The headings should be green.
Comment 16 clio 2010-10-28 09:30:08 UTC
28.10.2010 04:35, bugzilla-daemon@freedesktop.org пишет:
> I open
> your export file in evince and I see lots of nice colors
There are no colorful text, just color icons the color LibreOffice logo, 
right?
Comment 17 Noel Power 2010-10-28 09:48:55 UTC
(In reply to comment #15)
> A better example is in Comment 5.  It is the text, not the logo, that should be
> in color.  The headings should be green.

you are right :-( I somehow read ( but you didn't say it ) that the whole pdf was in black ( & white ) sorry :-( Is there an equivalent openoffice issue ?
Comment 18 Andy Brown 2010-10-28 10:04:52 UTC
I am not sure it there is an open issue for OOo but the same thing happens with OOo 3.3 RC2.
Comment 19 clio 2010-10-28 10:18:22 UTC
If you open those files (Pamphlet_01.odt and Pamphlet_01-fdo31070-ooo321.odt)
with LibreOffice (or OOo 3.3.0RC2) and go to the File/Print... menu, go to the
tab "LibreOffice.org Writer". You will see the checkbox "Print text in black"
marked. They are stored in the settings.xml file. It's caused by the
"PrintBlackFonts"  boolean true value. You should unmark this checkbox, press
cancel (the setting will be stored anyway) and then export this file to pdf.
You should save the file in order for the setting to be stored in the document.
The next time you open it, you will not have to go to the "Print..." dialog.
Comment 20 Andy Brown 2010-10-28 10:48:30 UTC
Thanks.  I see what you mean.  That must be a default setting inserted in old documents as it does not happen in new ones.

I guess this issue can be closed.
Comment 21 clio 2010-10-28 10:57:10 UTC
The print module has changed from 3.2.1 to 3.3.0. It seems that PDF export now takes some settings from the print settings.
Comment 22 Noel Power 2010-10-28 11:04:15 UTC
(In reply to comment #21)
> The print module has changed from 3.2.1 to 3.3.0. It seems that PDF export now
> takes some settings from the print settings.

closing as invalid ( and nice catch about the print settings )