Download it now!
Bug 31076 - Create backup copy is unchecked
Summary: Create backup copy is unchecked
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-24 02:45 UTC by pierre-yves samyn
Modified: 2015-12-29 17:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2010-10-24 02:45:43 UTC
Hello

XP-SP3 - LibO 3.2.99.2 - buildid=330m9(Build:1)

Tools > Options > Load/Save > General > "Always create backup copy" is unchecked

Even if we can assume that performance research is the reason why this option is unchecked it should always be checked by default

Safety should take precedence over performance

Best regards
Comment 1 Noel Power 2010-10-27 04:15:22 UTC
I don't think this is an issue of performance but rather space, if you always create a backup copy then you will have double the amount of documents you create ( in a non-obvious location ) Additionally the backup may not do exactly what you thing, the back up keeps the *previous* version of the file and not the version you just saved. In these circumstances it is quite reasonable to make this a non-default option. Note: autorecovery is enabled by default
Comment 2 pierre-yves samyn 2010-10-27 05:49:27 UTC
Thank's for reply...

> I don't think this is an issue of performance but rather space, if you always
> create a backup copy then you will have double the amount of documents you
> create ( in a non-obvious location )

That may indeed be the reason ... If that is the case we could consider adding a parameter max occupancy or shelf life.

> Additionally the backup may not do exactly
> what you thing, the back up keeps the *previous* version of the file and not
> the version you just saved. 

Yes I know and I know I do not take this proposal out of nowhere. The file corruption problems are so regular on the french forum that a section had their being dedicated : http://user.services.openoffice.org/fr/forum/viewforum.php?f=35

I also wrote a mini tutorial on this issue : http://user.services.openoffice.org/fr/forum/viewtopic.php?f=29&t=24511

The fact that problems often come from poor use of USB support does not diminish the loss of the document and the disappointment of users to discover "after the fact" that one option could have them save their document.

Note that this request is also included in the survey: http://wiki.services.openoffice.org/wiki/User_Experience/Improving_OOo_Default_Settings

> In these circumstances it is quite reasonable to
> make this a non-default option. 

Well this is a point of view but I do not share
Comment 3 Noel Power 2010-10-27 08:36:37 UTC
(In reply to comment #2)
> > I don't think this is an issue of performance but rather space, if you always
> > create a backup copy then you will have double the amount of documents you
> > create ( in a non-obvious location )
> 
> That may indeed be the reason ... If that is the case we could consider adding
> a parameter max occupancy or shelf life.
> 
I don't know that introducing even more options in this area would make things clearer :-(
> > Additionally the backup may not do exactly
> > what you thing, the back up keeps the *previous* version of the file and not
> > the version you just saved. 
> 
> Yes I know and I know I do not take this proposal out of nowhere. The file
> corruption problems are so regular on the french forum that a section had their
> being dedicated :
> http://user.services.openoffice.org/fr/forum/viewforum.php?f=35
[...]
don't read french but.... would be even better to get to the root cause of what sounds like endemic corruption problems
> Note that this request is also included in the survey:
> http://wiki.services.openoffice.org/wiki/User_Experience/Improving_OOo_Default_Settings
that's interesting, but I suppose it doesn't either indicate the amount of support for changing that option or not.
> 
> > In these circumstances it is quite reasonable to
> > make this a non-default option. 
> 
> Well this is a point of view but I do not share
:-) sure, and the beauty of this project is that it is in your power to change things, 
 a) poke the list, see if there are any major objections to making this change ( and the change required I would guess probably doesn't even require coding but just finding the correct config file in the build tree to change )
 b) propose a patch
 c) submit the patch

chances are it will even get accepted :-)
Comment 4 richard_g 2011-12-02 09:00:14 UTC
Hello.

This Issue should no longer be considered as WONTFIX. You should look at
the amount of lost data in the "Récupération de documents" section of the
french OOo forum, and I guess this is the same thing on other forums.

The argument that checking by default the "Always create backup copy" would
make too many copies and would need too much disk space is invalid with the
disk capacities we have now. We are no longer at the Stone age of computers. I
have this option checked, and I am also using an Incremental copy extension, so
I have ten or more copies of each of my files, and I am very far from lacking
of disk space.

The "Always create backup copy" option should be checked by default for
beginners who don't know that it exists.Experimented users have always the
possibility to uncheck it.
Comment 5 vulcain 2014-03-27 20:27:05 UTC
Same problem on Ubuntu 12.04 with
Comment 6 vulcain 2014-03-27 20:30:18 UTC
Same problem on Ubuntu 12.04 with LibreOffice 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13

If disk space is a problem why create a feature who delete the older backup. The user often need the last backup not the one with there years old ....