Download it now!
Bug 31095 - LibO writer crashes when inserting a caption to a picture
Summary: LibO writer crashes when inserting a caption to a picture
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: high blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
: 31365 31452 31659 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-25 01:24 UTC by Yifan Jiang
Modified: 2012-05-04 01:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
crash stack (52.31 KB, text/x-log)
2010-10-25 01:26 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-25 01:24:15 UTC
Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.2 build 1

[Steps]

    1. Open Writer

    2. Insert a picture (I used a png file)

    3. Keep the picutre in focus and select from menu Insert->Caption

    4. Type any number of words and press 'OK'

    
[Problem]

    LibO simple crashes when trying to insert a caption of the picture
          
[Extra Information]

    This is not a problem in plain OO.o 3.3 build

    Crash stack attached
Comment 1 Yifan Jiang 2010-10-25 01:26:13 UTC
Created attachment 39755 [details]
crash stack
Comment 2 Michael Meeks 2010-10-25 03:49:59 UTC
Sounds like the known crash in beta2.

Can you reproduce with a master build ?
Comment 3 Yifan Jiang 2010-10-25 21:37:07 UTC
(In reply to comment #2)
> Sounds like the known crash in beta2.
> 
> Can you reproduce with a master build ?

Hi Michael, thanks for the info. The build I have here for testing is beta-2 (documentation.org/download). But it was probably resolved since I remember I didn't see the problem when using the latest m12 build (from anongit.freedesktop.org) yesterday at home...

btw, I was using Ubuntu 10.04 at home.
Comment 4 sophie 2010-11-01 09:58:56 UTC
Verified in the 10_10_28_Cedric.rpm version - Closing - Sophie
Comment 5 Cédric Bosdonnat 2010-11-04 08:59:00 UTC
*** Bug 31365 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2010-11-08 02:45:33 UTC
Modified OS due to DUPS, Reproducible with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)] 

This would have been a blocker vor 3.3.0!
Comment 7 Rainer Bielefeld Retired 2010-11-08 02:46:27 UTC
*** Bug 31452 has been marked as a duplicate of this bug. ***
Comment 8 sophie 2010-11-16 09:26:28 UTC
*** Bug 31659 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2010-11-18 02:47:08 UTC
Tested in beta3 this morning on MacOSX SnowLeopard. Problem resolved, buggy behaviour no longer present.

Alex
Comment 10 Roman Eisele 2012-05-04 01:01:25 UTC
This is a Writer issue, therefore changed 'Component' field accordingly.

Set Version according to comment #6 and comment #9 -- if this bug was fixed in 3.3b3, we can assign 3.3b2 (even if this is not completely true, it will help to see at a glance to which period of history this bug belongs ;-).