Download it now!
Bug 31125 - Impress hangs when opening a specific odp file
Summary: Impress hangs when opening a specific odp file
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL: http://www.openoffice.org/issues/show...
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2010-10-25 23:13 UTC by Yifan Jiang
Modified: 2015-12-15 11:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test data (836.30 KB, application/x-7z-compressed)
2010-10-25 23:19 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-25 23:13:42 UTC
Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.2 build 1

[Steps]

    1. Open the attached odp file via Impress
    
[Problem]

    The first page of the file could be show, but Impress frozes there when
    trying to do some operation in it.
          
[Extra Information]

    I am not sure if there's a way to get valuable log here, since it was
    hanging rather than crashing ... Please let me know if you need more
    information.

    I did not see this problem when opening several other random odp files.
Comment 1 Yifan Jiang 2010-10-25 23:19:18 UTC
Created attachment 39774 [details]
test data

It looks bzip is not compressive enough ... ...
Comment 2 Noel Power 2010-10-27 06:45:48 UTC
confirmed - > thorsten
Comment 3 Thorsten Behrens (CIB) 2010-11-26 14:15:54 UTC
Not a hang, but a severe performance issue in polygon triangulation code. Needs deeper investigation. Workaround: disable anti-aliasing in tools->options->view
Comment 4 Thorsten Behrens (CIB) 2010-11-26 14:25:28 UTC
Ah, just noticed this was reported & fixed at OOo - http://www.openoffice.org/issues/show_bug.cgi?id=115761 - and also I notice that m17 has just been merged. Fixed.
Comment 5 sophie 2011-01-15 04:18:30 UTC
Closing - Sophie
Comment 6 Roman Eisele 2012-05-04 00:57:38 UTC
This is an Impress issue, therefore changed 'Component' field accordingly.

Set Version according to original description (more or less exactly: it should be sufficient for today to see at one glance that this is a (pre-)3.3-issue).
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:05:10 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]