Download it now!
Bug 31134 - [Impress] Slide related background image lost after saving
Summary: [Impress] Slide related background image lost after saving
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-26 08:31 UTC by Eliot the Cougar
Modified: 2011-12-21 02:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eliot the Cougar 2010-10-26 08:31:29 UTC
Windows XP x86
LibreOffice 3.3 beta2

Create presentation with several empty slides
Set background image for all slides
Set different background image for any other slide (Not for all)
Save presentation
Close LibreOffice
Open saved presentation

All slides now have the very same background...
Comment 1 Noel Power 2010-10-27 07:57:21 UTC
yes, I see the same thing ( on linux ) -> thorsten
Comment 2 Eliot the Cougar 2010-10-27 09:16:25 UTC
By the way... The problem is: LibreOffice edits (in styles.xml) the only entry:
<draw:fill-image draw:name="background" xlink:href="some-link-here" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad" />
and replaces existing image file no matter if you choose to apply new backround to the current slide only...
It has to create new style "background2" and change content.xml accordingly... But...

Same happens in OpenOffice.org 3.2.1 :)

I had to edit .odp file manually in text editor: added background2 style, added .jpg file, edited manifest.xml accordingly and changed some slides in content.xml to use another background style... Voila!.. Now I can use two backgrounds by duplicating slides... Thank you, XML!.. If I create new empty slide it has black background and any change to that slide's background does not save... I thing I broke master-style somehow... If I have to use third background, I have to edit styles.xml again...

I hope, my "hand-made" scientific report presentation will look fine tomorrow on the machine with OpenOffice 3.1
Comment 3 Rainer Bielefeld Retired 2010-11-25 23:28:21 UTC
[Reproducible] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]", but only for background images, my test did not show any slide background color problems.

IMHO most presentations have the same background image for all slides, so currently I agree with Tor Lillqvist that this is not a blocker for LibO 3.3. But It's a serious limitation. 
It would be fine to find the reason for the problem to check whether this really only is a background image problem or whether other functions are related. If other problems are improbable enough I also would strike this one from the blockers list.
Comment 4 Eliot the Cougar 2010-12-23 01:05:05 UTC
Re-tested on LibO 3.3.0 RC2 to see if the bug was fixed by Merged Commit OOO330m18...
It wasn't... :(

Changed the Bug description to reflect the fact that the issue seems to affect all Platforms and Operating System... (Noel Power)
Comment 5 Eliot the Cougar 2010-12-24 02:49:29 UTC
Just a small question
Should I keep track of my commited bugreports and change the Version tag if the issue is still present in the latest version, or should I set the Version tag according to the earliest known version where the issue was first noticed?..

Right now it seems to me I should update Version tags when I test newer versions...
Comment 6 Thorsten Behrens (CIB) 2011-01-11 13:09:39 UTC
@eliot - yes, if you re-test, please update the version.
Comment 7 Daniel Armando Rodriguez 2011-03-18 08:03:42 UTC
Still happens in LibreOffice 3.3.1 OOO330m19 (Build:8)

Reproduced in:

    Ubuntu package 1:3.3.1-1ubuntu3~maverick1

    Debian 6.0 "Squeeze"

    WinXP SP3
Comment 8 chiro79 2011-04-05 06:41:01 UTC
Hello,

I have the same issue. But instead of lose the background I lose some repeated pictures, like a heading image.

It happens randomly for me.

I use linux (KUbuntu) and LibreOffice 3.3.2.
Comment 9 Eliot the Cougar 2011-12-21 02:45:51 UTC
Just tested it in LODev 3.5... Mark as FIXED
Style entries for different backgrounds are created and assigned correctly to individual slides...