Download it now!
Bug 31141 - Calc crashes while saving a XLS document
Summary: Calc crashes while saving a XLS document
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Katarina Behrens
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-26 13:19 UTC by Gökçen Eraslan
Modified: 2012-05-04 00:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Stack trace of crash (5.40 KB, text/plain)
2010-10-26 13:19 UTC, Gökçen Eraslan
Details
Document that makes libreoffice crash (50.50 KB, application/vnd.ms-excel)
2010-10-26 13:21 UTC, Gökçen Eraslan
Details
Crashes saving as .xls (17.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-11-21 09:06 UTC, Liz Young
Details
Backtrace with line numbers (9.85 KB, text/plain)
2010-11-22 23:29 UTC, Gökçen Eraslan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gökçen Eraslan 2010-10-26 13:19:55 UTC
Created attachment 39796 [details]
Stack trace of crash

When I try to save a XLS document, oocalc crashes. Stack trace and the document is attached.

LibreOffice is 3.2.99.2 version.
Comment 1 Gökçen Eraslan 2010-10-26 13:21:07 UTC
Created attachment 39797 [details]
Document that makes libreoffice crash

Make some changes and try to save to reproduce the crash.
Comment 2 Noel Power 2010-10-27 08:03:15 UTC
works for me ( with beta2 ) did you try with libreoffice beta2?
Comment 3 Gökçen Eraslan 2010-10-27 10:13:04 UTC
(In reply to comment #2)
> works for me ( with beta2 ) did you try with libreoffice beta2?

Yes, I'm trying and reproducing it with Beta2. Are you saving the document as xls? When I save it as ods, it's OK, but if I try to save in xls, oocalc crashes, and the backtrace is attached.
Comment 4 Noel Power 2010-10-27 10:53:52 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > works for me ( with beta2 ) did you try with libreoffice beta2?
> 
> Yes, I'm trying and reproducing it with Beta2.
<sigh> dissappointing 
> Are you saving the document as
> xls? 

yup, I am saving as xls, and the backtrace is not very useful unfortunately and even running with valgrind doesn't yield any clues. You not by any chance building your own libreoffice ?
Comment 5 Gökçen Eraslan 2010-10-28 09:11:40 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > works for me ( with beta2 ) did you try with libreoffice beta2?
> > 
> > Yes, I'm trying and reproducing it with Beta2.
> <sigh> dissappointing 
> > Are you saving the document as
> > xls? 
> 
> yup, I am saving as xls, and the backtrace is not very useful unfortunately 

I've extracted all the tarballs and got backtrace again, but it's the same. If you can tell me a way for getting a better trace I can try it. Now I install debug symbol packages and run:

gdb ./soffice.bin

run -norestore -nologo -calc

and follow steps to reproduce the bug.

and
> even running with valgrind doesn't yield any clues. You not by any chance
> building your own libreoffice ?

I'm the LibreOffice package maintainer of Pardus Linux, so yes, I'm building my own LibreOffice from 3.2.99.2 sources.

By the way, I'm using KDE4 GUI for LibreOffice in KDE 4.5.2, maybe this is related.
Comment 6 Noel Power 2010-10-28 09:52:32 UTC
(In reply to comment #5)
[...]
> I'm the LibreOffice package maintainer of Pardus Linux, so yes, I'm building my
> own LibreOffice from 3.2.99.2 sources.
> 
great, can you build sc with debug ( e.g. build debug=t ) that way well get some line numbers too.

> By the way, I'm using KDE4 GUI for LibreOffice in KDE 4.5.2, maybe this is
> related.
wouldn't think so :-/
Comment 7 Thorsten Behrens (CIB) 2010-11-18 15:42:24 UTC
Gökcen, any news on this?
Comment 8 Liz Young 2010-11-21 09:04:14 UTC
LibreOffice 3.3.0 
OOO330m12 (Build:2)
libreoffice-build 3.2.99.3
(LibO_3.3.0beta3_20101115_Linux_x86_install-deb_en-US)
Ubuntu 10.04.1 LTS 32bit

Can consistently recreate this crash with the attached Pardus document.
Select File > Save As...
Change "All Formats" to "Microsoft Excel 97/2000/XP (.xls)"
Click Save.
The program disappears and the file is not saved.  Re-launching and running Document Recovery works to re-open the file.

This also occurs with all of my existing .ods files (did not crash with Beta2) saving to .xls. Can consistently recreate with the following attachment b3crashtest.ods.  There is no problem saving to .xlsx.  Did not test other formats.
Comment 9 Liz Young 2010-11-21 09:06:48 UTC
Created attachment 40455 [details]
Crashes saving as .xls
Comment 10 Gökçen Eraslan 2010-11-21 12:36:55 UTC
(In reply to comment #7)
> Gökcen, any news on this?

I will compile beta3 with debug options and provide a better trace in a while.
Comment 11 Gökçen Eraslan 2010-11-22 23:29:10 UTC
Created attachment 40493 [details]
Backtrace with line numbers

Here is the stack trace with line number. sc module is built with debug=t parameter.
Comment 12 Gökçen Eraslan 2010-11-22 23:34:17 UTC
(In reply to comment #11)
> Created an attachment (id=40493) [details]
> Backtrace with line numbers
> 
> Here is the stack trace with line number. sc module is built with debug=t
> parameter.

I think the "second" member of itRow is NULL, here is the output when I was trying to print itRow:

(gdb) l
2110                ++itrBlkEnd;
2111
2112            // write the ROW records
2113            RowMap::iterator itRow;
2114            for( itRow = itrBlkStart; itRow != itrBlkEnd; ++itRow )
2115                itRow->second->Save( rStrm );
2116
2117            // write the cell records
2118            for( itRow = itrBlkStart; itRow != itrBlkEnd; ++itRow )
2119                 itRow->second->WriteCellList( rStrm );
(gdb) p itRow
$1 = {first = 272, second = {px = , pn = {pi_ = }}}
(gdb) p itRow->second
There is no member or method named second.
Comment 13 Thorsten Behrens (CIB) 2010-11-23 02:22:50 UTC
Bubli, could you have a look please?
Comment 14 Katarina Behrens 2010-11-25 08:02:00 UTC
This should be fixed in 3.3 branch (git commit c9b21c9580204dc)
Tested both document attached to this issue - it no longer crashes.
Comment 15 Liz Young 2010-12-06 11:15:59 UTC
RC1. This is no longer reproducible and is saving correctly on my systems with both attachments.

LibreOffice 3.3.0 
OOO330m17 (Build:3)
libreoffice-build 3.3.0.1
Ubuntu 10.04.1 LTS 32bit

Thanks all!
Comment 16 Gökçen Eraslan 2010-12-06 11:46:47 UTC
(In reply to comment #15)
> RC1. This is no longer reproducible and is saving correctly on my systems with
> both attachments.

Yeah, this is why the bug is marked as fixed :)
Comment 17 sophie 2011-01-13 02:25:13 UTC
Verified - Closed - Sophie
Comment 18 Björn Michaelsen 2011-12-22 05:36:44 UTC
Remove infoprovider from closed and resolved bugs.
Comment 19 Roman Eisele 2012-05-04 00:54:41 UTC
This is a Calc issue, therefore changed 'Component' field accordingly.