Download it now!
Bug 31183 - Writer crashes when comparing selected documents.
Summary: Writer crashes when comparing selected documents.
Status: RESOLVED DUPLICATE of bug 30921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-27 23:06 UTC by Yifan Jiang
Modified: 2013-11-23 13:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
testdata - i65094a.odt (276.58 KB, application/vnd.oasis.opendocument.text)
2010-10-27 23:06 UTC, Yifan Jiang
Details
testdata - i65094b.odt (318.15 KB, application/vnd.oasis.opendocument.text)
2010-10-27 23:07 UTC, Yifan Jiang
Details
crash stack (44.91 KB, text/plain)
2010-10-27 23:07 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-27 23:06:35 UTC
Created attachment 39830 [details]
testdata - i65094a.odt

Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.2 build 1

[Steps]

    1. Open attached file i65094a.odt

    2. Select from menu Edit->Compare Document...

    3. compare it with i65094b.odt

[Problem]

    LibO crashes.
          
[Extra Information]

    - This is a regression to OO.o 3.2.1

    - Vanilla OO.o 3.3 does not have this problem

    - There might be some useful info in the original bug, which birth the    
    testing data

        http://www.openoffice.org/issues/show_bug.cgi?id=65094

    - crash stack attached
Comment 1 Yifan Jiang 2010-10-27 23:07:08 UTC
Created attachment 39831 [details]
testdata - i65094b.odt
Comment 2 Yifan Jiang 2010-10-27 23:07:44 UTC
Created attachment 39832 [details]
crash stack
Comment 3 Cédric Bosdonnat 2010-10-28 02:54:20 UTC
Same backtrace than bug 30921. Not reproducable in master branch

*** This bug has been marked as a duplicate of bug 30921 ***
Comment 4 Roman Eisele 2012-05-04 06:45:39 UTC
This is a Writer issue, therefore changed the 'Component' field accordingly.

'Version' field set according to original description.