Download it now!
Bug 31186 - libreoffice fails to build with --with-lightproof unless --with-extension-integration is also specified
Summary: libreoffice fails to build with --with-lightproof unless --with-extension-int...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: All Linux (All)
: medium normal
Assignee: Kami
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 01:10 UTC by Bernhard Rosenkraenzer
Modified: 2011-01-22 08:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2010-10-28 01:10:06 UTC
Checking Shortcut assignments ...

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_1 !

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_2 !

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_0 !
Checking missing parents ...

ERROR: Parent "gid_Module_Optional_Extensions_Sun_Template_Pack" at Module "gid_Module_Optional_Extensions_Sun_T_Pack_Root_hr" is not defined!
dmake:  Error code 255, while making '../unxlngx6.pro/bin/osl/setup_osl.ins'

1 module(s): 
        scp2
need(s) to be rebuilt
Comment 1 Noel Power 2010-10-28 04:48:20 UTC
hopefully petr might know something about this
Comment 2 Bernhard Rosenkraenzer 2010-11-04 02:10:41 UTC
FWIW pretty much the same thing happens when the sun template pack is disabled but lightproof is enabled:


Checking Shortcut assignments ...

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_1 !  

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_2 !  

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_0 !  
Checking missing parents ...

ERROR: Parent "gid_Module_Optional_Extensions_LightProof" at Module "gid_Module_Optional_Extensions_LightProof_Root_fi" is not defined!
dmake:  Error code 255, while making '../unxlngx6.pro/bin/osl/setup_osl.ins'

1 module(s):
        scp2
need(s) to be rebuilt


Probably the same bug...
Comment 3 Bernhard Rosenkraenzer 2010-11-05 04:37:09 UTC
Both of these happened in a build with --with-lang=ALL, so the problem may be related to trying to build extensions for languages in which they aren't available.
Comment 4 Petr Mladek 2010-11-19 10:47:30 UTC
I am not able to reproduce it with the current libreoffice-3-3 branch. I used:

./autogen.sh --with-distro=LibreOfficeLinux --with-package-format="rpm deb" --without-junit --without-git --with-max-jobs=6 --with-num-cpus=4 --with-lang="ALL" --with-sun-templates --with-lightproof

I see the warnings about gid_File_Lib_Graphite but no errors.

Berhard, do you still see it?

What exact configure options are you using?
Comment 5 Bernhard Rosenkraenzer 2010-12-08 14:48:38 UTC
Still happens here with -rc1 (though it turns out lightproof and not the template pack is the culprit).

Error message from -rc1:


Entering /usr/src/ark/BUILD/libreoffice-build-3.3.0.1/build/libreoffice-3.3.0.1/sc
p2/util

Making:    setup_osl.ins

ERROR: Parent "gid_Module_Optional_Extensions_LightProof" at Module "gid_Module_Optional_Extensions_LightProof_Root_fi" is not defined!

par2script -i ../unxlngx6.pro/par,/usr/src/ark/BUILD/libreoffice-build-3.3.0.1/build/libreoffice-3.3.0.1/solver/330/unxlngx6.pro/par @@/tmp/mkMb9PNb -o ../unxlngx6.pro/bin/osl/setup_osl.ins
Reading par files
Collecting items
Collecting assigned items
Searching for Undefinitions
Removing assigned GIDs without definitions
Adding definitions without assignment to the root
Control of multiple assignments
                GID: gid_Brand_Dir_Share Assignments: 2
                GID: gid_Brand_Dir_Program Assignments: 2
Control of definitions with missing assignments
Checking directory definitions ...
Checking module definitions ...
Checking module assignments ...
Checking StarRegistry ...
Checking Root Module ... gid_Module_Root
Checking Shortcut assignments ...

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_1 !


        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_2 !

        WARNING: FileID gid_File_Lib_Graphite has no definition at shortcut gid_Shortcut_Lib_Graphite_0 !
Checking missing parents ...
dmake:  Error code 255, while making '../unxlngx6.pro/bin/osl/setup_osl.ins'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

 it seems that the error is inside 'scp2', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/bin/bash
cd /usr/src/ark/BUILD/libreoffice-build-3.3.0.1/build/libreoffice-3.3.0.1
source ./LinuxX86-64Env.Set.sh
cd scp2
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
sometimes (sadly) it is necessary to rm -Rf unxlngx6.pro in a module.
make: *** [stamp/build] Error 1



On a side note, the error message is also wrong, it should be rm -rf, not rm -Rf
Comment 6 Petr Mladek 2010-12-09 04:25:38 UTC
Bernhard, what exact configure options are you using, please?
Comment 7 Bernhard Rosenkraenzer 2010-12-09 08:56:20 UTC
./configure --prefix=/usr --libdir=/usr/lib64 \
        --disable-gtk \
        --disable-gnome-vfs \
        --disable-gio \
        --disable-mediawiki \
        --disable-wiki-publisher \
        --disable-evolution2 \
        --enable-extra-template \
        --enable-extra-sample \
        --enable-layout \
        --enable-pam-link \
        --enable-xrender-link \
        --enable-build-noarch \
        --enable-extensions \
        --with-google-docs \
        --with-nlpsolver \
        --with-oooblogger \
        --with-numbertext \
        --with-lightproof \
        --without-gtk \
        --with-split \
        --enable-hunspell \
        --enable-opengl \
        --enable-kde4 \
        --enable-ogltrans \
        --enable-minimizer \
        --enable-presenter-screen \
        --enable-presenter-console \
        --enable-pch \
        --enable-pdfimport \
        --without-myspell-dicts \
        --without-nas \
        --without-junit \
        --with-openldap \
        --with-system-stdlibs \
        --with-system-cairo \
        --with-system-dicts \
        --with-system-zlib \
        --with-system-openssl \
        --with-system-jpeg \
        --with-system-expat \
        --with-system-libwpd \
        --with-system-libwps \
        --with-system-libwpg \
        --with-system-libxml \
        --with-system-python \
        --with-system-icu \
        --with-system-poppler \
        --with-system-db \
        --with-system-lucene \
        --with-lucene-core-jar=/usr/share/java/lucene-core.jar \
        --with-lucene-analyzers-jar=/usr/share/java/lucene-analyzers.jar \
        --with-system-mysql \
        --with-system-libxslt \
        --with-system-odbc-headers \
        --with-system-sane-header \
        --with-system-xrender-headers \
        --with-system-mesa-headers \
        --with-system-curl \
        --with-system-boost \
        --with-system-neon \
        --with-system-agg \
        --with-system-hunspell \
        --with-system-cppunit \
        --with-system-redland \
        --with-system-allocation \
        --with-system-mdbtools \
        --with-system-xml-apis \
        --with-xml-apis-jar=/usr/share/java/xml-apis.jar \
        --with-system-xerces \
        --with-xerces-jar=/usr/share/java/xercesImpl.jar \
        --with-system-xalan \
        --with-system-xt \
        --with-xt-jar=/usr/share/java/xt.jar \
        --with-system-vigra \
        --with-system-graphite \
        --with-linker-hash-style=gnu \
        --without-binsuffix \
        --without-stlport \
        --disable-mono \
        --enable-access \
        --enable-vba \
        --disable-cairo \
        --disable-mono \
        --disable-odk \
        --enable-openxml \
        --enable-split-app-modules \
        --enable-split-opt-features \
        --disable-pch \
        --disable-fontooo \
        --enable-fontconfig \
        --enable-kde4 \
        --disable-gconf \
        --enable-pam-link \
        --enable-xrender-link \
        --with-jdk-home=$JAVA_HOME \
        --with-distro=Ark \
        --with-vendor="Ark Linux" \
        --with-sun-templates \
        --with-source-version=3.3.0.1 \
        --with-java-target-version=5 \
        --with-db-jar-so=/usr/lib64/libdb.jar.so \
        --with-xml-apis-jar-so=/usr/lib64/libxml-apis.so \
        --with-xerces-jar-so=/usr/lib64/libxercesImpl.so \
        --with-xt-jar-so=/usr/lib64/libxt.so \
        --with-dict-path=/usr/share/myspell \
        --with-thes-path=/usr/share/myspell \
        --with-hyph-path=/usr/share/myspell \
        --with-alloc=system \
        --enable-xsltproc \
        --with-docdir=/usr/share/doc/libreoffice-3.3.0.1 \
        --with-openclipart=/usr/share/openclipart \
        --with-icons="crystal" \
        --disable-symbols \
        --disable-debug \
        --disable-dbgutil \
        --enable-presenter-console \
        --enable-layout \
        --with-build-version="Ark Linux libreoffice-3.3.0-0.rc1.1ark" \
        --with-num-cpus=8 \
        --without-git \
        --with-lang="af ar as ast be-BY bg bn bo br brx bs ca ca-XV cs cy da de dgo dz el en en-GB en-US en-ZA eo es et eu fa fi fr ga gl gu he hi hr hu id is it ja ka kid kk km kn ko kok ks ku lt lv mai mk ml mn mni mr my nb ne nl nn nr ns oc om or pa-IN pl pt pt-BR ro ru rw sa-IN sat sd sh si sk sl sq sr ss st sv sw-TZ ta te tg th tn tr ts ug uk uz ve vi xh zh-CN zh-TW zu"
Comment 8 Bernhard Rosenkraenzer 2010-12-09 08:59:50 UTC
I don't fully understand the OOo/LibO build system, but I think I found the problem:

scp2/source/extensions/module_extensions.scp defines gid_Module_Optional_Extensions_LightProof inside

#ifdef WITH_EXTENSION_LIGHTPROOF
#ifdef WITH_EXTENSION_INTEGRATION

while

scp2/source/extensions/module_extension_lightproof.scp defines various things (incl. gid_Module_Optional_Extensions_LightProof_Root_fi) with parent gid_Module_Optional_Extensions_LightProof inside

#ifdef WITH_EXTENSION_LIGHTPROOF

(note the absence of #ifdef WITH_EXTENSION_INTEGRATION)

Sure enough, looking at my configs, I had WITH_EXTENSION_LIGHTPROOF but not WITH_EXTENSION_INTEGRATION defined.

Currently rebuilding with --with-extension-integration, pretty sure that will fix it.

Is there any reason why --with-lightproof and friends don't imply --with-extension-integration? That may be a better fix than adding #ifdef WITH_EXTENSION_INTEGRATION around all the definitions missing it...
Comment 9 Bernhard Rosenkraenzer 2010-12-10 04:16:23 UTC
I can now confirm that adding --with-extension-integration fixes this.
Is there any reason why --with-lightproof and friends don't imply --with-extension-integration?
Comment 10 Petr Mladek 2010-12-10 08:39:47 UTC
Bernhard, thanks for the analyze. It helped a lot.

It seems that --with-lightproof, --with-minimizer, ... define whether the particular extension is built.

--with-extension-integration defines if the built extensions are installed by the native installer. It makes sense to disable it in the --simple mode that is used by Linux distro packagers and developers. They needed to package the extensions a special way.

The problem is that "gid_Module_Optional_Extensions_LightProof" is defined only when --with-lightproof and --with-extension-integration are used together.  
Though, "gid_Module_Optional_Extensions_LightProof_Root_fi" depends on "gid_Module_Optional_Extensions_LightProof" and is defined when --with-lightproof is used => it ignores the --with-extension-integration option.

The right fix should be to add #ifdef WITH_EXTENSION_INTEGRATION around the "gid_Module_Optional_Extensions_LightProof_Root_fi" definition.

KAMI is going to look at it.
Comment 11 Kami 2010-12-10 09:26:32 UTC
Bug fixed in 432ca3d03da329e296ef3b4b1079a97f302743af (libreoffice-3-3)

Currently we require --with-extension-integration for any extension integration. This may change in the future.
Comment 12 sophie 2011-01-22 08:54:13 UTC
Closed - Sophie