Download it now!
Bug 31187 - Template Pack and Lightproof don't see requested languages with --with-lang=ALL
Summary: Template Pack and Lightproof don't see requested languages with --with-lang=ALL
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Petr Mladek
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 01:25 UTC by Bernhard Rosenkraenzer
Modified: 2011-01-15 04:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Proposed patch (1.05 KB, patch)
2010-10-28 01:33 UTC, Bernhard Rosenkraenzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2010-10-28 01:25:03 UTC
configure.in checks the list of requested languages against the list of languages supported by the Template Pack and the Lightproof extension.

In both cases, the supported languages are checked against $with_lang - which fails if with_lang=ALL (none of the supported languages matches the word ALL, and ALL is expanded elsewhere.
Comment 1 Bernhard Rosenkraenzer 2010-10-28 01:33:17 UTC
Created attachment 39837 [details]
Proposed patch
Comment 2 Noel Power 2010-10-28 04:49:51 UTC
the patch looks good to me ( but what do I know ) Anyway with the feature freeze in 2 days I am reluctant to push something in the build/packaging arena, Petr I guess would be better to look at this
Comment 3 Petr Mladek 2010-11-01 09:39:55 UTC
It is bugfix. It looks fine => can be commited even on this stage.

Commited as http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?id=f6f6e5409a930d2213041b9b4b151ed4eac929d0

I am going to cherry pick it to the newly created libreoffice-3-3 branch as well.
Comment 4 sophie 2011-01-15 04:01:00 UTC
Closing - Sophie