Download it now!
Bug 31190 - After "data to fields" mail merge won't work
Summary: After "data to fields" mail merge won't work
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 03:10 UTC by Davide Pesenti
Modified: 2012-05-04 00:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch to review for 3.3 (1.34 KB, patch)
2010-12-02 04:57 UTC, Cédric Bosdonnat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Pesenti 2010-10-28 03:10:44 UTC
Using mail merge within a text document, if I click on "data to fields" icon, save the doc, closeit, reopen it and try to print it, the print process just asks if i want to do a mail merge, but nothing happens.

Without data in filds, it works fine.

How to reproduce the bug:

1) Create a text doc and insert fields from a registered database.
2) Select a record on the data source and click on "data to fields"
3) Save the doc and close.
4) Open the doc and file->print

See it in action: http://mrjive.it/~mrjive/tmp/mailmergebug-1.ogv
Comment 1 Davide Pesenti 2010-10-29 00:47:55 UTC
Actually I discovered that the problem is that mailmerge won't work at all after save/close/open. So maybe I should change the subject of the bug report.

I'm running LO (but the same with OOo) on debian GNU/Liniux (both 32 and 64).
OOo -> debian package
LO -> downloaded from documentfoundation.org

Can anyone confirm this please?
Comment 2 Rainer Bielefeld Retired 2010-11-20 03:13:55 UTC
[Reproducible] with my own mail merge data base and  "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.2)]"
Comment 3 Yifan Jiang 2010-12-01 23:32:54 UTC
For cedric?

I tried this 'step by step' referring to the video. But:

I could reproduce it in:

- LibreOffice 3.3 beta3 - SLED 11 sp1 x64

I could NOT reproduce it in:
 
- LibreOffice 3.3 beta3 - SLED 11 sp1 i586 
- LibreOffice 3.3 beta3 - Windows XP 32
Comment 4 Cédric Bosdonnat 2010-12-02 04:57:32 UTC
Created attachment 40737 [details]
Patch to review for 3.3
Comment 5 Michael Meeks 2010-12-02 05:44:18 UTC
Patch looks reasonable to me; but we're getting really close to release ... if we broke this code path completely - what would break ? - all of mail-merge, or the (already not working) data->fields functionality ? :-)
Comment 6 Cédric Bosdonnat 2010-12-02 07:17:57 UTC
(In reply to comment #5)
> Patch looks reasonable to me; but we're getting really close to release ... if
> we broke this code path completely - what would break ? - all of mail-merge, or
> the (already not working) data->fields functionality ? :-)

Only the already not working print feature with merge would be affected by this patch.
Comment 7 Michael Meeks 2010-12-03 02:12:12 UTC
Then lets get it in :-) thanks !
Comment 9 sophie 2011-01-22 07:55:47 UTC
Verified in RC4 - Closed - Sophie
Comment 10 Roman Eisele 2012-05-04 00:53:51 UTC
This is a Writer issue, therefore changed 'Component' field accordingly. This also allows us to remove the '[WRITER]' from teh Summary.