Download it now!
Bug 31201 - A odt file make Writer freeze.
Summary: A odt file make Writer freeze.
Status: CLOSED DUPLICATE of bug 31199
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 07:56 UTC by winlin0330
Modified: 2013-11-23 13:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
The odt that will freeze writer (13.51 KB, application/vnd.oasis.opendocument.text)
2010-10-28 07:56 UTC, winlin0330
Details
Log of strace. (606.26 KB, application/x-bzip2)
2010-10-28 08:01 UTC, winlin0330
Details
Screenshot of file content. (37.50 KB, image/png)
2010-10-28 16:25 UTC, winlin0330
Details
I package the font and odt into a 7-zip file. (2.89 MB, application/x-7z-compressed)
2012-04-26 21:42 UTC, winlin0330
Details

Note You need to log in before you can comment on or make changes to this bug.
Description winlin0330 2010-10-28 07:56:08 UTC
Created attachment 39864 [details]
The odt that will freeze writer

Hi,
I have a odt file that will freeze Writer.
Please open the attachment, scroll down to the end of file, and click "CLICK HERE WILL FREEZE WRITER", then Writer will be freezed.

ps.
Please apply this traditional chinese font to test the odt file:
http://cle.linux.org.tw/fonts/cwttf/center/cwheib.ttf

Thanks~
Comment 1 winlin0330 2010-10-28 08:01:19 UTC
Created attachment 39865 [details]
Log of strace.
Comment 2 Cédric Bosdonnat 2010-10-28 08:32:29 UTC
There is no need to enter the same bug twice.

*** This bug has been marked as a duplicate of bug 31199 ***
Comment 3 winlin0330 2010-10-28 16:25:09 UTC
Created attachment 39874 [details]
Screenshot of file content.

(In reply to comment #2)
> There is no need to enter the same bug twice.
> 
> *** This bug has been marked as a duplicate of bug 31199 ***

Sorry. 
My browser crashed then. I am not sure whether it was submitted ,so I commit it again.
Here I add a screenshot of the odt file content.
Comment 4 winlin0330 2012-04-26 21:42:06 UTC
Created attachment 60648 [details]
I package the font and odt into a 7-zip file.

This bug is annoying to me for 2+ years, I lost lots of data again and again, please help me.
I found the download link of the truetype font was broken, so I  package the font and odt into a 7-zip file. (Don't worry, the font is licensed with GPL.)
If you need any information about this bug, please let me know, I will do my best to test it. Thank you~
Comment 5 Roman Eisele 2012-05-03 12:04:53 UTC
This is a Writer issue, therefore changed the 'Component' field accordingly.