Download it now!
Bug 31228 - Converting date to local default automatically
Summary: Converting date to local default automatically
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 23:03 UTC by Usama
Modified: 2012-08-31 10:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Usama 2010-10-29 23:03:08 UTC
Hi,

Calc is working as Gregorian to Hijri date converter. It assume that I'm inputting Gregorian and converts it to Hijri on local that depends on Hijri date (example: ar_SA)

The Problem:

if I enter,
1/1/1430 it will show like 6/04/833
1/1/2009 it will show 5/01/1430 (١٤٣٠/٠١/٥)

What should happen:
It should leave the date as entered.


Bug at openoffice.org:
http://www.openoffice.org/issues/show_bug.cgi?id=98616

Similar issue with Farsi date:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=6&t=14643

by the way, Congratulation on the freedom of Libreoffice. Best wishes.
Comment 1 Kohei Yoshida 2011-01-21 07:22:34 UTC
This is often requested, however, the difficulty of implementing this correctly is very high.
Comment 2 Björn Michaelsen 2011-12-23 11:33:52 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Rainer Bielefeld Retired 2012-07-20 05:40:31 UTC
@Usama Akkad
If this is still a problem for you please contribute test document and information how an English speaking user with English LibO can reproduce your problem.
Comment 4 Florian Reisinger 2012-08-14 13:59:18 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:00:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:05:11 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:07:14 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian