Download it now!
Bug 31242 - Remove outdated definitions from desktop/openoffice.xml
Summary: Remove outdated definitions from desktop/openoffice.xml
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 12:30 UTC by Raphael Kubo da Costa
Modified: 2012-08-31 10:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa 2010-10-30 12:30:25 UTC
Most (or all) of the mimetype definitions in desktop/openoffice.xml seem to have already been added upstream to shared-mime-info.

In some cases, the mimetype is changed when submitted upstream. For example, *.fodt is listed as application/vnd.oasis.opendocument.text in openoffice.xml, whereas shared-mime-info's freedesktop.xml lists it as application/vnd.oasis.document.text-flat-xml. This in turn can cause problems when running mimetype unit tests for KDE, and may also lead to conflicting mimetypes.

If it is not possible to remove openoffice.xml altogether, it would be nice to at least remove the mime definitions that are present in shared-mime-info.
Comment 1 David Faure 2010-11-02 09:18:01 UTC
For more information about what's already present in shared-mime-info: http://cgit.freedesktop.org/xdg/shared-mime-info/tree/freedesktop.org.xml.in
search for "fodt" for instance.
Comment 2 Björn Michaelsen 2011-12-23 11:34:35 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 13:59:56 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:01:05 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:05:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:07:50 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 David Faure 2012-08-17 18:18:50 UTC
I confirm that *.fodt is associated with application/vnd.oasis.opendocument.text-flat-xml
and *.fodp is associated with application/vnd.oasis.opendocument.presentation-flat-xml in /usr/share/mime/packages/libreoffice3.6.xml, coming from libreoffice3.6-suse-menus-3.6.1-1.noarch.rpm

That's still "duplicate definitions" with shared-mime-info, but at least they match.