Download it now!
Bug 31269 - LibreOffice reports that a JRE is required when closing
Summary: LibreOffice reports that a JRE is required when closing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Mac OS X (All)
: high blocker
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE-Warnings
  Show dependency treegraph
 
Reported: 2010-10-31 16:12 UTC by Patrick Bregman
Modified: 2012-08-31 08:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot of the error message I get (21.25 KB, image/png)
2010-10-31 16:12 UTC, Patrick Bregman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Bregman 2010-10-31 16:12:15 UTC
Created attachment 39936 [details]
A screenshot of the error message I get

When I quit the latest LibreOffice beta on my Mac OS X machine I get a message stating "LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice".

System version and architecture: Mac OS X 10.6.4 on a MacBook Pro 2010 (x86_64)
LibreOffice version: LibreOffice 3.3.0 / OOO330m9 (Build:1) / libreoffice-build 3.2.99.2
Steps to reproduce:
1. Open LibreOffice
2. Create a new Text Document
3. Open the About box
4. Quit the application (either through the menu or using Command-Q)
5. See the error appear

Expected result:
LibreOffice closes

Actual result:
I get a error message saying "LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice".

If you need more information or want me to test something, just ask and I'll see what I can do.
Comment 1 Patrick Bregman 2010-10-31 16:16:18 UTC
I just tried this again, and I noticed that there is some application starting and immediatly closing again in my dock. This is happening twice before I get the error. I think I see a coffeecup icon appearing just before the application disappears from the dock, this icon should be OS X' Java implentation.
Comment 2 Jason P 2010-11-03 14:11:24 UTC
I have also experienced this. I do NOT get this if I close from the File menu, but the Command-Q keystroke will produce every time.

The program that spawns twice and immediately quits is called JREProperties.
Comment 3 Patrick Bregman 2010-11-03 14:23:06 UTC
Slightly off-topic, I am getting this more and more. So I guess the JRE check is run at places where it is not completely needed. Currently I get it while adding/removing cells from a table...

I know this is the risc of running a pre-release version, but it is really starting to irritate me :(
Comment 4 Petr Mladek 2010-11-12 11:09:40 UTC
Thorsten, could you please look at it? It seems to block the MAC users.
Comment 5 Patrick Bregman 2010-11-12 15:22:23 UTC
Alright, I am getting more and more instances of this happening. A few that I noticed:
 - Zooming in or out via the dialog box
 - Giving focus to the page after having used another application
 - Sometimes when I enter another table or tablecell
All of those give the message and still execute the given command after closing the dialog.

I know my way around programming and I'm probably suggesting something stupid and/or hugely complex, but isn't it possible to completly disable the JRE in LibreOffice? This would at least give a temporary work-around and make it useable again.
Comment 6 Alex Thurgood 2010-11-15 06:52:16 UTC
Probably linked to the MacOS Java update, and the bug that that caused in the underlying OOo code. Patched files were made available (which work, having tested them on LibO Beta2), and apparently the whole thing was fixed in OOo 3.3 RC3 (but not yet tested on my Mac).

Whilst waiting for the next release of LibO beta (which should be synched with the latest 3.3 code base ??), try the interim patched files fix mentioned in issue 115180 of IssueTracker, which you can get from here :

ftp://qa-upload.services.openoffice.org/jl162/

Since the patched files work for me on Beta2, am setting as RESOLVED WORKSFORME. If the next Beta still has the problem, the issue should probably be reopened again.


Alex
Comment 7 Alex Thurgood 2010-11-15 06:56:11 UTC
I should probably add that issue 115180 contains instructions on symlinking - given that this tends to screw things up even more, I wouldn't go down that route, but check out the how-to install the patched files here : 

http://wiki.services.openoffice.org/wiki/Documentation/FAQ/Platform/Mac_OS_X_10.6


Alex
Comment 8 Patrick Bregman 2010-11-16 00:57:33 UTC
I agree with the WORKSFORME. I checked this on my machine and everything works fine now. It still launches the two processes, but that's something that I'll just have to learn to live with. Thanks!
Comment 9 Jason P 2010-11-16 05:51:21 UTC
I will confirm a "RESOLVED WORKSFORME" with this work around. I see the JREProperties still spawn twice upon closing the application, but no error message.