Download it now!
Bug 31352 - Show live results when changing format attributes
Summary: Show live results when changing format attributes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 04:59 UTC by Larsen
Modified: 2014-07-20 09:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
button, indentation working fine. (40.46 KB, image/jpeg)
2013-02-27 11:58 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larsen 2010-11-03 04:59:45 UTC
ATM, when you want to change e.g. the indentation of a paragraph you have to open the dialog, change the desired values and press Ok to see the changes.

It would be much nicer, when you could change the values and instantly see the results. The ancient Lotus Ami Pro could already do this.
Comment 1 Björn Michaelsen 2011-12-23 11:35:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Larsen 2011-12-23 13:04:51 UTC
This bug is an enhancement request, so I guess it´s ok to move it to NEW.
Comment 3 retired 2013-02-27 11:58:52 UTC
Created attachment 75629 [details]
button, indentation working fine.
Comment 4 retired 2013-02-27 11:59:16 UTC
I can't reproduce this on LO 4.0. From my experience no menu at all is needed. Just use the buttons on the top and you'll see instant results. Which menu are you referring to?

Setting to "WORKSFORME". Please re-open if this is still valid in LO 4.0.
Comment 5 Larsen 2013-02-27 12:41:09 UTC
Indentation was just an example. The menu I was referring to is opened when you select some text, right click, and choose the menu item above "cut" (don´t know what it is in English, in German it´s "Absatzvorlage bearbeiten" (perhaps "Format paragraph")).

There you can modify multiple aspects of the paragraph that allow way more than just the buttons.
Comment 6 Jean-Baptiste Faure 2014-05-01 21:14:22 UTC
Many formatting actions can be done directly using buttons or acting on the rules (paragraph indentation for example). Doing this way you can see instantly the effect of your action.

Please, could you list actions for which you need to open a dialog and it would be nice to see instantly the result of the modification?


Best regards. JBF
Comment 7 Larsen 2014-05-03 14:41:41 UTC
Yes, you can increase or decrease indentation by using the buttons, but this uses a fixed value. You cannot set the first line indentation to 0,2 cm and the following lines to 0,5 cm by using buttons. You have to use the corresponding dialog and if you want so see what your changes do, you have to close the dialog and then reopen it if you don´t like the changes and want to try other values of indentation.
Comment 8 Jean-Baptiste Faure 2014-07-20 09:04:07 UTC
Closing as WorksForMe because you can using the cursors on the horizontal rule and these cursors have tooltips showing the corresponding indentation values.

About "You cannot set the first line indentation to 0,2 cm and the following lines to 0,5 cm by using buttons." in comment #7 that is false because the cursor on the horizontal rule has 2 parts, the upper part is for the first line and the lower part for all lines.

Best regards. JBF