Download it now!
Bug 31359 - Problem to sign documents with smart card
Summary: Problem to sign documents with smart card
Status: CLOSED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 09:35 UTC by Gustavo Pacheco
Modified: 2012-12-12 12:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Digital Signature with smart card problem (screenshots) (406.20 KB, application/vnd.oasis.opendocument.text)
2010-11-03 09:35 UTC, Gustavo Pacheco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Pacheco 2010-11-03 09:35:46 UTC
Created attachment 40016 [details]
Digital Signature with smart card problem (screenshots)

Context: two users (User 1 and User 2)  need to sign a document with their digital signatures. They are in the same computer, using the account of User 1 (LibreOffice 3.3.0 Beta 2, Windows XP SP3, smart card with digital signature).

 - User 1 opens a saved document to sign in Writer

 - User 1 inserts his smart card in the Rockey Smart Card Reader 

 - in Writer, User 1 opens File > Digital Signatures...

 - User 1 opens a saved document to sign in Writer

 - User 1 inserts his smart card in the Rockey Smart Card Reader

 - in Writer, User 1 opens File > Digital Signatures...

 - User 1 clicks in Sign Document... button

 - LibreOffice recognizes the User 1´s digital signature and prompts the PIN dialog

 - User 1 inserts his PIN and selects his certificate, the document is signed by User 1 and User 1 removes his smart card

 - Now, the User 2 inserts his smart card to sign the same document 

 - User 2 opens File > Digital Signatures...

 - Writer shows the User 1's digital signature in the document

 - User 2 clicks in Sign Document...

 - Writer shows the PIN dialog, but here is the problem: even if User 2 types his PIN correctly, Writer doesn´t recognize the correct PIN and maintains the PIN's dialog opened. User 2 can put his PIN many times, but the dialog remains opened until User 2 clicks Cancel.

Additional information:

 - the digital signature and the PIN are OK in other applications;

 - there is a similar problem registered in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=593602

Thanks!
Gustavo.
Comment 1 Don't use this account, use tml@iki.fi 2010-11-04 01:46:21 UTC
Hmm, did you repeat the first three items in the scenario by accident, or is that really the exact scenario?
Comment 2 Gustavo Pacheco 2010-11-04 03:35:51 UTC
Hi! Thank you for comment!

It was an accident, sorry. Please, consider the repeated topics (the first three) only once.
Comment 3 Thorsten Behrens (CIB) 2010-11-18 16:10:32 UTC
Hm, Gustavo, this sounds like a somewhat seldom use case - by chance, does it work with OpenOffice.org 3.3?
Comment 4 Gustavo Pacheco 2010-11-29 09:00:48 UTC
  Hi Thorsten!
 
 Yes, we have this issue in OOo 3.3.0 (Beta or RCs). The problem is reproducible with the same digital signatures/smart cards.

 If you need more information about the smart cards or about the cenario, please, tell me.

 Thanks!
Comment 5 Thorsten Behrens (CIB) 2010-11-29 11:38:41 UTC
Gustavo, thanks for the info - adjusting importance accordingly.
Comment 6 Björn Michaelsen 2011-12-23 11:33:59 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 sasha.libreoffice 2012-02-23 02:02:28 UTC
In 3.5.0 version is still reproducible?
Comment 8 Gustavo Pacheco 2012-02-26 06:33:55 UTC
I'm still waiting information from the user side. The company where the bug occurs haven't started the 3.5.0 tests.
Comment 9 Florian Reisinger 2012-08-14 14:01:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 10 Florian Reisinger 2012-08-14 14:02:37 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:07:12 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:09:18 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian