Download it now!
Bug 31362 - RTF: new RTF export locks RTF file until LibO is closed
Summary: RTF: new RTF export locks RTF file until LibO is closed
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 10:39 UTC by André Schnabel
Modified: 2011-01-12 21:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description André Schnabel 2010-11-03 10:39:15 UTC
If a RTF file is opened using LibO, the file gets locked and the lock is kept, even if the file is closed. You need to close LibO completely to free the file again.

To reproduce simple open an rtf file, close it, try to open again
-> warning message appears, that the file is locked

this *might* be fixed with the new RTF export implementation,
 at least the problem occures on Windows and Ubuntu using beta2 builds but not on OpenSuse using build from surces as of 2010-10-01
Comment 1 Miklos Vajna 2010-11-03 11:19:35 UTC
I think I know what will be the problem here. ;)

Could you please confirm that this is now fixed by commit 120483d[1]?

(The Ubuntu part is not clear to me, I think this is reproducible on Windows only.)

Thanks

[1] http://cgit.freedesktop.org/libreoffice/writer/commit/?id=120483d
Comment 2 Kohei Yoshida 2010-11-09 06:44:18 UTC
Cedric, I believe Miklos has cherry-picked the fix to the 3.3 branch.  Could you verify that fixes the reported bug?  Thanks!
Comment 3 Cédric Bosdonnat 2010-11-09 07:06:07 UTC
(In reply to comment #2)
> Cedric, I believe Miklos has cherry-picked the fix to the 3.3 branch.  Could
> you verify that fixes the reported bug?  Thanks!

Indeed I can't reproduce it it in 3.3 branch with that commit.
Comment 4 sophie 2011-01-12 21:53:40 UTC
Verified - Closed - Sophie