Download it now!
Bug 31424 - Libreoffice Gnome Page Color Inherit
Summary: Libreoffice Gnome Page Color Inherit
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-05 23:15 UTC by Chris Carpenter
Modified: 2012-08-31 10:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots (602.66 KB, application/zip)
2010-11-05 23:15 UTC, Chris Carpenter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Carpenter 2010-11-05 23:15:07 UTC
Created attachment 40079 [details]
Screenshots

Libreoffice will use the gnome theme to set the default background and text colors for the document view of all applications. Abiword does not do this. I have screenshots, in a zip archive, attached showing how Abiword and each Libreoffice application reacts to the Darklooks theme included with Debian testing. Also included is a screenshot of the theme colors dialog box.


Expected result:  Libreoffice maintains the sane defaults of white background and black text for the main document view, even when the Gnome theme has different colors specified.

Actual result:    Libreoffice inherits the input box colors of gnome theme, and uses them to specify the background and text color color for the document view.

Steps to reproduce:

1. Change gnome theme to one with input box colors other than white background black text.(Or change your existing theme for the same effect)
2. Open any of the libreoffice applications.


Screenshots' Descriptions:

abiword.png: Reference shot of how Abiword handles the theme.

darklooksDialog.png: This screenshot simply shows the darklooks theme's color selections, which is the theme that all the screenshots are using.

libreBase.png:  This shows libreoffice base. Just general color mismatches here.

libreCalc.png: This shows libreoffice calc. Another one with no special issues that I saw.

libreDraw.png: This shows libreoffice draw. Nothing special found here.

libreImpress.png: This shows libreoffice impress. As you can see, it appears that something about the text color is tranlsating into the presentation, as the presentation is showing light grey text. Further testing needed.

libreMath.png: This shows libreoffice math. The icons in the elements toolbox look terrible to me.

libreSplash.png: This shows the splash screen that is launched from soffice binary. As shown, the text retains the light grey from the theme, but the background is white. This makes it hard to read. (Mousing over changes colors to theme colors)

libreWriter.png: This shows libreoffice writer. Nothing special here.


P.S: I could not test printing, as I don't have a printer on this computer. I would assume printing uses the actual colors set, not the display colors. However, print preview uses gnome theme colors. Also, opening one of these documents in another application(such as Abiword) does not retain the gnome theme colors, but uses black text and white background as automatic, or whatever colors you specified.
Comment 1 Björn Michaelsen 2011-12-23 11:35:27 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-02-23 02:02:17 UTC
With 3.5.0 still reproducible?
Comment 3 Florian Reisinger 2012-08-14 14:04:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:05:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:09:50 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:11:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian