Download it now!
Bug 31429 - Hovering over menu items is laggy
Summary: Hovering over menu items is laggy
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-06 05:07 UTC by Andrea
Modified: 2011-02-19 02:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea 2010-11-06 05:07:39 UTC
I'm using beta2, and as you can see from the video, hovering over menu items is more laggy than OOo 3.2.1.
Some additional lag is caused by the video recording settings, but I hope the difference is still noticeable.

The video is here (codec is - extra old? - Microsoft Video 1, so be ready with VLC):
http://www.mediafire.com/?uaa60f2205ckfyc
Comment 1 Petr Mladek 2010-11-16 07:21:34 UTC
The lag is pretty annoying also when displaying the context menu, see the bug #31438.

Tor, could you please have a look?
Comment 2 Don't use this account, use tml@iki.fi 2010-11-16 07:59:12 UTC
I can't reproduce any disturbung lagginess, in a fresh 3.3 build on XP SP3 in a virtual machine. And seriously, that video, is it a joke? Is that how you typically use menus, flip the mouse up and down with great speed? To me "hover" means keeping the mouse *still*
Comment 3 Andrea 2010-11-16 09:15:07 UTC
(In reply to comment #2)
> I can't reproduce any disturbung lagginess, in a fresh 3.3 build on XP SP3 in a
> virtual machine. And seriously, that video, is it a joke? Is that how you
> typically use menus, flip the mouse up and down with great speed? To me "hover"
> means keeping the mouse *still*

Sorry if I chose the wrong word, but I'm not native english.
Of course I don't pass the cursor over the menu entry at that speed, it was just to emphasize the lag, that is still very noticeable when passing the mouse over at normal speeds, but in this case the low framerate of the video wouldn't have made it perceivable
Comment 4 Rainer Bielefeld Retired 2011-02-15 06:56:54 UTC
The video seems to be no longer available?

I remember that reaction to hovering over menu items and similar action was rather slow, selection (highlighting) of the items was with with annoying delay. But currently I can't see that any longer.

@Andrea:
Still a problem for you?
Comment 5 Andrea 2011-02-18 11:16:31 UTC
(In reply to comment #4)
> The video seems to be no longer available?
> 
> I remember that reaction to hovering over menu items and similar action was
> rather slow, selection (highlighting) of the items was with with annoying
> delay. But currently I can't see that any longer.
> 
> @Andrea:
> Still a problem for you?

No more :)
Comment 6 Rainer Bielefeld Retired 2011-02-19 00:40:35 UTC
That's good news.
Due to
<https://bugs.freedesktop.org/page.cgi?id=fields.html#status>
we should used FIXED only if a known fix has solved the problem; if the problem only disappeared without known reason, please use WORKSFORME.
Comment 7 Andrea 2011-02-19 02:29:49 UTC
(In reply to comment #6)
> That's good news.
> Due to
> <https://bugs.freedesktop.org/page.cgi?id=fields.html#status>
> we should used FIXED only if a known fix has solved the problem; if the problem
> only disappeared without known reason, please use WORKSFORME.

All right, sorry for the mistake