Download it now!
Bug 31438 - UI: Context menu closed instead of moved on a new right-click
Summary: UI: Context menu closed instead of moved on a new right-click
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-07 03:20 UTC by vohe
Modified: 2013-03-29 00:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vohe 2010-11-07 03:20:13 UTC
I figure out, that in all moduls the behaviour of the context menue is different to other Software and to older Versions of the Office Suite.
If i click right into a text document the menue appears (as i suggest with a little lag, but i can reproduce this any time).
Now, if i click into another Point of the document the menue disappears.
But the normal behaviour is that the menue disappear on the first place and appears on the actual point. 
So i need to do two clicks to get the context menue.

regards.
vohe
Comment 1 Rainer Bielefeld Retired 2010-11-07 11:13:23 UTC
Reproducible with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)], I checked WRITER, DRAW and CALC.

It would be interesting to know whether other OS are affected.
Comment 2 Petr Mladek 2010-11-16 07:18:26 UTC
The two clicks are needed on Linux as well. Though, it is normal behavior there.

Hmm, it takes several seconds before the context menu is displayed on Windows. It seems that there is something wrong with the menus. The lag is pretty annoying.

Tor, could you please have a look?
Comment 3 Don't use this account, use tml@iki.fi 2010-11-16 07:54:04 UTC
I see this in OOo 3.2.1 (Novell Edition), too. So it probably is by design.  Haven't checked with vanilla OOo.

Surely this is not Importance: high:major... (Not that those fields have any impact.)

I don't see any delay of several seconds.
Comment 4 Don't use this account, use tml@iki.fi 2010-11-17 02:14:48 UTC
What "older version of the office suite" are you referring to?
Comment 5 Don't use this account, use tml@iki.fi 2010-11-17 02:50:00 UTC
Isn't the title of this bug report misleading? The context menu drops down after the *first* mouse click (no matter which button) or key press after it has been displayed. Then a new right-click is needed to show it again.

Attempting to make the title less misleading...
Comment 6 vohe 2010-11-17 11:04:08 UTC
I don't see this on Openoffice 3.1.x .
Comment 7 vohe 2010-11-17 11:21:40 UTC
and... I don't know how to descibe it better than this for you. (Sorry about my bad english)

Any other Software I use (on this machine under Windows) does it like the following:

Open a Document. (e.g. Firefox on Windows)  As you see the empty browserscreen, let us assume, that the left upper corner of the document is pointxy(0,0) and the bottom right corner point(1000,1000).
So if i click with a right mouse click to pointxy(10,10) the contextmenue appears.
Leaving this menue on the screen i click (right mouse) to pointxy(100,100), then the contextmenue appears at this point and disappears at pointxy(10,10).
With only ONE klick.

What happens in Libreoffice (and i found it in OOffice3.3, 3.2 and TheGimp for Windows too - so may it's a GTK  Problem?)

Open a Document. (e.g. Writer on Windows)  As you see the empty sheet, let us assume, that the left upper corner of the document is pointxy(0,0) and the bottom right corner point(1000,1000).
So if i click with a right mouse click to pointxy(10,10) the contextmenue appears.
Leaving this menue on the screen i click (right mouse) to pointxy(100,100), then the contextmenue at pointxy(10,10) disappears and nothing more.

And because there is a little delay in the appearing of the contextmenue, it could happen, that i click two times on the same place (e.g pointxy(10,10)) in this case - NO contextmenue appears! 

(Check this with firefox (or other software) the contextmenue appears! Doesn't matter how often i click on a point)

I hope this discription helps?

Regards Volker
Comment 8 Don't use this account, use tml@iki.fi 2010-11-17 11:38:45 UTC
I asked what "older versions of the office suite" you mean. I was not interested in the reproduction instructions, or comparisons to other software. And GTK+ definitely has nothing at all to do with this.
Comment 9 Rainer Bielefeld Retired 2010-11-17 22:09:17 UTC
Modified Summary due to original report.
[Reproducible]
Nothing unclear left, so I remove keyword

@Tor:
All other (WIN) applications move the context open context menu to the new click, LibO closes the context menu.
Older versions of the office suite are all OOo versions (at least WIN versions) before LibO, where I never saw that behaviour. 
But OOo-dev 3.4 shows "same behaviour as LibO.
I filed <http://www.openoffice.org/issues/show_bug.cgi?id=115646>, let's see what they say.
I agree, that's not "major"
Comment 10 Sebastian G. <bastik> 2010-11-26 08:27:43 UTC
I got the same problem with Beta3 on Win7 HP 64bit. It mainly affects the writer. Calc's right click menu open much faster.

My system got 4 cores and soffice.bin takes 25% for about 7 seconds. When I misspell a word it gets underlined. If I right click on the misspelled word the menu is there within a second.

It's a Windows only problem. The standard right-click-menu is the problem, maybe due to the fonts (sub)menu.

Maybe this is helpful in some way.
Comment 11 Sebastian G. <bastik> 2010-11-26 08:37:41 UTC
I found something that might be helpful.

I searched the userlist:
http://www.libreoffice.org/lists/users/msg00470.html

Removing the "presenter-screen" extension solves the problem for me. (only 2-3 seconds)
Comment 12 Don't use this account, use tml@iki.fi 2010-11-26 08:59:14 UTC
Sebastian: the slowness of opening the right-click menu is a different problem, new in beta 3. That is not what this bug is about. There is a different bug report for that, bug #31716 . Let's keep these issues separate. I wish there was a way in bugzilla to permanently "hide" comments.
Comment 13 Petr Mladek 2010-11-26 12:23:51 UTC
I see the wrong behavior also with plain OOo-3.2.1 build. I guess that OOo has behaved like this since ages.
Comment 14 retired 2013-03-29 00:52:34 UTC
This is not reproducible with LO 4.0.1.2.

The behavior is now as expected by vote (bug reporter), which is:

Right click in a document > menu opens
Right click another point in the document > menu disappears in the first place and appears on the other point where second click was made.

>> WORKSFORME