Download it now!
Bug 31468 - Writer crashes when copying drawing to clipboard
Summary: Writer crashes when copying drawing to clipboard
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 06:54 UTC by Silviu Berbinschi
Modified: 2012-05-04 00:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A example file to try the action that produce the bug. (37.59 KB, application/vnd.oasis.opendocument.text)
2010-11-08 06:54 UTC, Silviu Berbinschi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silviu Berbinschi 2010-11-08 06:54:50 UTC
Created attachment 40122 [details]
A example file to try the action that produce the bug.

Hi,
I use LibreOffice at work ("Dunarea de Jos" University, Galati, Romania) and at home, and I found a bug: when I copied to clipboard a image with some drawing object, all of these in a frame box, the LibreOffice Writer crashed.
For better understanding I attached the file, to try yourself. Try to copy the frame box in other place.
I posted this for better knowledge of some bugs.

Sincerely,
Silviu Berbinschi
Comment 1 Silviu Berbinschi 2010-11-08 06:58:05 UTC
I work on last Libre Office version:
LibreOffice 3.3.0 
OOO330m9 (Build:1)
libreoffice-build 3.2.99.2
Comment 2 Cédric Bosdonnat 2010-11-09 04:06:15 UTC
I'm wondering whether it's a duplicate of bug 30921, but I can't even reproduce the bug on a Beta2 build. Could you run libreoffice in gdb and get the backtrace of the bug?

See this page for help: http://wiki.documentfoundation.org/BugReport
Comment 3 Yifan Jiang 2010-11-22 02:20:50 UTC
LibO 3.3 beta3 on SLED 11 sp1 could not reproduce this problem either.

Hi Cedric, did you have chance to look at the Windows build? The platform field was marked as Windows. I'll download the beta3 windows build over tonight.
Comment 4 Don't use this account, use tml@iki.fi 2010-11-22 02:33:17 UTC
Changing summary to be more descriptive. Changing platform as LibreOffice is a 32-bit application; that the Windows machine might be running a 64-bit OS is irrelevant.
Comment 5 Yifan Jiang 2010-11-22 19:29:24 UTC
Not be able to reproduce either, after several tries on LibO beta3 Windows build.
Comment 6 Rainer Bielefeld Retired 2010-11-26 08:47:54 UTC
Not Reproducible with "LibreOffice 3.3.0Beta3 - WIN XP ES [OOO330m9 (build 3.2.99.3)]"
I believe it's a DUP of or related to caption problems in Bug 31452?

Closing because not reproducible with current version.
Comment 7 Rainer Bielefeld Retired 2010-11-26 08:49:49 UTC
@reporter:
Please feel free to reopen this Bug if you find out that the problem still exists in the latest release of OOo1
Comment 8 Björn Michaelsen 2011-12-22 05:49:36 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 9 Roman Eisele 2012-05-04 00:43:46 UTC
This is a Writer issue, therefore changed 'Component' accordingly.