Download it now!
Bug 31472 - [UI]: Grid to Front does not work
Summary: [UI]: Grid to Front does not work
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 08:44 UTC by Rainer Bielefeld Retired
Modified: 2011-12-23 13:45 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-11-08 08:44:05 UTC
I checked with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)] 

Steps to reproduce: 
1. open new DRAWing
2. Make grid visible if invisible
3. Draw a big rectangle with filling
   normally grid will become invisible behind drawing
4. 'Rigtclick -> Grid -> Grid to Front'
    into empty drawing area 
    expected: grid should become visible in drawing rectangle filled area
    actual: nothing, grid stays invisible behind rectangle

Same problem in Menu

I believe this very visible problem is a blocker for 3.3.0
Comment 1 Rainer Bielefeld Retired 2010-11-11 13:52:47 UTC
Also Impress affected as expected.
I just saw that OOo-dev330m10 (build 9533) also is affected. I will check tomorrow whether an IZ issue does exist.
Comment 2 Rainer Bielefeld Retired 2010-11-12 07:46:58 UTC
Seems to have to do with automatic gric color. I was able to heal the problem finally with menu 'Tools -> Options -> LibreOffice -> Appearance -> Drawing Grid Color = Black'. With that setting the grid became visible in front of objects and remained visible even after I turned back to "Automatic", closed and restarted LibO, rebooted PC ... .

So this might have been an issue with installation / configuration or similar.

Pls. also see <http://www.openoffice.org/issues/show_bug.cgi?id=115549>
With dev330m10 I saw the same problem, now works for me with DEV300m92.
Comment 3 Rainer Bielefeld Retired 2010-11-18 21:34:29 UTC
Beta3 did not show that problem (as expected)
Comment 4 Rainer Bielefeld Retired 2010-11-18 22:39:05 UTC
restored assignation, I'm sorry for the SPAM
Comment 5 Don't use this account, use tml@iki.fi 2010-11-19 03:22:31 UTC
If the problem doesn't show up in beta3, let's assume it has been fixed. (Note that here in freedesktop.org bugzilla we don't have such an elaboratre process to resolve, verify and close (if I recall correctly) issues as in OOo IssueZilla. Just resolve a bug as fixed if that is how it seems to be.)
Comment 6 Rainer Bielefeld Retired 2010-11-29 21:44:42 UTC
No longer reproducible, so I close this Bug.