Download it now!
Bug 31485 - /Tools/Customize/Category/LibreOffice macro shuts down LibO
Summary: /Tools/Customize/Category/LibreOffice macro shuts down LibO
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Mac OS X (All)
: high normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 23:50 UTC by James Wilde
Modified: 2012-05-08 07:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Apple's automatic bug report on crash (44.34 KB, text/plain)
2010-11-08 23:56 UTC, James Wilde
Details
Apple Automatic Crash Report (55.21 KB, text/plain)
2010-11-30 08:40 UTC, Alex Thurgood
Details
screen capture of msgbox after running Noel's test macro (32.27 KB, image/png)
2011-01-05 08:29 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Wilde 2010-11-08 23:50:52 UTC
I have created a macro in LibO whose function is to paste unformatted text.  I am trying to associate this to the Cmd+V key instead of the default paste formatted text.

When I select /Tools/Customize and have marked Cmd+V, I go to Category and click on the little expander arrow beside LibreOffice macros (next to the bottom in the Category list.  This shuts down LibO.

I am running 3.3 beta1 on Mac OSX 10.6.4 on an Intel Macbook Pro.
Comment 1 James Wilde 2010-11-08 23:56:30 UTC
Created attachment 40136 [details]
Apple's automatic bug report on crash

Hope it's of value
Comment 2 Petr Mladek 2010-11-16 11:57:58 UTC
I am not able to reproduce it on Linux. It seems to be MAC-specific.

Thorsten, could you please have a look?
Comment 3 Alex Thurgood 2010-11-17 00:11:23 UTC
Hi Petr,

Can not confirm this behaviour on Mac OSX SnowLeopard. I can click on any of the develop category arrows, either via mouse button click or Up/Down/Side navigation arrow keys on keyboard and LibO beta 2 does not crash.

My thinking is that this is perhaps related to the Mac OS Java recognition bug now fixed upstream because that bug caused havoc with a lot of functionality of LibO.

Could you please, James, tell us whether you have updated your Java to the latest provided by Apple Update (I think it is version 1.6.0_u22) ? One easy way to check from within LibO is to go to the Tools>Options>Java setting and see if your Java version is recognised automatically.

If it is the Java bug, then this is allegedly solved by the upstream OOo fix (now in 3.3 rc3 and later) which should appear in LibO beta 3.


Setting NEEDINFO keyword.


Alex
Comment 4 James Wilde 2010-11-18 08:48:30 UTC
On Nov 17, 2010, at 09:11 , bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31485
> 
> Alex Thurgood <alex.thurgood@gmail.com> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>           Keywords|                            |NEEDINFO
>                 CC|                            |alex.thurgood@gmail.com
> 
> --- Comment #3 from Alex Thurgood <alex.thurgood@gmail.com> 2010-11-17 00:11:23 PST ---
> Hi Petr,
> 
> Can not confirm this behaviour on Mac OSX SnowLeopard. I can click on any of
> the develop category arrows, either via mouse button click or Up/Down/Side
> navigation arrow keys on keyboard and LibO beta 2 does not crash.
> 
> My thinking is that this is perhaps related to the Mac OS Java recognition bug
> now fixed upstream because that bug caused havoc with a lot of functionality of
> LibO.
> 
> Could you please, James, tell us whether you have updated your Java to the
> latest provided by Apple Update (I think it is version 1.6.0_u22) ? One easy
> way to check from within LibO is to go to the Tools>Options>Java setting and
> see if your Java version is recognised automatically.

Sorry, should have replied yesterday if not the day before.  I confirm I have 
Apple Java 1.6.0.22 by testing as suggested.
> 
> If it is the Java bug, then this is allegedly solved by the upstream OOo fix
> (now in 3.3 rc3 and later) which should appear in LibO beta 3.

I have not updated yet beyond LibO v.3.3 beta 1.  I will now update to the 
latest (presumably one of the rcs).
> 
> 
> Setting NEEDINFO keyword.
> 
> 
> Alex
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 5 Thorsten Behrens (CIB) 2010-11-26 13:33:10 UTC
James, please update to Beta3 and re-test - your crash is indeed Java-related, and we had stuff fixed there for Beta3.
Comment 6 James Wilde 2010-11-29 12:04:04 UTC
Hi and sorry for the delay - I didn't answer directly and the mail temporarily got lost in the crowd.

I have now installed beta3, and done the same operation: Tools/Customize, chosen Categories and LibreOffice Macros.  I get the circle of colour and then LibreOffice quits and I sometimes get a request to send a report to Apple.

I've also just tested it with Open Office, 3.2.1, and got the circle of colour, but then after a short pause it gave me the available macros.

I'll just restart LibO and make sure it's the right version, and not some remains of beta1.

LibreOffice 3.3.0
OOO330m12 (Build:1)
libreoffice-build 3.2.99.3

is what I get from the About LibreOffice menu

Back to you.  Sorry.
Comment 7 Thorsten Behrens (CIB) 2010-11-29 15:47:25 UTC
James, it seems nobody can reproduce this bug according to your description. I notice though that the "category" you go to seems at least ambiguous - maybe you could clarify by providing a real step-by-step explanation (open Writer doc, go to menu, click on "X", click on "Y" etc)? Closing as WORKSFORME meanwhile.
Comment 8 James Wilde 2010-11-30 02:09:21 UTC
It gets worse.  Before I started the step-by-step description you asked for, I decided to check the status of macros and scripts.  Under Tools/Macros/Organize Macros there was a heading My Macros, with subheading Standard and sub-subheading Module 1.  There was also a heading Untitled 1, with no subheadings.  In other words, the macro I created was not visible.  I don't know if upgrading removed it, but I decided to re-create it.

Tools/Macros/Record Macro is greyed out, so I am unable to create a macro.

The procedure I follow, which I can still follow, is as follows:

In a Writer document click on Tools
Click on Customize
Under Category scroll down until LibreOffice Macros is visible
Click on the grey arrow to the left of LibreOffice Macros
LibreOffice disappears and a window comes up:

LibreOffice quit unexpectedly.
Click Reopen to open the application again.  Click Report to se more detailed information and send a report to Apple.

Three buttons:  Ignore, Report..., Reopen

I have now removed LibO from my computer (deleted it from Applications, removed Library/Application Support/Libreoffice) and reinstalled from scratch.  Tools/Macros/Record Macro is still grey.

That's it.  As I say, this works fine in OOo 3.2..1
Comment 9 Alex Thurgood 2010-11-30 02:57:33 UTC
Aha, been playing around with this and have just reproduced the crash behaviour.

1) Start LibO
2) Choose new Writer document from start menu page
2) Go to Tools > Customize
3) Choose Keyboard tab from dialogue window.
4) In the bottom left-hand pane of the dialogue window, click on the arrow next to "LibreOffice Macros"
5) Click on "Shared", the list of shared macros will appear.
6) Click on any of the entries in the list under "Shared".

7) LibO crashes systematically.

Resetting status to reopened, importance high, and critical.


Alex
Comment 10 Alex Thurgood 2010-11-30 03:04:14 UTC
Additional info :


It only appears to happen in the "share" (and not "shared" as I initially stated) folder and on the first entry of the list of that folder in tree hierarchy. If I click on any of the macros lower down in the list, I can access them without LibO crashing, but it appears that clicking on the first in the list, or moving to it with scroll key will cause crash to occur.


Alex
Comment 11 Thorsten Behrens (CIB) 2010-11-30 06:40:59 UTC
Ok, many thanks for the updates - unfortunately still not able to reproduce, though a hunch this may be related to accessibility stuff, that pops up in other mac bugs as well - Alex, could you please also attach a report of the Apple crash reporter, for comparison?
Comment 12 Alex Thurgood 2010-11-30 08:40:00 UTC
Created attachment 40675 [details]
Apple Automatic Crash Report

Just did it again, that's 5 out of 5 attempts so far :-). I have enclosed the bug report info gathered by the Apple Crash Report notifier.


Alex
Comment 13 Thorsten Behrens (CIB) 2010-11-30 12:50:47 UTC
Ok, thanks for the info so far - telling from the callstacks, it seems likely the crash happens below SfxConfigGroupListBox_Impl::GroupSelected(), in James case inside Java, for Alex directly there. Did some extensive valgrind runs (a memory debugger) on Linux for the described scenario, nothing fishy really, except for a load of Python PyObject_Free false positives (I guess).

Adding Noel on Cc, maybe you've seen something like this before?

Sadly, am not able to reproduce this on MacOS, so currently, there's not much I can do. Will ask back when releases get out, whether something changes in behaviour.
Comment 14 Noel Power 2010-12-01 03:22:33 UTC
(In reply to comment #13)
> Ok, thanks for the info so far - telling from the callstacks, it seems likely
> the crash happens below SfxConfigGroupListBox_Impl::GroupSelected(), in James
> case inside Java, for Alex directly there. Did some extensive valgrind runs (a

looking in cui/source/customize/cfgutil.cxx the only way afaics that GroupSelected could fail ( and according to the trace it fails no deeper than GroupSelected ) is if this line in GroupSelected

SvLBoxEntry *pEntry = FirstSelected();

ends up with pEntry with NULL value

This can only happen if  rootNode ( in SfxConfigGroupListBox_Impl::Init ) is null


@James - I wonder could you try create and insert the following macro and report the results



sub test
   smgr = getProcessServiceManager()
   context = smgr.getPropertyValue("DefaultContext" )
   xFac =  context.getValueByName("/singletons/com.sun.star.script.browse.theBrowseNodeFactory")
   
   rootNode = xFac.createView( com.sun.star.script.browse.BrowseNodeFactoryViewTypes.MACROSELECTOR  )
   msgbox rootNode.dbg_properties
end sub
Comment 15 Alex Thurgood 2011-01-05 08:29:04 UTC
Created attachment 41670 [details]
screen capture of msgbox after running Noel's test macro
Comment 16 Alex Thurgood 2011-01-05 08:29:51 UTC
Hi Noel,

Ran your test from within an empty Writer document on RC2. I have enclosed the screenshot of the msgbox.


Alex
Comment 17 Alex Thurgood 2011-01-05 08:32:42 UTC
BTW, I can no longer reproduce the crash in RC2.

Alex
Comment 18 Noel Power 2011-01-05 11:43:08 UTC
(In reply to comment #17)
> BTW, I can no longer reproduce the crash in RC2.
> 
> Alex

well in the crashing case I would expect that macro to fail so... looks like what ever caused this is now gone, so closing now as fixed ( reopen of course if this reappears ) :-)
Comment 19 Noel Power 2011-01-05 11:43:29 UTC
.
Comment 20 Björn Michaelsen 2011-12-22 05:37:24 UTC
Remove infoprovider from closed and resolved bugs.
Comment 21 Björn Michaelsen 2011-12-22 05:51:46 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 22 Roman Eisele 2012-05-08 07:44:45 UTC
Set 'Component' to 'BASIC' because this is a macro issue.

Set 'Version' field according to original description.