Download it now!
Bug 31496 - [PATCH] Support Lucene 3.x
Summary: [PATCH] Support Lucene 3.x
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-09 04:32 UTC by Bernhard Rosenkraenzer
Modified: 2012-02-23 13:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch (5.83 KB, application/octet-stream)
2010-11-09 04:32 UTC, Bernhard Rosenkraenzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2010-11-09 04:32:09 UTC
Created attachment 40144 [details]
Patch

l10ntools and xmlhelp currently require on an outdated version of Lucene.

The attached patch adds support for Lucene 3.x, but drops support for versions older than 2.9.
Comment 1 Petr Mladek 2010-11-18 06:44:49 UTC
I am fine with the change but I use the internal Lucene.

Rene, Caolan, do you have anything against the update?
Comment 2 Caolán McNamara 2010-11-18 07:33:45 UTC
Clearly we can't change from using lucene2 to lucene3 without at least updating the internal lucene to that version, otherwise the "stock" build will just fail. Ideally we would be able to build against both, seeing as we happen to still have lucene 2.4.1 as our latest version :-).

As an aside, the --with-external-lucene would error with "you need lucene 2 or 3" if someone had lucene 2, right ?
Comment 3 Rene Engelhard 2010-11-18 12:26:21 UTC
> Rene, Caolan, do you have anything against the update?

Not per se, but Caolan is right:

> Clearly we can't change from using lucene2 to lucene3 without at least updating
> the internal lucene to that version, otherwise the "stock" build will just
> fail.

> Ideally we would be able to build against both, seeing as we happen to
> still have lucene 2.4.1 as our latest version :-).

Unfortunately Java doesn't have a preprocessor... :)

> As an aside, the --with-external-lucene would error with "you need lucene 2 or
> 3" if someone had lucene 2, right ?

Jup, that needs to be changes to "need lucene 3" if we applied that patch
Comment 4 Rene Engelhard 2010-11-18 12:28:37 UTC
> Not per se, but Caolan is right:

Hmm, I retract that, apparently we don't have lucene3 either yet (thought we had it in unstable or experimental)

So we *do* need to support both I think...
Comment 5 Caolán McNamara 2010-11-18 12:44:27 UTC
Java doesn't have a processor so its kind of painful, but ant and our makefiles can conditionally compile one or another file so I'm sure we had some hackery in somewhere where we compile one or another file depending on something like Sun vs GCJ jdk but I can't seem to find it to use as an example.
Comment 6 Björn Michaelsen 2011-12-23 11:33:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Andras Timar 2012-02-23 13:41:55 UTC
We migrated to clucene, this patch became obsolote.