Download it now!
Bug 31518 - Help:About dialog has zero width
Summary: Help:About dialog has zero width
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-09 23:37 UTC by Don't use this account, use tml@iki.fi
Modified: 2010-12-15 05:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Suggested patch (466 bytes, patch)
2010-12-15 05:22 UTC, Don't use this account, use tml@iki.fi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Don't use this account, use tml@iki.fi 2010-11-09 23:37:13 UTC
In a fresh build of the libreoffice-3-3 branch with --with-distro=NovellWin32, the Help:About dialog has zero width and is thus fairly useless and hard to close. Most likely caused by the layout patches.
Comment 1 Petr Mladek 2010-11-18 07:46:04 UTC
AFAIK, the about dialog is not layouted.

It might be somehow related to the Novell branding.

Fridrich, please have a look.
Comment 2 Don't use this account, use tml@iki.fi 2010-12-15 05:16:01 UTC
Yep, it seems that the width of the Help:About dialog is set from the width of the "about" bitmap image (loaded using Application::LoadBrandBitmap ("about", aBitmap)), and apparently in my --with-distro=NovellWin32 builds that image is then nonexistent or something, with no fallback, resulting in a zero-sized bitmap.

I wonder if this is just a problem in my build environment, or if others would see this too if they tried building --with-distro=NovellWin32.

Anyway, I will check to see what happens if I make it use some default non-zero size in case there is no about image.
Comment 3 Don't use this account, use tml@iki.fi 2010-12-15 05:22:31 UTC
Created attachment 41139 [details]
Suggested patch
Comment 4 Don't use this account, use tml@iki.fi 2010-12-15 05:33:51 UTC
Fixed in master, commit 1f9d435a78ed161c642410fddd627cf8161dabc7 in libs-core. In case the problem shows up also in an actual official libreoffice-3-3 NovellWin32 build, will have to cherry-pick that.