Download it now!
Bug 31531 - desktop menu entries mention OOo instead of LibreOffice for french
Summary: desktop menu entries mention OOo instead of LibreOffice for french
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 11:33 UTC by zebulon
Modified: 2011-12-22 05:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (38.48 KB, image/png)
2010-11-10 22:07 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zebulon 2010-11-10 11:33:28 UTC
I just installed libreoffice

the entries in the gnome menu are "Base de données OOo Base", "Traitement de texte OOo Writer" etc...

I wonder why the entries still mention OOo while it must be LibreOffice
And note it's only for the french languague.

So the question is: why in the .desktop files only the french languague entries are not migrated to LibreOffice but instead still mention OOo ????
Comment 1 Rainer Bielefeld Retired 2010-11-10 22:07:04 UTC
Created attachment 40197 [details]
Screenshot

Not reproducible because of wrong language
Comment 2 Rainer Bielefeld Retired 2010-11-10 22:19:34 UTC
@zebulon:
You only mention "gnome", but selected "All OS". What other OS did you test?
Please add some hints concerning your "Other" platform.

NOT reproducible on my PC with German WIN XP, LibO French UI [OOO330m9 (Build:1 - build 3.2.99.2)], but I believe that's because of my GE WINDOWS
Comment 3 zebulon 2010-11-11 00:07:06 UTC
forgot to fill that
platform is gnome on archlinux.

The bug is easy to spot 
just open the writer.desktop file and go the line Name[fr]
you'll see the bug there
here it is installed as /usr/share/applications/writer.desktop

I can't point you to the same file on the git repo. I don't know where it is
Comment 4 zebulon 2010-11-11 00:27:50 UTC
so it seems the offending file is http://cgit.freedesktop.org/libreoffice/build/tree/po/fr.po

look for the string OOo and you'll find the cause of the bug described above (at least I think)
Comment 5 Petr Mladek 2010-11-18 07:36:37 UTC
Great catch. Fixed as 
http://cgit.freedesktop.org/libreoffice/build/commit/?id=f3d8834d92ada4127766adc15da756ef70f0f9cf

Also cherry picked to the libreoffice-3-3 branch.
Comment 6 sophie 2011-01-13 07:47:12 UTC
Closing - Sophie
Comment 7 Björn Michaelsen 2011-12-22 05:52:52 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.