Download it now!
Bug 31552 - [FILEOPEN] LibreOffice crashes when open particular docx file
Summary: [FILEOPEN] LibreOffice crashes when open particular docx file
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-11 07:27 UTC by Guillaume Vauvert
Modified: 2012-05-04 00:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A .docx document (23.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-11-11 07:27 UTC, Guillaume Vauvert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Vauvert 2010-11-11 07:27:34 UTC
Created attachment 40206 [details]
A .docx document

Whe I open this .docx document, OpenOffice crashes.

LibreOffice / Linux
Comment 1 Guillaume Vauvert 2010-11-11 07:29:24 UTC
This problems affects ClosedOffice too.
Comment 2 Noel Power 2010-11-12 03:48:17 UTC
What version of libreoffice, ( btw, I can't reproduce this on the latest dev build so probably this is fixed already )
Comment 3 Rainer Bielefeld Retired 2010-11-18 02:50:05 UTC
[Unconfirmed] with "LibreOffice 3.3.0Beta3 - WIN XP EN [OOO330m9 (build 3.2.99.2)]", I can open sample document from LigO file open dialog in IMPRESS without problems.

Modified OS due to report.

@Guillaume Vauvert:
May I ask you to read the hints on 
<http://wiki.documentfoundation.org/BugReport>?
Then please contribute a clear step by step instruction.
Comment 4 Petr Mladek 2010-11-18 08:52:37 UTC
I am unable to reproduce it with LibO-3.3-beta3 on SLED11-SP1-x86_64.

=> it seems to be fixed

Feel free to reopen it if you still see the problem with the last build.
Comment 5 sophie 2011-01-13 08:01:52 UTC
Verified - Closed - Sophie
Comment 6 Björn Michaelsen 2011-12-22 05:35:43 UTC
Remove infoprovider from closed and resolved bugs.
Comment 7 Björn Michaelsen 2011-12-22 05:49:45 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 8 Roman Eisele 2012-05-04 00:42:52 UTC
This is a Writer issue, therefore changed 'Component' accordingly. Now we can (and should) remove the '[WRITER]' from the Summary.

Set the Version field, according to comment #3 and #4: if this bug was fixed in 3.3b3, it must have been in 3.3b2 (if it ever existed).