Download it now!
Bug 31556 - Unknown frame prevents text being selected in attached document (.doc)
Summary: Unknown frame prevents text being selected in attached document (.doc)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-11 11:26 UTC by leighman
Modified: 2012-10-18 09:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Affected document (59.50 KB, application/msword)
2010-11-11 11:26 UTC, leighman
Details
Document displayed in Word 2007 through Wine (37.81 KB, image/png)
2010-11-11 12:25 UTC, leighman
Details
Document displayed in LibreOffice (41.83 KB, image/png)
2010-11-11 12:25 UTC, leighman
Details
screenshot of the selected frame (71.20 KB, image/png)
2010-11-18 09:32 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leighman 2010-11-11 11:26:41 UTC
Created attachment 40209 [details]
Affected document

Only tested on Linux but presumably affects other OSs.
Cannot select any text on the attached file; cursor just defaults to top corner
Presumably some silly non-standard formatting has gone on but text is selectable in Word 2007 running in Wine
Comment 1 leighman 2010-11-11 12:22:50 UTC
No frame is shown on the document in Word 2007 and text can be selected fine.
OO either adds a spurious frame or does not handle the frame in the same way as 
Word 2007 (eg. in a way that text can be selected through it)

Screenshots attached.
Comment 2 leighman 2010-11-11 12:25:28 UTC
Created attachment 40211 [details]
Document displayed in Word 2007 through Wine
Comment 3 leighman 2010-11-11 12:25:56 UTC
Created attachment 40212 [details]
Document displayed in LibreOffice
Comment 4 Petr Mladek 2010-11-18 09:32:37 UTC
Created attachment 40390 [details]
screenshot of the selected frame

I selected a frame, see the attached screenshot. Then I was able to move it using mounse to another location. The text under the frame was editable.

It is possible that MS Office shows the frames in different order, so the problematic one does not hide the text.
Comment 5 Petr Mladek 2010-11-18 09:34:49 UTC
Cedric, this is for you. Or maybe for Lubos?
Comment 6 Roman Eisele 2012-05-03 09:55:44 UTC
NOT reproducible anymore with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80), German langpack installed, on MacOS X 10.6.8 German UI. If I open the sample document I can immediately edit the text, as expected.

@leighman,
@everybody else:
Could you please test if the issue is fixed for you, too? Then we could close this bug report ... Or is the issue still reproducible on Linux?

This is a Writer issue, therefore changed the 'Component' field accordingly.
Comment 7 leighman 2012-05-03 12:26:41 UTC
Yup. Fixed here in 3.5.3 on Ubuntu 12.04
Comment 8 Roman Eisele 2012-05-03 13:08:16 UTC
@leighman:
(In reply to comment #7)
> Yup. Fixed here in 3.5.3 on Ubuntu 12.04

Thank you very much for your fast response! One more bug closed makes it easier to find the important (persistent) bugs ...
Comment 9 Roman Eisele 2012-10-18 09:27:12 UTC
Just for the record:
We prefer WORKSFORME instead of FIXED in cases like this one, where there is no acutual fix known which solved the problem. (No action necessary! ;-)