Download it now!
Bug 31558 - inserting a png file in writer crashes LibO Beta 2
Summary: inserting a png file in writer crashes LibO Beta 2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-11 14:28 UTC by Sigrid Carrera
Modified: 2012-05-04 06:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
plain textfile with the appropriate data from the LibO crash. (726.90 KB, text/plain)
2010-11-11 14:28 UTC, Sigrid Carrera
Details
Example from the mailing list (51.00 KB, application/msword)
2011-01-03 23:17 UTC, Stefano Fraccaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sigrid Carrera 2010-11-11 14:28:44 UTC
Created attachment 40214 [details]
plain textfile with the appropriate data from the LibO crash. 

Hi, 

the other day I tried to insert a png-file in a writer document. After choosing the correct file and clicking on "OK", LibO crashed repeatedly. 

The file was just a letter (1 page), the png file was my signature, that I wanted to insert.

For the record, I was able to use OOo (version 3.2) to insert the file into the letter. 

The Gnome bugreporting tool created a file with the (hopefully) relevant system data from the crash - I will attach it to this report as well. 

Btw, I'm using Mandriva Linux 2010.0 with all current updates and LibreOffice Beta2. 

Thanks for looking into this. 


Sigrid
Comment 1 Rainer Bielefeld Retired 2010-11-12 09:24:40 UTC
NOT reproducible with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)]. Might be linux specific?

@Sigrid Carrera:
Is that 100% reproducible with a new clean WRITER document, any .png inserted in any way? Or is a particular proceeding required to reproduce your problem?
Comment 2 Sigrid Carrera 2010-11-12 10:33:40 UTC
Hi Rainer, 

yes, I can reproduce it. 

I created a new file and added some text
"abcd...." and so on. 
This time I chose a different .png file and LibO crashed immediately after clicking on the OK button. 

Do you need any more data? If yes, what should I do to help you?


Sigrid
Comment 3 Sigrid Carrera 2010-11-12 10:39:02 UTC
Uh, I forgot something. 

Just now I tested also with gif and jpg and the same happens. So at least it's not limited to png files. 


Sigrid
Comment 4 Alex Thurgood 2010-11-18 03:24:20 UTC
Can not reproduce with beta 3 on MacOSX SnowLeopard. There was a similar issue with Caption insertion after inserting an image in beta 2, but that has also been resolved.


@Sigrid : please try with the latest beta 3 to see if problem still present. If yes, then it could be platform / OS specific.


Setting NEEDINFO keyword.

Alex
Comment 5 Stefano Fraccaro 2011-01-03 23:17:10 UTC
Created attachment 41606 [details]
Example from the mailing list

Single page with one big image... Lib0 in Windows XP SP3 will crash. If you make some blank lines before the image, all works fine
Comment 6 Stefano Fraccaro 2011-01-03 23:31:25 UTC
More info: my Lib0 is Release Candidate 2
Comment 7 Rainer Bielefeld Retired 2011-01-05 06:20:04 UTC
.
Comment 8 Alex Thurgood 2011-01-05 06:45:50 UTC
Hi all,

Still can not reproduce on MacOSX, LibO 3.3 beta 2. If I create an empty Writer document, and then insert a PNG file into it through the Insert > Image... menu, everything works fine. I guess this is Linux specific ?


@druido77 : why have you attached a DOC file ? The bug issue relates to inserting PNG, JPG, GIF into a Writer document.

Alex
Comment 9 Alex Thurgood 2011-01-05 06:53:09 UTC
@druido77 : well I opened your DOC file in OpenOffice.org and copy-pasted the image file from there into a clean LibO 3.3 beta2 Writer document. Everything worked fine, no crash - I can manipulate the image and move it around, resize, etc.

Someone on Linux will have to test.


Alex
Comment 10 Sigrid Carrera 2011-01-06 01:57:15 UTC
Hi, 

my experience with the file attached by druido77 (Example from the mailinglist): 

In LibreOffice 3.3RC2 I see: 

Recruitment
CA11289292
Contact Person: TJ Kochhar


With OpenOffice.org 3.2.1 I see: 

All of the above
plus the pictures (MonsterTruck)
Text about the hiring event
Company Logo (name)

LibO does not crash, but the file isn't displayed correctly either. 

I'm running Mandriva Linux 2010.1.
Comment 11 Rainer Bielefeld Retired 2011-10-09 08:26:45 UTC
Sigrid Carrera:
Anything new?

BTW: the picture in "Example from the mailing list"
- is a WMF, not png
- looks truncated when .doc with "LibreOffice 3.4.3  - WIN7 Home Premium 
  (64bit) German UI [OOO340m1 (Build:302)]", but looks fine with 
   LibO 3.3.3 Portable
Comment 12 Julien Nabet 2011-10-25 05:41:12 UTC
I tried to reproduce this bug without success.
I'm on a pc Linux Debian X86-32 on master branch (3.5).
I tried too with 3.4.3 Debian package without success too.

Sigrid Carrera: do you confirm you still have this pb with 3.4.x ?
Comment 13 Björn Michaelsen 2011-12-23 11:34:49 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 14 Björn Michaelsen 2011-12-23 17:01:32 UTC
needinfo keyword redundant by needinfo status.
Comment 15 Rainer Bielefeld Retired 2011-12-27 22:56:51 UTC
No success trying to reproduce, no answer, so WFM

@reporter:
Please feel free to reopen this bug if you find out that the problem still exists with LibreOffice version 3.5 and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport>
Comment 16 Roman Eisele 2012-05-04 06:37:16 UTC
This is a Writer issue (at least at the surface of the issue), therefore changed the 'Component' field accordingly.

Set Version field according to Summary, cf. comment #1 ("beta 2" must be 3.3b2).