Download it now!
Bug 31574 - characters appear in reverse typing order using ShortKeys Lites
Summary: characters appear in reverse typing order using ShortKeys Lites
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-12 00:15 UTC by Floater
Modified: 2014-10-23 20:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Floater 2010-11-12 00:15:20 UTC
When under load, text appears in the reverse order of keystrokes typed.

The problem can be reproduced in 2 ways.
Method 1.
 Here's a simple macro to illustrate the behaviour. It creates a key handler and 
waits for 10 secs to exit
The keyhandler idles counting for 99999 counts before returning hence not 
allowing LO to handle key immediately (simulating load).

Open a writer doc, run the macro and type 'abcdef' immediately . You will see 
that after a while the text output will be 'fedcba'.


===============================================================================
sub	keyreverse
oKeyHandler = 
CreateUnoListener("KeyReverseHandler_","com.sun.star.awt.XKeyHandler")
ThisComponent.GetCurrentController.addKeyHandler(oKeyHandler)
wait 10000
msgbox "done"
end sub


Function KeyReverseHandler_keyPressed(oKeyEvent as new 
com.sun.star.awt.KeyEvent) as boolean
		for i = 1 to 99999
		KeyHandler_keyPressed = False
		next i
End Function


Function KeyReverseHandler_keyReleased(oKeyEvent as new 
com.sun.star.awt.KeyEvent) As Boolean

	KeyHandler_keyReleased = False
End Function


Sub KeyReverseHandler_disposing
End Sub

==============================================================



Method 2. Install 'ShortKeys Lite' (a shortcut handling software) and create a 
shortcut for '-' on the num pad and assign to 'abcdef'. Open a writer doc and 
press '-' on the numpad. The output will be 'fedcba'.

Regards
Floater
Comment 1 Floater 2010-11-12 00:24:30 UTC
This issue is also filed in OO as issue 112925 & has been confirmed.

Regards
Comment 2 Thorsten Behrens (CIB) 2010-11-18 16:19:39 UTC
Cedric, please have a look. Lowering prio though, this does not seem to be a general problem.
Comment 3 Cédric Bosdonnat 2011-02-15 04:14:41 UTC
Well, what can we do here apart from remembering the extensions developers not to perform heavy computations on such handlers? We can't even can these handlers in asynchronous mode as they would turn to be useless (and that would really break the way some existing extensions/macros are working).

Closing as not our bug: please report the bug to the extensions developers.
Comment 4 Floater 2011-03-25 01:10:18 UTC
Hi
The term 'under load' in the title is a misnomer. Actually all it takes is rapid input of keys for eg. through a shortcut handler (assigned to input my signature following a shortcut). The 'Method 2' mentioned below is more appropriate than the 'Method 1' since the later seems to suggest a heavy macro as cause of the problem.

Regards
Floater
Comment 5 Laurent Kloetzer 2012-06-17 23:34:43 UTC
I reproduced it with a simple doc, with no specific extension. The doc is quite long, and if I type fast, the letters appear in the wrong order.
Comment 6 Laurent Kloetzer 2012-06-17 23:48:17 UTC
Concerning my preceeding comment, I investigated a little bit more.
I was working in fact on a piece of text with a very big paragraph (30 pages)
(litterary exigence, let's say).
If I bre
Comment 7 Laurent Kloetzer 2012-06-17 23:49:27 UTC
Concerning my preceeding comment, I investigated a little bit more.
I was working in fact on a piece of text with a very big paragraph (30 pages)
(litterary exigence, let's say). I have the impression that the program is slowed down by doing the layout of this all big parapgraph...
If I break the paragraph in smalling chunks, the bug does not reproduce.
Comment 8 Jean-Baptiste Faure 2014-05-02 21:00:32 UTC
Do you still experience the problem with current stable version ?

Set status to NEEDINFO because this bug has never been independently confirmed.
@Laurent: your description is different from the one by the reporter.

Best regards. JBF
Comment 9 Floater 2014-05-03 08:26:56 UTC
Yes
I have Version: 4.2.4.1
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e51

and the result is the same; o/p appearing in reverse order of typing.

Regards
Floater


On Saturday, 3 May 2014 2:30 AM, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> wrote:
 
 
Jean-Baptiste Faure  changed bug 31574 

What
Removed
Added
Status REOPENED  NEEDINFO  
CC    jbf.faure@sud-ouest.org  
Comment # 8 on bug 31574 from Jean-Baptiste Faure  
Do you still experience the problem with current stable version ? Set status to NEEDINFO because this bug has never been independently confirmed.
@Laurent: your description is different from the one by the reporter. Best regards. JBF
________________________________
 You are receiving this mail because: 
	* You are on the CC list for the bug.
	* You reported the bug.
Comment 10 Jean-Baptiste Faure 2014-05-03 09:42:57 UTC
(In reply to comment #9)
> Yes
> I have Version: 4.2.4.1
> Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e51
> 
> and the result is the same; o/p appearing in reverse order of typing.
> 
With the same 'ShortKeys Lite' software or without it ? Did you encounter the same problem without this software?
Note: you should try the autotext function in LibreOffice.

Please, do not reply by mail, use bugzilla website only.

Best regards. JBF
Comment 11 Floater 2014-05-05 10:08:04 UTC
I used the macro posted in the first mail and the problem remains.

I no longer use Short-keys.

Regards
Comment 12 Jean-Baptiste Faure 2014-05-05 20:17:37 UTC
Thank you, no more question for the moment.
Set status back to unconfirmed.

Best regards. JBF
Comment 13 tommy27 2014-06-22 07:05:38 UTC
tested with LibO 4.2.4.2 under Win7x64
I can reproduce bug using the macro in the description.
status NEW

would you please tell me which kind of situations do you encounter this problem?

has it ever happened during fast hand typing or just using phrase shortcut softwares like ShortKeys Lite?

I use a similar software called PhraseExpress ( http://www.phraseexpress.com/ ) and I've never encountered reverse typing issues.
Comment 14 Floater 2014-06-22 08:37:49 UTC
Never happened during manual typing. It's only with the shortkeyslite following which i tried to reproduce the bug with a macro. 

I have not tried any other phrase shortcut s/w.

Regards
Floater
Comment 15 QA Administrators 2014-10-23 17:32:24 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 16 tommy27 2014-10-23 20:00:35 UTC
Hi I've installed ShortKeys Lite 2.3b from this website: 
http://www.shortkeys.com/lite.htm

I set the suggested shortcut for '-' on the num pad and assigned it to 'abcdef'

then I typed '-' inside a LibO 4.3.2.2 Writer page and I see no reverse typing.

I don't know if this depends on a code change of ShortKeys Lite (I suppose the current version is a different release than those you tried in 2011) or a code change of LibO, so it seems now it's working 

the macro reverse typing issue is still happening but that is a very "artificial" situation that won't happen in real life

so I edited summary notes to focus on the issue of the ShortKeys Lite software which seems RESOLVED WORKSFORME