Download it now!
Bug 31695 - Crash when docking the Navigator or Stylists
Summary: Crash when docking the Navigator or Stylists
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
: 31775 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-17 16:30 UTC by RGB
Modified: 2011-01-12 09:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2010-11-17 16:30:21 UTC
LibO beta 3 on openSUSE 11.2 64 bits, Spanish languagepack installed.
When trying to dock the navigator or the stylists, LibO crash. Running from terminal I obtain:

# A fatal error has been detected by the Java Runtime Environment:
#                                                                 
#  SIGSEGV (0xb) at pc=0x00007fdf714576d5, pid=7080, tid=140597701129984
#                                                                       
# JRE version: 6.0_22-b04                                               
# Java VM: Java HotSpot(TM) 64-Bit Server VM (17.1-b03 mixed mode linux-amd64 )
# Problematic frame:                                                           
# C  [libsfxlx.so+0x3a16d5]
Comment 1 Rainer Bielefeld Retired 2010-11-18 00:05:59 UTC
[Unconfirmed] with "LibreOffice3.3.0Beta2 - WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)]". Seems to be related to OS or Platform?
Comment 2 vitriol 2010-11-18 04:55:26 UTC
Same problem with LibO under Win Vista HP full patched.
Comment 3 vitriol 2010-11-18 04:56:33 UTC
(In reply to comment #2)

> Same problem with LibO under Win Vista HP full patched.

LibO 3.3 beta 3
Comment 4 Jean-Baptiste Faure 2010-11-18 23:49:50 UTC
For me (Ubuntu 10.04 x86-64 FR) LibO crashes only if I dock the Navigator or the Stylist on the right edge of the window. No problem on the left edge.

Best regards. JBF
Comment 5 Jean-Baptiste Faure 2010-11-18 23:50:39 UTC
version number set.
Comment 6 Thorsten Behrens (CIB) 2010-11-19 06:58:53 UTC
Fixed with commit cce6be23d70e5d8911fc54dfc4c04a07097caf14
Comment 7 Thorsten Behrens (CIB) 2010-11-19 07:02:12 UTC
btw, the Java runtime error blurb is a red herring - it's just that the jvm puts up signal handlers all over the place.

I wonder if jvm_detach is not properly called when leaving java code - if yes, it's probably time to run the JVM out-of-process ...
Comment 8 GerardF 2010-11-19 13:14:54 UTC
*** Bug 31775 has been marked as a duplicate of this bug. ***
Comment 9 sophie 2011-01-12 09:56:52 UTC
Closing - Sophie
Comment 10 sophie 2011-01-12 09:57:20 UTC
Closing - Sophie