Download it now!
Bug 31698 - when Impress it's opened again from a crash, but opening another file it will crash
Summary: when Impress it's opened again from a crash, but opening another file it will...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 20:09 UTC by Maximiliano Castañón
Modified: 2012-05-12 12:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file (401.04 KB, application/vnd.oasis.opendocument.presentation)
2010-12-07 09:03 UTC, Maximiliano Castañón
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maximiliano Castañón 2010-11-17 20:09:06 UTC
If you open a file1.odp and it crash, and you this time open another file, called file2.odp, when LO start, it will show you the recovery window, you click on next, and now LO will crash... that's all, this is reproduce able :D

this doesn't happen on the others, just impress.
Comment 1 Thorsten Behrens (CIB) 2010-11-18 15:36:42 UTC
Maximiliano, well, if it crashes the first time loading file1.odp, it will subsequently keep crashing when trying to recover it. Or did I get the problem wrong?

It would be helpful to get hold of the file that makes LibO crash, could you share it?
Comment 2 Maximiliano Castañón 2010-11-18 18:31:47 UTC
Hi, this is what i get when it crash:

[maximi89@localhost gnash]$ /opt/libreoffice3/program/simpress '/home/maximi89/Documentos/mysql.odp' 

** (soffice:22972): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed
X-Error: BadAlloc (insufficient resources for operation)
	Major opcode: 53 (X_CreatePixmap)
	Resource ID:  0x15e
	Serial No:    17474 (17474)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging
Application Error/opt/libreoffice3/program/soffice: línea 125: 22972 Abortado                (`core' generado) "$sd_prog/$sd_binary" "$@"



it happens when i open the same crashed file... it doesn't matter where are it from, it's just a random file.
Comment 3 Maximiliano Castañón 2010-11-18 18:36:41 UTC
it crash one time it's loading the file, after the file recovery, when it start loading the file it crash.
Comment 4 Katarina Behrens 2010-12-07 02:18:21 UTC
Can you perhaps attach the document causing the crash?
Comment 5 Maximiliano Castañón 2010-12-07 09:03:07 UTC
Created attachment 40874 [details]
file
Comment 6 Katarina Behrens 2010-12-09 03:07:19 UTC
Now that the problematic doc is attached -- Thorsten, can you please take care of this one?
Comment 7 Roman Eisele 2012-05-03 05:54:38 UTC
This is a Impress bug, therefore changed Component accordingly.
Comment 8 Julien Nabet 2012-05-11 22:43:48 UTC
On pc debian x86-64, with 3.5 branch updated today, I don't reproduce the crash.

Do you still have this problem with 3.5.3 ?
Comment 9 Maximiliano Castañón 2012-05-12 10:10:14 UTC
Hi, actually it doesn't affects me, no crash no fail, but using a newer version.

Thanks
Comment 10 Julien Nabet 2012-05-12 12:49:36 UTC
Ok since you don't reproduce it anymore with this new version, I'll put the status to RESOLVED/WORKSFORME.

Thank you for your feedback.