Bug 31702 - Extensions installed from beta2 not recognised in beta3
Summary: Extensions installed from beta2 not recognised in beta3
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 01:12 UTC by Alex Thurgood
Modified: 2011-12-22 05:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Error message when trying to reinstall package (31.21 KB, image/png)
2010-11-18 01:12 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2010-11-18 01:12:53 UTC
Created attachment 40358 [details]
Error message when trying to reinstall package

I installed yesterday evening the mysql-connector extension available on the OOo extensions site into my beta2 copy of LibreOffice,via the gui tool (Extensions Manager).

The extension was installed for all users. The extension was functional (i.e. I used it to set up an ODB file and work with a connection to a mysql instance).

Today, I downloaded beta3 for Mac OSX, installed it, fired it up, went to open my ODB file and was given an error message that the connector was not installed.

Opened up the Extensions Manager gui. To my surprise, the mysql connector did not appear in the list of extensions.

Tried to reinstall the extension. Enclosed is the error message in PNG format.


I also tried to reinstall using unopkg, from the command line, both with and without sudo. The error message was the following :

ERROR: Error binding package: vnd.sun.star.expand:$UNO_SHARED_PACKAGES_CACHE/uno_packages/3IhLOI_/mysql-connector-ooo-1.0.0-macosx-intel.oxt
       Cause: an error occured during file opening

unopkg failed.



 Now, the gui Extensions Manager refuses to open for me, even when I am in the LibreOffice application GUI. Looks like the extensions cache is screwed. I haven't tested to see whether other manually installed extensions are affected in the same way, but this could be quite a serious problem.



Alex
Comment 1 Alex Thurgood 2010-11-18 02:24:36 UTC
Did some more checking. Removed the LibreOffice directory in my Mac User/Library/Application Support directory.

It turns out that most of the bundled extensions were not displayed as being installed either, because when I did the above and restarted LibO, the whole LibreOffice user directory structure was created anew and lo and behold, all of the bundled extensions appeared.

I was also able thereafter to reinstall the mysql connector.

So there is definitely a problem with take up of preceding configurations, at least insofar as extensions are concerned. One good way to displease users is to screw up their existing configurations.

Alex
Comment 2 Thorsten Behrens (CIB) 2010-11-22 09:02:28 UTC
Alex, sorry, there was some fallout due to incomplete renaming of libreoffice (e.g. for the plist) - any chance you could try a clean install of beta3, possibly with an existing OOo installation? That should definitely work.

As for this specific bug, it's a WONTFIX - the damage was done in beta1/beta2, beta3 should be correct in its behaviour.
Comment 3 Alex Thurgood 2010-11-22 09:14:52 UTC
No worries Thorsten, but I sorted it out myself, and beta 3 seems to have everything OK, so we'll leave it at that.


Alex
Comment 4 Björn Michaelsen 2011-12-22 05:36:47 UTC
Remove infoprovider from closed and resolved bugs.
Comment 5 Björn Michaelsen 2011-12-22 05:50:51 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.