Download it now!
Bug 31737 - Calc zoom in and out changes the position of images and other drawing objects
Summary: Calc zoom in and out changes the position of images and other drawing objects
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.3
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 10:22 UTC by Paulo Tavares
Modified: 2014-03-14 00:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The spreadsheet has a macro to change the student photo automatically (77.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-11-18 10:22 UTC, Paulo Tavares
Details
Screenshots where you can see images changing position (242.40 KB, application/pdf)
2010-11-19 03:13 UTC, Paulo Tavares
Details
wrong patch (1.00 KB, patch)
2014-03-13 23:37 UTC, Damien Chambe
Details
spreadsheet with Y position during zooming problem and wrong picture Y position in preview (92.00 KB, application/x-msexcel)
2014-03-13 23:39 UTC, Damien Chambe
Details
patch for correct Y picture position with zoom (490 bytes, patch)
2014-03-13 23:45 UTC, Damien Chambe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Tavares 2010-11-18 10:22:49 UTC
Created attachment 40396 [details]
The spreadsheet has a macro to change the student photo automatically

I have a spreadsheet with the photos of my students and they are anchored in a cell.

When I zoom in or out the position of the images or other drawing objects change.

This is very annoying and is a bug that doesn't happens in Go-OOo 3.2.1.

I haven't tested this in other plataforms... just Ubuntu 10.10 (32 bits)

Thanks

libo3.3 beta 3
Comment 1 Thorsten Behrens (CIB) 2010-11-18 16:39:52 UTC
Confirmed. E.g. the 'niveis por periodo' moves up and down, depending on zoom level. Kohei, please have a look.
Comment 2 Kohei Yoshida 2010-11-18 18:38:38 UTC
Sorry, I don't see what the problem is.  When I zoom in and out, the images stay where they are...
Comment 3 Kohei Yoshida 2010-11-18 18:46:51 UTC
Can you give me more detail?  Perhaps the screenshots of the images moving would be great.
Comment 4 Paulo Tavares 2010-11-19 03:13:02 UTC
Created attachment 40407 [details]
Screenshots where you can see images changing position

Please see the new attachment named screenshots.pdf.
Thank you

Screenshots where you can see images changing positions.
I didn't test this in the OOo3.3 RC
Comment 5 Kohei Yoshida 2010-11-19 07:40:06 UTC
Thanks for the screenshot.  This helps.

However, I'm still not seeing what the screenshot shows...
Comment 6 Kohei Yoshida 2010-11-19 07:41:54 UTC
Ah!

The release beta3 shows the object moving up and down.  I'm using the latest dev build which is newer than beta3, and that build doesn't exhibit the problem.

Perhaps already fixed (by Oracle)?
Comment 7 Kohei Yoshida 2010-11-19 11:34:04 UTC
This may be what fixed this:

http://cgit.freedesktop.org/libreoffice/calc/commit/?h=libreoffice-3-3&id=1a647a5e1b76e24cf250ef66dc9604e956e3112d

which comes from Oracle's Open Office code, which just missed the tag for beta 3 by one commit (!)
Comment 8 Paulo Tavares 2010-11-26 08:27:05 UTC
I've tested this in OpenOffice.org 3.3 RC6 and it's fixed.


Should I wait for the next beta/rc of libo?
Comment 9 Thorsten Behrens (CIB) 2010-11-26 11:53:48 UTC
Yes please. We're merging the OOo fixes when they become available in milestones.
Comment 10 Paulo Tavares 2010-12-07 15:15:23 UTC
Solved in LibO RC1

Best regards,
Paulo Tavares
Comment 11 Kohei Yoshida 2011-01-03 22:22:51 UTC
Setting it FIXED per comment #10.
Comment 12 sophie 2011-01-13 03:07:38 UTC
Verified - Closed - Sophie
Comment 13 Roman Eisele 2012-05-04 00:38:46 UTC
This is a Calc issue, therefore changed 'Component' accordingly.
Comment 14 Damien Chambe 2014-03-13 23:36:31 UTC
Zooming is again erratic on Libreoffice 4.1, 4.2, 4.3 on the Y axis, for pictures inside high height cells.

The fix in /sc/source/ui/view/drawview.cxx :
- if (nEndRow<1000)
+ if (nEndRow<20)

has been reverted by
http://cgit.freedesktop.org/libreoffice/core/commit/sc/source/ui/view/drawview.cxx?id=bc30ba74e880122b257cc6aa2965a79851fa4608

To reproduce :
- load Image_y_axis_zoom_preview_problem.xls
- Select the last image
- Zoom in and out, notice how the selection corners move on the Y axis
- Launch a preview, the pictures at the bottom are not at the right position

If you apply the attached patch correction (done in AOO on bug #i116848#), zomming and preview are correct. 
(Tested on linux 64 , libreoffice 4.3.0.0.alpha0+ Build ID: ccd765079ae573d24ded2a07ec434e4e89b619a2 )

Note that on the spreadsheet ERROR-1.ods attached in the bug, the problem is not visible, with or without the correction.
You should have huge cell height, and anchored picture fit inside. More the cell is far from the top, more the problem is visible.
Comment 15 Damien Chambe 2014-03-13 23:37:28 UTC
Created attachment 95757 [details]
wrong patch
Comment 16 Damien Chambe 2014-03-13 23:39:19 UTC
Created attachment 95760 [details]
spreadsheet with Y position during zooming problem and wrong picture Y position in preview
Comment 17 Damien Chambe 2014-03-13 23:44:03 UTC
Comment on attachment 95757 [details]
wrong patch

>Zooming is again erratic on Libreoffice 4.1, 4.2, 4.3 on the Y axis, for pictures inside high height cells.
>
>The fix in /sc/source/ui/view/drawview.cxx :
>- if (nEndRow<1000)
>+ if (nEndRow<20)
>
>has been reverted by
>http://cgit.freedesktop.org/libreoffice/core/commit/sc/source/ui/view/drawview.cxx?id=bc30ba74e880122b257cc6aa2965a79851fa4608
>
>To reproduce :
>- load Image_y_axis_zoom_preview_problem.xls
>- Select the last image
>- Zoom in and out, notice how the selection corners move on the Y axis
>- Launch a preview, the pictures at the bottom are not at the right position
>
>If you apply the correction done in AOO on bug #i116848#, zomming and preview are correct. 
>(Tested on linux 64 , libreoffice 4.3.0.0.alpha0+ Build ID: ccd765079ae573d24ded2a07ec434e4e89b619a2 )
>
>Note that on the spreadsheet ERROR-1.ods attached in the bug, the problem is not visible, with or without the correction.
>You should have huge cell height, and anchored picture fit inside. More the cell is far from the top, more the problem is visible.
Comment 18 Damien Chambe 2014-03-13 23:45:06 UTC
Created attachment 95761 [details]
patch for correct Y picture position with zoom
Comment 19 Kohei Yoshida 2014-03-14 00:08:47 UTC
NEVER reopen a bug report against such an old version.  Please file a brand new bug.