Download it now!
Bug 31746 - Text boxes of background DRAWING object in particular documents not visible
Summary: Text boxes of background DRAWING object in particular documents not visible
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 18:45 UTC by mhonline
Modified: 2013-07-22 10:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
not reproducible (302.73 KB, application/vnd.oasis.opendocument.text)
2010-11-22 03:54 UTC, Rainer Bielefeld Retired
Details
layer fehler (23.85 KB, application/vnd.oasis.opendocument.text)
2010-11-22 18:04 UTC, mhonline
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mhonline 2010-11-18 18:45:58 UTC
writer-file from any older ooo-version, that has a drawing object in the background, will not display that object.
Workaround: find it with the navigator - bring it to front - select it again and bring it to back: now it works as expected, it is visible and text-object can be set in front of these grafics. 

(same bug in OOO 3.3)

mh
Comment 1 Don't use this account, use tml@iki.fi 2010-11-19 03:11:27 UTC
Please provide a sample document exhibiting the behaviour.
Comment 2 Rainer Bielefeld Retired 2010-11-22 03:45:02 UTC
[Unconfirmed] with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]", picture and Draw element in attached sample.odt (created with OOo 3.1.1) visible when opened with LibO.

@mhonline:
Please read hints on <http://wiki.documentfoundation.org/BugReport> and contribute required information!
Comment 3 Rainer Bielefeld Retired 2010-11-22 03:54:26 UTC
Created attachment 40476 [details]
not reproducible
Comment 4 mhonline 2010-11-22 17:50:00 UTC
same as ooo issue 115539

mh
Comment 5 mhonline 2010-11-22 18:04:55 UTC
Created attachment 40489 [details]
layer fehler
Comment 6 mhonline 2010-12-06 19:21:25 UTC
as you may already found out, the attached file 
-- was original made with OOO 3.0 or earlier (meaning ODF 1.0)
-- the attached file is from the automated conversation to ODF 1.1

Why that here?
Because the attached file worked (somehow)
But when I opened an older file (same form, but untouched in ooo 3.1 or later), the grafical object is neither visible in the navigator nor seriuosly clickable. 
not that good

Martin
Comment 7 Rainer Bielefeld Retired 2011-10-09 09:24:49 UTC
@mhonline
I still can't see any problem. I can open your "layer fehler" document with all my LibO and OOo versions without problems, it contains a DRAWING object showing some kind of "Table lines" in the background, no problem at all.

Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (especially BugReport Details)!
Comment 8 Rainer Bielefeld Retired 2011-10-09 10:01:31 UTC
My mistake!
[Reproducible] with reporter's sample "layer fehler" and "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]":

1. open document
2. Select background Drawing object in Navigator
3. Right click to any element in Drawing object
4. Context Menu 'Wrap -> Through' (old was "Background"
   Expected: Nothing happens
   Actual: many text boxes appear.

Same in Master build.

Works fine with OOo 3.1.1
Comment 9 Rainer Bielefeld Retired 2011-10-09 10:06:33 UTC
No Idea how to create a sample with OOo 3.1.1

@mhonline:
Any Idea how to create a sample from the scratch?

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 10 mhonline 2011-10-10 19:09:39 UTC
@Rainer

no idea.
And that file is crashing LO 3.4.3 too, when you hit discard changes

As the file-structur is really different in new and old ODF, I am quite sure it is the process doing the transformation to the new object-order. (the idea, but I am no coder) 

m.
Comment 11 Björn Michaelsen 2011-12-23 13:26:04 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 12 Julien Nabet 2012-05-11 22:51:42 UTC
To give an update, on pc Debian x86-64, with 3.5 branch and master (both updated today and each time by reinit LO profile), I reproduced the same problem by following Rainer's comment 8.
Comment 13 Julien Nabet 2013-07-22 10:25:20 UTC
On pc Debian x86-64 with 4.0.3 Debian package, I don't reproduce this.
I put it as WFM.

mhonline: if you still reproduce this with a newer LO version (3.6.6 or 4.0.4 for example), don't hesitate to reopen this tracker.