Download it now!
Bug 31794 - [FILEOPEN] Crash on *.ppt opening
Summary: [FILEOPEN] Crash on *.ppt opening
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: All All
: high major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-20 11:40 UTC by luk3Z
Modified: 2013-11-23 13:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ppt part1 (900.00 KB, application/x-rar-compressed)
2010-11-21 11:01 UTC, luk3Z
Details
ppt part2 (900.00 KB, application/x-rar-compressed)
2010-11-21 11:18 UTC, luk3Z
Details
ppt part3 (900.00 KB, application/x-rar-compressed)
2010-11-21 11:21 UTC, luk3Z
Details
ppt part4 (76.51 KB, application/x-rar-compressed)
2010-11-21 11:23 UTC, luk3Z
Details
test data part1 (976.56 KB, application/gzip)
2010-11-28 23:29 UTC, Yifan Jiang
Details
test data part2 (976.56 KB, application/gzip)
2010-11-28 23:30 UTC, Yifan Jiang
Details
test data part3 (951.03 KB, application/gzip)
2010-11-28 23:31 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luk3Z 2010-11-20 11:40:35 UTC
-Windows XP SP3 (32 bit)
-Crash on *.ppt opening
-OpenOffice RC5 works fine (not crash)

Screen:
http://yfrog.com/2g314vj
Comment 1 Rainer Bielefeld Retired 2010-11-21 00:16:39 UTC
A Crash is not a minor problem!
Error message 'instruction at "0x7c9109d8" ... "0xfffffff"' looks similar to the one of Bug 31494, but it's not identical.

@luk3Z:
Please attach a sample document and contribute a detailed step by step instruction!
Do you see that crash with all .ppt documents or only with particular ones?
Comment 2 luk3Z 2010-11-21 07:43:51 UTC
(In reply to comment #1)
> A Crash is not a minor problem!
> Error message 'instruction at "0x7c9109d8" ... "0xfffffff"' looks similar to
> the one of Bug 31494, but it's not identical.
> 
> @luk3Z:
> Please attach a sample document and contribute a detailed step by step
> instruction!
> Do you see that crash with all .ppt documents or only with particular ones?

Ok, currently problem looks like this:
1) ppt file crash
2) crash on exit LO (probably similar to bug 31494) 'instruction at "0x7c9109d8" ... "0xfffffff"'

ppt file:
http://rapidshare.com/files/432242657/SSL_VPN_Basics.7z

- file not even opening at 2 click (crash + exit LO)
- LO Impress progess bar on the bottom stop with 75% on File -> Open, but application don't hang/crash
Comment 3 Rainer Bielefeld Retired 2010-11-21 08:38:23 UTC
@luk3Z:
If it's not too big, please attach your sample here in the issue using 'Add an attachment'. From RapidShare I get message "Please stop flooding our download servers" and can'd ownload.
Comment 4 luk3Z 2010-11-21 10:10:02 UTC
(In reply to comment #3)
> @luk3Z:
> If it's not too big, please attach your sample here in the issue using 'Add an
> attachment'. From RapidShare I get message "Please stop flooding our download
> servers" and can'd ownload.

I have error when I trying to add attachments but I try upload again without archive.
I also can't dowload it from rapidshare as free user msg appears "This is usually a temporary problem and can be solved by retrying the same URL at a later time or by becoming a RapidPro-user."
Comment 5 luk3Z 2010-11-21 11:01:22 UTC
Created attachment 40461 [details]
ppt part1
Comment 6 luk3Z 2010-11-21 11:18:20 UTC
Created attachment 40462 [details]
ppt part2
Comment 7 luk3Z 2010-11-21 11:21:34 UTC
Created attachment 40463 [details]
ppt part3
Comment 8 luk3Z 2010-11-21 11:23:59 UTC
Created attachment 40464 [details]
ppt part4
Comment 9 Rainer Bielefeld Retired 2010-11-26 08:10:09 UTC
@luk3Z:
No Idea what to do with those attachment noshes
Please send the document by email to me with additional instruction how to reproduce the crash.
Comment 10 Yifan Jiang 2010-11-28 23:29:39 UTC
Created attachment 40625 [details]
test data part1
Comment 11 Yifan Jiang 2010-11-28 23:30:26 UTC
Created attachment 40626 [details]
test data part2
Comment 12 Yifan Jiang 2010-11-28 23:31:15 UTC
Created attachment 40627 [details]
test data part3
Comment 13 Yifan Jiang 2010-11-29 00:02:59 UTC
I got the file re-attached here, test data part1/par2/part3. They were divided by raw split. Just 'cat' all of them to a tar.gz file.

The 'open ppt crash' problem *intermittently* happened on LibO 3.3 beta3 on SLED 11 sp1, but *always* Windows build could not open the file.

I didn't reproduce once on Novell LibO 3.3 beta3 build.

Namely, In most of time the file can be opened successfully on Linux build, but Windows build can never open it.

When it crashes once on my sled 11 sp1, I ever caught a crash here:

Program received signal SIGSEGV, Segmentation fault.
0xb7e4a4d7 in osl_getFileStatus ()
   from /opt/libreoffice/program/../basis-link/ure-link/lib/libuno_sal.so.3
Comment 14 Yifan Jiang 2010-11-29 00:06:22 UTC
Would Thorsten please take this? Thanks~

It looks more like a 'hang' on Windows since I saw the Impress 'Power Point Import' progress bar always sticks to about 70% when trying to open the file.
Comment 15 Thorsten Behrens (CIB) 2010-11-29 02:55:52 UTC
Hm. No crash here, but a suspicious valgrind warning:

==12550==  Address 0x284a9dbb is 715 bytes inside a block of size 32,008 alloc'd
==12550==    at 0x4C26C3A: malloc (in /usr/lib64/valgrind/vgpreload_memcheck-amd64-linux.so)
==12550==    by 0x6F665F6: cppu::idefaultConstructElements(_sal_Sequence**, _typelib_TypeDescriptionReference*, int, int, int) (in /builds/oobuild/ooo-build-pristine-git/build/install/ure/lib/libuno_cppu.so.3)
==12550==    by 0x6F695AA: uno_type_sequence_construct (in /builds/oobuild/ooo-build-pristine-git/build/install/ure/lib/libuno_cppu.so.3)
==12550==    by 0x69D5CBF: comphelper::OStorageHelper::CopyInputToOutput(com::sun::star::uno::Reference<com::sun::star::io::XInputStream> const&, com::sun::star::uno::Reference<com::sun::star::io::XOutputStream> const&) (in /builds/oobuild/ooo-build-pristine-git/build/libreoffice-3.2.99.2/comphelper/unxlngx6.pro/lib/libcomphelp4gcc3.so)
==12550==    by 0x6963E03: comphelper::EmbeddedObjectContainer::InsertGraphicStream(com::sun::star::uno::Reference<com::sun::star::io::XInputStream> const&, rtl::OUString const&, rtl::OUString const&) (in /builds/oobuild/ooo-build-pristine-git/build/libreoffice-3.2.99.2/comphelper/unxlngx6.pro/lib/libcomphelp4gcc3.so)
==12550==    by 0x696D908: comphelper::EmbeddedObjectContainer::StoreAsChildren(unsigned char, unsigned char, com::sun::star::uno::Reference<com::sun::star::embed::XStorage> const&) (in /builds/oobuild/ooo-build-pristine-git/build/libreoffice-3.2.99.2/comphelper/unxlngx6.pro/lib/libcomphelp4gcc3.so)
==12550==    by 0x783D808: SfxObjectShell::SaveAsChildren(SfxMedium&) (objstor.cxx:3220)
==12550==    by 0x782EA3A: SfxObjectShell::SaveAs(SfxMedium&) (objstor.cxx:192)
==12550==    by 0x2904B4B3: ScDocShell::SaveAs(SfxMedium&) (in /builds/oobuild/ooo-build-pristine-git/build/libreoffice-3.2.99.2/sc/unxlngx6.pro/lib/libsclx.so)
==12550==    by 0x783D383: SfxObjectShell::SaveAsOwnFormat(SfxMedium&) (objstor.cxx:3159)
==12550==    by 0x78375A1: SfxObjectShell::DoSaveObjectAs(SfxMedium&, unsigned char) (objstor.cxx:1935)
==12550==    by 0x788F165: SfxBaseModel::storeToStorage(com::sun::star::uno::Reference<com::sun::star::embed::XStorage> const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) (sfxbasemodel.cxx:3516)
Comment 16 david 2011-02-02 04:26:18 UTC
I have the same problem on Linux. Opening .odp files is not a problem but opening .ppt files is. It seems to be a problem with the ppt importer plugin.

Weirdly enough, the ppt opened fine for me a while ago. Only after I opened it with PPTVIEW.exe (using wine) did some instance of OpenOffice 3.2 report that the file was locked. (Note: Libre 3.3 does not report that.) Both versions then crashed while importing the ppt (progress bar gets up to approx. 30%)

The relevant parts seem to be somewhere in here:

[pid 16351] getcwd("/home/kwisatz/Documents/Beesecure/BeeSecure_V1.5", 4096) = 49
[pid 16351] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=110592, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis-link", {st_mode=S_IFLNK|0777, st_size=8, ...}) = 0
[pid 16351] readlink("/usr/lib/libreoffice/basis-link", "basis3.3", 4095) = 8
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/program", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/ure-link", {st_mode=S_IFLNK|0777, st_size=9, ...}) = 0
[pid 16357] <... futex resumed> )       = -1 ETIMEDOUT (Connection timed out)
[pid 16355] <... poll resumed> )        = 0 (Timeout)
[pid 16351] readlink("/usr/lib/libreoffice/basis3.3/ure-link",  <unfinished ...>
[pid 16355] poll([{fd=28, events=POLLIN}], 1, 1000 <unfinished ...>
[pid 16357] futex(0x1983b60, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 16357] futex(0x1983b34, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 255, {1296649424, 269016000}, ffffffff <unfinished ...>
[pid 16351] <... readlink resumed> "../../ure", 4095) = 9
[pid 16351] lstat("/usr/lib/ure", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib/libuno_cppu.so.3", {st_mode=S_IFREG|0644, st_size=192912, ...}) = 0
[pid 16351] open("/tmp/sv2ed.tmp/sv2in.tmp", O_RDWR) = 38
[pid 16351] fstat(38, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
[pid 16351] fcntl(38, F_SETLK, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0}) = 0
[pid 16351] pwrite(38, "\211PNG\r\n\32\n\0\0\0\rIHDR\0\0\1=\0\0\1 \10\6\0\0\0\306\323\244"..., 28713, 0) = 28713
[pid 16351] close(38)                   = 0
[pid 16351] umask(077)                  = 022
[pid 16351] open("/tmp/sv2ed.tmp", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = 38
[pid 16351] umask(022)                  = 077
[pid 16351] close(38)                   = 0
[pid 16351] umask(077)                  = 022
[pid 16351] open("/tmp/sv2ed.tmp/sv2io.tmp", O_RDWR|O_CREAT|O_EXCL, 0666) = 38
[pid 16351] fstat(38, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
[pid 16351] fcntl(38, F_SETLK, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0}) = 0
[pid 16351] umask(022)                  = 077
[pid 16351] close(38)                   = 0
[pid 16351] open("/tmp/sv2ed.tmp", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = 38
[pid 16351] close(38)                   = 0
[pid 16351] open("/tmp/sv2ed.tmp/sv2io.tmp", O_RDONLY) = 38
[pid 16351] fstat(38, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
[pid 16351] close(38)                   = 0
[pid 16351] getcwd("/home/kwisatz/Documents/Beesecure/BeeSecure_V1.5", 4096) = 49
[pid 16351] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=110592, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis-link", {st_mode=S_IFLNK|0777, st_size=8, ...}) = 0
[pid 16351] readlink("/usr/lib/libreoffice/basis-link", "basis3.3"..., 4095) = 8
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/program", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/ure-link", {st_mode=S_IFLNK|0777, st_size=9, ...}) = 0
[pid 16351] readlink("/usr/lib/libreoffice/basis3.3/ure-link", "../../ure"..., 4095) = 9
[pid 16351] lstat("/usr/lib/ure", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib/libuno_cppu.so.3", {st_mode=S_IFREG|0644, st_size=192912, ...}) = 0
[pid 16351] open("/tmp/sv2ed.tmp/sv2io.tmp", O_RDWR) = 38
[pid 16351] fstat(38, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
[pid 16351] fcntl(38, F_SETLK, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0}) = 0
[pid 16351] pread(38, "", 4096, 0)      = 0
[pid 16351] open("/tmp/sv2ed.tmp", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = 39
[pid 16351] close(39)                   = 0
[pid 16351] open("/tmp/sv2ed.tmp/sv2in.tmp", O_RDONLY) = 39
[pid 16351] fstat(39, {st_mode=S_IFREG|0600, st_size=28713, ...}) = 0
[pid 16351] close(39)                   = 0
[pid 16351] getcwd("/home/kwisatz/Documents/Beesecure/BeeSecure_V1.5", 4096) = 49
[pid 16351] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=110592, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis-link", {st_mode=S_IFLNK|0777, st_size=8, ...}) = 0
[pid 16351] readlink("/usr/lib/libreoffice/basis-link", "basis3.3", 4095) = 8
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/program", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
[pid 16351] lstat("/usr/lib/libreoffice/basis3.3/ure-link", {st_mode=S_IFLNK|0777, st_size=9, ...}) = 0
[pid 16351] readlink("/usr/lib/libreoffice/basis3.3/ure-link", "../../ure", 4095) = 9
[pid 16351] lstat("/usr/lib/ure", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 16351] lstat("/usr/lib/ure/lib/libuno_cppu.so.3", {st_mode=S_IFREG|0644, st_size=192912, ...}) = 0
[pid 16351] open("/tmp/sv2ed.tmp/sv2in.tmp", O_RDWR) = 39
[pid 16351] fstat(39, {st_mode=S_IFREG|0600, st_size=28713, ...}) = 0
[pid 16351] fcntl(39, F_SETLK, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0}) = 0
[pid 16351] pread(39, "\211PNG\r\n\32\n\0\0\0\rIHDR\0\0\1=\0\0\1 \10\6\0\0\0\306\323\244"..., 28713, 0) = 28713
[pid 16351] close(39)                   = 0
[pid 16351] pwrite(38, "GRF5\1\0001\0\0\0\1\0\0\0\0\0\0\0=\1\0\0 \1\0\0\1\0\33\0\0\0"..., 4096, 0) = 4096
[pid 16351] pwrite(38, "\307\304\353\272J\5\267<\23`R\237\27W\235\30\305\221\243t\250\232\345\370(\300\371Hu\366{\231"..., 24743, 4096) = 24743
[pid 16351] pread(38, "GRF5\1\0001\0\0\0\1\0\0\0\0\0\0\0=\1\0\0 \1\0\0\1\0\33\0\0\0"..., 4096, 0) = 4096
[pid 16351] pwrite(38, "GRF5\1\0001\0\0\0\1\0\0\0lp\0\0=\1\0\0 \1\0\0\1\0\33\0\0\0"..., 4096, 0) = 4096
[pid 16351] close(38)                   = 0
[pid 16351] pread(27, "\4\0\0\0\0\0\0\0\37\0D\361\374\t\0\0\0\0'\361 \0\0\0\0\0\0\0\3\0\0\0"..., 4096, 12792320) = 4096
[pid 16351] open("/usr/lib/libreoffice/program/../basis-link/program/libexlinkli.so", O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 16351] open("/usr/lib/libreoffice/program/../basis-link/program/libanimcore.so", O_RDONLY) = 38
[pid 16351] read(38, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\20\21\1\0\0\0\0\0"..., 832) = 832
[pid 16351] fstat(38, {st_mode=S_IFREG|0644, st_size=180312, ...}) = 0
[pid 16351] mmap(NULL, 2275840, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 38, 0) = 0x7f6fe6fc2000
[pid 16351] mprotect(0x7f6fe6fe9000, 2093056, PROT_NONE) = 0
[pid 16351] mmap(0x7f6fe71e8000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 38, 0x26000) = 0x7f6fe71e8000
[pid 16351] close(38)                   = 0
[pid 16351] open("/usr/lib/libreoffice/program/../basis-link/program/libexlinkli.so", O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 16351] open("/usr/lib/libreoffice/program/../basis-link/program/libexlinkli.so", O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 16351] open("/usr/lib/libreoffice/program/../basis-link/program/libexlinkli.so", O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 16351] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Comment 17 Thorsten Behrens (CIB) 2011-03-25 09:00:56 UTC
Re-tested with 3.2.2 on Linux & Windows, no hang, loads flawlessly - closing, please feel free to re-open with additional info, if this still happens for you.