Download it now!
Bug 31812 - Compatibility>Key bindings needs to be more descriptive
Summary: Compatibility>Key bindings needs to be more descriptive
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: Other All
: medium enhancement
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.0.0.beta2 target:3.7.0
Keywords:
: 39143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-21 06:09 UTC by Ed
Modified: 2012-08-03 09:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2010-11-21 06:09:31 UTC
Under Tools>Options>LibreOffice Calc>Compatibility the user is asked to "select desired key binding type" from the non-descriptive headings of "Default" and "OpenOffice.org Lagacy".  Nowhere is there any indication of what either of these options actually do.

This option page needs to tell the user:

1.  Which keybindings this setting will change
2.  What these keybindings will be set to for each option

There is currently plenty of empty space available for this information.
Comment 1 Kohei Yoshida 2010-11-21 07:54:42 UTC
I agree that we need to provide more information about this.  My hope is that once we get the on-line help organized we'll add that information there.

We don't want to add that info on the Options page itself, because the page will contain more compatibility options later on, so this page is not just for the key binding compatibility.  Also, the list of affected key bindings will likely grow in the future.

For now, please refer to the blog post of mine

http://kohei.us/2010/10/15/key-binding-compatibility-options-take-2/

for which key bindings are affected.
Comment 2 Ed 2010-11-21 13:23:06 UTC
Online help is not the answer.

The first place any user will look for information about a setting that is not self-explanatory is the built-in help file.  As a minimum there needs to be an explanation of what this setting does there.
Comment 3 Kohei Yoshida 2010-11-21 14:02:44 UTC
(In reply to comment #2)
> The first place any user will look for information about a setting that is not
> self-explanatory is the built-in help file.  

Yes, what you refer to as the "built-in" help is what we call "on-line" help.  I believe we are on the same page here.
Comment 4 Ed 2010-11-21 14:22:17 UTC
"on-line" generally means something accessed via the internet, not the help files that are installed on the user's own machine when they install the software.
Comment 5 Kohei Yoshida 2010-11-21 16:00:42 UTC
Yes, I understand that.  But believe or not, that thing is also referred to as the "on-line" help.  I'm not responsible for the naming, so let's not argue this.
Comment 6 Kohei Yoshida 2010-11-24 08:59:58 UTC
Re-assigning this to David Nelson.  This pertains to documentation.
Comment 7 David Nelson 2010-11-24 10:16:50 UTC
OK, I will discuss this issue with documentation team members and we will propose/implement a solution. I'm tracking this issue.
Comment 8 Not Assigned 2012-06-15 07:40:13 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7e897801c7909aa165e9f8ac181378061a8f0e12&g=libreoffice-3-6

fdo#31812 add help for Tools - Options - Libreoffice Calc - Compatibility


It will be available in LibreOffice 3.6.
Comment 9 Not Assigned 2012-06-15 07:40:41 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=dd5911a782678cff44b87f2dfaca71723ea72144

fdo#31812 add help for Tools - Options - Libreoffice Calc - Compatibility
Comment 10 Andras Timar 2012-06-24 04:35:06 UTC
*** Bug 39143 has been marked as a duplicate of this bug. ***
Comment 11 Rainer Bielefeld Retired 2012-08-03 09:14:25 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.