Download it now!
Bug 31820 - Windows installer: unopkg.bin error during the end of the setup with DATA env var set
Summary: Windows installer: unopkg.bin error during the end of the setup with DATA env...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: Other Windows (All)
: low normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 10:16 UTC by Cesare Leonardi
Modified: 2012-05-30 13:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the error (40.60 KB, image/jpeg)
2010-11-21 10:16 UTC, Cesare Leonardi
Details
Screenshot of error on windows 7 x64 Russian (38.08 KB, image/jpeg)
2010-12-09 22:06 UTC, Igor Kovalyov
Details
Applications start error after setup with disabled "Optional components" (15.10 KB, image/jpeg)
2011-01-11 00:36 UTC, Igor Kovalyov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cesare Leonardi 2010-11-21 10:16:47 UTC
Created attachment 40457 [details]
Screenshot of the error

There's a null pointer somewhere.
See the attachment.

In english should be:
-----
unopkg.bin - Application error

The instruction at "0x7ceab159" reference memory at "0x00000000". The memory could not be "read". Click OK to terminate the program.
-----

This error doesn't interrupt the setup: in fact the final installer windows and the error are indipendent and they can be closed indipendently.
The platform is Windows 2000 Pro SP4 italian.

Cesare.
Comment 1 Don't use this account, use tml@iki.fi 2010-11-24 07:38:47 UTC
Can not reproduce in my Windows 2000 (English).

Is there anything special about your Windows 2000 machine, except it being Italian? Presumably it is a quite old installation of Windows 2000, with much software accumulated during the years? Do you have lots of additional 3rd-party "helpful" software running in the background that might be involved in the unopkg.bin problem, like desktop enhancements etc? Virus scanners? Have you tried without such?
Comment 2 Cesare Leonardi 2010-11-24 14:14:33 UTC
(In reply to comment #1)
> Presumably it is a quite old installation of Windows 2000, with much
> software accumulated during the years?

Yes, it's the pc i'm using at work, and the os installation is probably older than 6 year and have frequently seen many application install/uninstall. But i take care of it, keep updated, cleaned and healty.

> Do you have lots of additional 3rd-party
> "helpful" software running in the background that might be involved in the
> unopkg.bin problem, like desktop enhancements etc? Virus scanners? Have you
> tried without such?

The only application that, i think, can have some influence, is the Avast Pro antivirus.
In the next days (probably during next week) i'll try to install LO on another more basic Win2000 pc, without antivirus, and i will post here the results.

Thank you for your work.

Cesare.
Comment 3 Cesare Leonardi 2010-11-30 13:39:03 UTC
I've made some test.

- i've installed LO on a different PC with a very basic setup e no antivirus: the problem didn't happen;

- i've uninstalled LO and the antivirus from the PC which i talk about in this bug report, then reinstalled again: the problem is always here.

Don't know what can trigger the null pointer exception. Could it be the JRE 1.3.1 used by our laser printer? I can make some test if you think it might be worth.

Cesare.
Comment 4 Igor Kovalyov 2010-12-07 23:56:35 UTC
(In reply to comment #0)
> Created an attachment (id=40457) [details]
> Screenshot of the error
> 
> There's a null pointer somewhere.
> See the attachment.
> 
> In english should be:
> -----
> unopkg.bin - Application error
> 
> The instruction at "0x7ceab159" reference memory at "0x00000000". The memory
> could not be "read". Click OK to terminate the program.
> -----
> 
> This error doesn't interrupt the setup: in fact the final installer windows and
> the error are indipendent and they can be closed indipendently.
> The platform is Windows 2000 Pro SP4 italian.
> 
> Cesare.

I have very similar bug. The platform is Windows 7 64-bit.
LibreOffice - 3.3 rc1.

Error title is "Microsoft Visual C++ Runtime Library"
Error message is
"Runtime Error!

Program: C:\Program Files(x86)\LibreOffice 3\program\unopkg.bin

This application has requested the Runtime to terminate it in an
unusual way.
Please contact the application's support team for more information."
Openoffice 3.3 rc1 setup fails with the same bug, but Openoffice 3.2 setup works successful. 

Maybe this situation due to msvc dll-files installed in Windows by other software?
Comment 5 Don't use this account, use tml@iki.fi 2010-12-09 04:56:21 UTC
Igor, so do you see any error message as in the initial report at all?
Comment 6 Petr Mladek 2010-12-09 05:06:07 UTC
Igor, have you seen this problem also with the older LibO-3.3-betas?

unopkg.bin is needed to install extensions. It should not be necessary for the main function. Are you able to somehow use the LibO-3.3?
Are you able to install extensions from the menu Tools/Extensions Manager?

Do you have running any virus scanner?
Comment 7 Igor Kovalyov 2010-12-09 21:58:51 UTC
(In reply to comment #6)
> Igor, have you seen this problem also with the older LibO-3.3-betas?
> 
> unopkg.bin is needed to install extensions. It should not be necessary for the
> main function. Are you able to somehow use the LibO-3.3?
> Are you able to install extensions from the menu Tools/Extensions Manager?
> 
> Do you have running any virus scanner?

I did not try other LibO-3.3-betas. I can't use LibO-3.3 because after failed setup any LibO application can't run - they fails with error, so I can't run Tools/Extensions Manager because I can't start application. I have running nod32 antivirus.
Comment 8 Igor Kovalyov 2010-12-09 22:06:19 UTC
Created attachment 40978 [details]
Screenshot of error on windows 7 x64 Russian
Comment 9 Igor Kovalyov 2010-12-09 22:08:12 UTC
(In reply to comment #5)
> Igor, so do you see any error message as in the initial report at all?

I added screenshort of error in attachment "Screenshort of error on windows 7 x64 Russian".
Comment 10 Don't use this account, use tml@iki.fi 2010-12-10 01:04:47 UTC
Igor, have you tried without the nod32 antivirus running?
Comment 11 Igor Kovalyov 2010-12-10 01:29:36 UTC
(In reply to comment #10)
> Igor, have you tried without the nod32 antivirus running?

I tried with disabled nod32 antivirus.
Comment 12 Cédric Bosdonnat 2010-12-10 01:45:49 UTC
Tor, this one is for you.
Comment 13 Don't use this account, use tml@iki.fi 2010-12-10 01:48:43 UTC
And it still happened? To what extent did you disable it? It might well be that there still is some part of it active in some way if you just toggle some button in the antivirus software itself.
Comment 14 Igor Kovalyov 2010-12-10 02:11:30 UTC
(In reply to comment #13)
> And it still happened? To what extent did you disable it? It might well be that
> there still is some part of it active in some way if you just toggle some
> button in the antivirus software itself.

I just toggled button in the antivirus software itself. If it is necessary I can totally remove antivirus software from computer or exclude some folders from antivirus control. At the same computer openoffice 3.2 setups successfully with enabled antivirus. If You need I also can run process monitor before libo setup and send You process monitor's log.
Comment 15 Don't use this account, use tml@iki.fi 2010-12-10 02:18:36 UTC
Well, of course I am not certain that the antivirus is the problem, but it is just something to try...
Comment 16 Igor Kovalyov 2010-12-10 02:47:11 UTC
(In reply to comment #15)
> Well, of course I am not certain that the antivirus is the problem, but it is
> just something to try...

To run test with uninstalled antivirus I need some time. Computer is used by other person at my work. At the same time first bug reporter (Cesare Leonardi) tells that he removed antivirus software and this didn't help him. I think, in my case setup fails due to latest dll's installed on computer by Visual Studio or other software.  
May be You will do somthing in this way: libO installation with detailed log which will help to understand, what's happend. Please let me know: are You  waiting for test with uninstalled antivirus from me?
Comment 17 Don't use this account, use tml@iki.fi 2010-12-10 03:18:40 UTC
No, I am not waiting for that. (Note that I don't mean that I would be desperately trying to fix this problem already either.) If you do try the uninstallation of the antivirus, it would be a nice test, yes. Or any other *specific* information you find out would be welcome.
Comment 18 Petr Mladek 2010-12-10 07:10:31 UTC
One possibility would be to better handle the unopkg errors. IMHO, it is not critical for main LibO function, so failing unopkg should show a warning and do not block the installation.
Comment 19 Igor Kovalyov 2010-12-15 04:19:00 UTC
(In reply to comment #17)
> No, I am not waiting for that. (Note that I don't mean that I would be
> desperately trying to fix this problem already either.) If you do try the
> uninstallation of the antivirus, it would be a nice test, yes. Or any other
> *specific* information you find out would be welcome.

I get the same error on notebook with installed Windows Vista sp1 32-bit Russian with no antivirus installed.
Comment 20 Eliot the Cougar 2010-12-22 04:42:44 UTC
I don't have this problem, but I do have this kind of problem with some other programs on different systems (I've had that with Opera 10.0-11.0-alpha installers. They've fixed that now)

1. Program 1 creates some file (i.e. during installation)
2. Program 2 (usually an anti-virus) temporarily blocks read/write access to that file if it fits certain criteria (I guess, .bin extension)
3. Program 1 can't Read or Write the file and throws Exception

Normally, Program 1 should wait a second and Retry operation to check if the file in question is still blocked or not...

I guess it may also happen if the Disk I/O is overloaded at the moment of installation...
Comment 21 Don't use this account, use tml@iki.fi 2010-12-22 06:43:05 UTC
No. It can not be expected for programs to "wait and retry" if some operation fails in a way that in no way indicates that the failure would be intermittent. (Wait for what?)

If anti-virus software causes that kind of failures, it is buggy.

If anti-virus software "temporarily blocks read/write access", as you say, then it should just cause read/write requests to not return until the anti-virus software releases the file. Not cause read/write requests to fail in a way that then would need to be handled by code in user level software to "wait and retry", that would be horrible.
Comment 22 jmpierre 2010-12-23 06:17:51 UTC
Need to kill the process
Comment 23 Petr Mladek 2011-01-04 06:27:28 UTC
I am not able to reproduce it here with Windows XP.

One workaround would be to do custom installation and disable extensions. It should finally work with LO-3.3-rc2.

Tor, any chance to look where the unopkg.bin is called and handle the error, so it is not fatal?
Comment 24 Don't use this account, use tml@iki.fi 2011-01-04 06:52:45 UTC
As the initial comment says, the unopkg error doesn't affect the installation, it still proceeds. Also the source code supports this claim, looking in setup_native/source/win32/customactions/shellextensions/registerextensions.cxx the exit status of unopkg.exe (which presumably is a wrapper for unopkg.bin) is ignored.
Comment 25 Don't use this account, use tml@iki.fi 2011-01-04 06:53:58 UTC
jmpierre, could you be more verbose please if you are suggesting some code changes?
Comment 26 Petr Mladek 2011-01-06 02:53:13 UTC
Okay, the bug happens only with some strange circumstances, it does not affect the base function, so I am going to remove it from the list of LibO-3.3 blocker bugs.
Comment 27 Cesare Leonardi 2011-01-06 10:21:03 UTC
This bug doesn't happen for me anymore. Tested on rc2 (both with JRE6 installed and uninstalled) but if i recall well, i haven't seen it on rc1 too.

I'm the same of #30850, another unopkg problem.

Cesare.
Comment 28 Igor Kovalyov 2011-01-11 00:36:00 UTC
Created attachment 41870 [details]
Applications start error after setup with disabled "Optional components"
Comment 29 Igor Kovalyov 2011-01-11 00:43:29 UTC
I tested with rc2 - error is the same. So I can't install libreoffice on 4 computers, 2 of them under Windows 7 64-bit, 1 - under Windows 7 32-bit, 1 - under Windows Vista 32-bit. 
I tried to install with disabled "Optional components" options. In this case there are no errors during installation but after installation I can't run any libreoffice application - they fail's with error "... A general access error occured while accessing your central configuration.".
Comment 30 Igor Kovalyov 2011-01-11 00:44:58 UTC
PS. I attached screenshot of error"... A general access error
occured while accessing your central configuration."
Comment 31 gatocl.maipu 2011-01-13 09:30:26 UTC
In my case when the installer it's was finishing the unopkg do a something related to java.
I dont now wich is the cause but aparently many popups of a jre comprobation(in your case crash), to finish the install i have to kill the java proccess wich depend of the unopkg.bin and unopkg.exe

Perhaps related to:

https://bugs.freedesktop.org/show_bug.cgi?id=32643

https://bugs.freedesktop.org/show_bug.cgi?id=31354
https://bugs.freedesktop.org/show_bug.cgi?id=31476
https://bugs.freedesktop.org/show_bug.cgi?id=31602
Comment 32 Petr Mladek 2011-01-17 02:01:37 UTC
(In reply to comment #29)
> I tried to install with disabled "Optional components" options. In this case
> there are no errors during installation but after installation I can't run any
> libreoffice application - they fail's with error "... A general access error
> occured while accessing your central configuration.".

Hmm, it sounds too much to disable all "Optional componets". The installer has more granular tunning. You should disable just the optional extensions.
Comment 33 Igor Kovalyov 2011-01-17 03:31:23 UTC
(In reply to comment #32)
> (In reply to comment #29)
> > I tried to install with disabled "Optional components" options. In this case
> > there are no errors during installation but after installation I can't run any
> > libreoffice application - they fail's with error "... A general access error
> > occured while accessing your central configuration.".
> 
> Hmm, it sounds too much to disable all "Optional componets". The installer has
> more granular tunning. You should disable just the optional extensions.

When I disabled "Optional components" on another computer (wich don't have a problem with unopkg.bin during install) - libreoffice installed successfully and I can run Libreoffice Writer. So as I see disabling "Optional componets" on other computer allow run libreoffice applications.
At the same time computers wich have problem with unopkg.bin during install have problem running libreoffice applications with disabled "Optional componets".

I think if I have problem running libreoffice applications with disabled "Optional componets" - when I'll enable some elements from Optional components - I'll have the same error running lebreoffice applications (If program wich consist of elements have an error, it will have the same error if we will add some elements to it).
Can You explain me why to try setup with disabled optional extensions?
Comment 34 Igor Kovalyov 2011-12-21 02:30:09 UTC
Error was due to environment variable DATA. After I removed this variable and rebooted computer, LibreOffice installed successfully.
Comment 35 Roman Eisele 2012-05-24 01:35:43 UTC
This is an installation issue, therefore changed the Component field accordingly.
Comment 36 Andras Timar 2012-05-30 13:18:06 UTC
I tried to install LibreOffice 3.6 (pre-alpha0) on Windows XP, where DATA environment variable was set. Everything went OK. Either this bug has been fixed, or it cannot be triggered only by DATA environment variable (which would be surprising anyway). So I close this bug as WORKSFORME, because I cannot reproduce it, we did not get more error reports about it, and it is quite old. Please reopen, or even better file a new a bug, when you can reproduce it with a recent build. Thanks for your feedback.